F15: Gnome Extension are disable after update
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 11 of 11
  1. #1
    Join Date
    May 2010
    Posts
    33

    Unhappy F15: Gnome Extension are disable after update

    I just updated my system a few hours ago, then turn off. Now I reboot the system and all the gnome-shell-extenstion-* installed from repo are disabled. What happens?

  2. #2
    Join Date
    May 2011
    Posts
    14

    Re: F15: Gnome Extension are disable after update

    same issue here, been talking about it on #fedora and it seems some other people have it as well

    maybe some config file somewhere?

  3. #3
    Join Date
    Aug 2007
    Location
    London Postbox (the red one)
    Age
    53
    Posts
    3,868

  4. #4
    Join Date
    Dec 2010
    Posts
    32

    Re: F15: Gnome Extension are disable after update

    Same problem here. I tried to follow the instructions in the above link but didn't understand where I am supposed to replace the version number in the .json file. Can anyone be more specific?

  5. #5
    Join Date
    May 2011
    Posts
    14

    Re: F15: Gnome Extension are disable after update

    sorry to say but it didnt work. i was running 3.0.2 and i changed all of the metadata.json files to use that version number.

    interestingly, i have 5 extensions installed, but only three are present in that directory

    ---------- Post added at 04:51 PM ---------- Previous post was at 04:49 PM ----------

    Quote Originally Posted by fedoraist
    Same problem here. I tried to follow the instructions in the above link but didn't understand where I am supposed to replace the version number in the .json file. Can anyone be more specific?
    if you open the metadata.json file you should see an entry like this:

    {
    "uuid": "media@sotecware.net",
    "name": "Media",
    "description": "Some cool stuff",
    "original-author": "j.wielicki@sotecware.net",
    "shell-version": [ "3.0.2" ],
    "localedir": "/usr/share/locale",
    "url": "none"
    }

    where it says shell-version, replace that number with your gnome-shell version number

    ---------- Post added at 04:56 PM ---------- Previous post was at 04:51 PM ----------

    alright i figured it out. go to /usr/share/gnome-shell/extensions/ and find the extension in question. (for me it was all of them). edit their .json files like mentioned above. restart gnome-shell and voila.

  6. #6
    Join Date
    Aug 2007
    Location
    London Postbox (the red one)
    Age
    53
    Posts
    3,868

    Re: F15: Gnome Extension are disable after update

    Quote Originally Posted by fedoraist
    Same problem here. I tried to follow the instructions in the above link but didn't understand where I am supposed to replace the version number in the .json file. Can anyone be more specific?
    Yeh im sorry, it wasnt very clear, i get carried away sometimes anyway i have added some screenshots that will hopefully make it more clear.

    Or this command will fix all extenstions with the current bug, should of put this first really
    su -
    sed -i 's/3.0.1/3.0.2/g' /usr/share/gnome-shell/extensions/*/*.json
    Dont forget to refresh shell (alt+f2 'r' enter)

  7. #7
    Join Date
    Apr 2006
    Location
    North West UK.
    Age
    38
    Posts
    531

    Re: F15: Gnome Extension are disable after update

    You could also just grab the latest Gnome-Shell extensions rpms from koji.

    http://koji.fedoraproject.org/koji/b...buildID=245510
    - Phanteks Enthoo Luxe, Intel Core i5 6600k @ 4.4ghz, 16GB DDR4, Asus Z170-A, Nvidia GTX 970 4GB running Fedora 24 and Win 10

  8. #8
    Join Date
    May 2009
    Location
    /dev/ph
    Posts
    317

    Re: F15: Gnome Extension are disable after update

    Rather than changing the the version number from ["3.0.1"] to ["3.0.2"], a better approach is to change the version number string to ["3.0"]. Then your extensions will all work for all the 3.0.X versions of GNOME Shell.

    I have 5 extensions installed, but only three are present in that directory
    Extensions can also exist in $HOME/.local/share/gnome-shell/extensions.

    You could also just grab the latest Gnome-Shell extensions rpms from koji.
    Do not install the user-theme extension unless you using a theme selector tool such as g-t-t or themeselector. If you have to install it to get the extension theme gschema/gsetting key (which these tools use), ensure that the extension is blacklisted via the gsettings key so that it is not loaded by GNOME shell. There is a problem with that particular extension's interaction with other extension stylesheets.

  9. #9
    Join Date
    May 2005
    Posts
    3,868

    Re: F15: Gnome Extension are disable after update

    Rahul
    http://fedoraproject.org/wiki/RahulSundaram

  10. #10
    Join Date
    Apr 2011
    Posts
    188

    Re: F15: Gnome Extension are disable after update

    Quote Originally Posted by RahulSundaram
    Is the message there anything to be concerned with?:

    caillon (proventesters) - 2011-05-28 23:56:47
    Where do these sources come from? The claimed revision does not exist in upstream git. Why is this not using the released version of 3.0.2 instead of a phantom git snapshot?

  11. #11
    Join Date
    May 2005
    Posts
    3,868

    Re: F15: Gnome Extension are disable after update

    Hi

    Haven't checked git tagging but a newer upstream snapshot has always been used before tarballs were created by upstream.
    Rahul
    http://fedoraproject.org/wiki/RahulSundaram

Similar Threads

  1. [SOLVED]
    Xorg Crash on F15 after installing extension applet for GNOME 3
    By km0r3 in forum Using Fedora
    Replies: 2
    Last Post: 8th July 2011, 03:11 PM
  2. Replies: 0
    Last Post: 28th May 2011, 09:58 AM
  3. [SOLVED]
    Gnome shell crashing after removing ^user theme^ extension
    By DachaArh in forum Using Fedora
    Replies: 2
    Last Post: 27th May 2011, 04:12 PM
  4. Disable gnome update when logged into KDE
    By mgleahy in forum Using Fedora
    Replies: 2
    Last Post: 20th December 2008, 09:15 AM
  5. Replies: 0
    Last Post: 3rd February 2007, 03:35 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •