F14 RTL8192E Staging Drivers
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    Join Date
    Sep 2006
    Posts
    48
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    F14 RTL8192E Staging Drivers

    OK --I've installed the RPMFusion staging drivers for my wireless.
    I get a signal

    Output from iwconfig:

    iwconfig


    lo no wireless extensions.



    wlan0
    802.11bgn ESSID:"ThePetes"
    Mode:Managed Frequency=2.462 GHz Access Point: 00:24:01:40:0E:B6
    Bit Rate=1 Mb/s Retry:on RTS thr:off Fragment thr:off
    Power Management:off Link Quality=0/100 Signal level=0 dBm
    Noise level=0 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0



    eth0 no wireless extensions.

    output from iwlist scan

    iwlist scan


    lo Interface doesn't support scanning.


    wlan0
    Scan completed :

    Cell 01 - Address: 00:24:01:40:0E:B6 ESSID:"ThePetes"
    Protocol:IEEE802.11g Mode:Master Channel:11
    Encryption key:off Bit Rates:54 Mb/s
    Extra: Rates (Mb/s): 1 2 5.5 11 6 9 12 18 24 36 48 54
    Quality=76/100 Signal level=-60 dBm Noise level=-108 dBm
    Extra: Last beacon: 8ms ago



    eth0 Interface doesn't support scanning.


    I still can't connect to the network.
    What am I missing---a setting? a configuration?

    iwlist scan shows a 76/100 signal

    iwconfig shows 0/100 signal

    I'm stumped

    fnshman

  2. #2
    Join Date
    Sep 2006
    Posts
    48
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F14 RTL8192E Staging Drivers

    Update---automatically connected when first logged in, but only stayed connected for a couple minutes. Haven't connected since. Also haven't made any changes since the first post. Must be a conflict with something.

  3. #3
    Join Date
    Sep 2006
    Posts
    48
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F14 RTL8192E Staging Drivers

    Going to try uninstalling drivers and then reinstalling them. No time today though---will keep everyone updated as to progress.

  4. #4
    Join Date
    Sep 2006
    Posts
    48
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F14 RTL8192E Staging Drivers

    OK---VERY strange---uninstalled then reinstalled drivers. Same results as before. gave up for a few days. just booted up Fedora and watching the startup screen, my wlan0 connected!!!! and so far is still connected. The only thing I've done different is to turn off the wireless for my second access point. must have been confused as to which one to connect to even though I configured each to a specific MAC address. OH well--it's working and that's all I care about.
    Just a note two access points with the same SSID may have confused it as well. The two AP's worked well in Windblows 7 Home Premium64. Go figure??

  5. #5
    Join Date
    Sep 2006
    Posts
    48
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F14 RTL8192E Staging Drivers

    OK---Here we go again. Wireless works VERY sporadically. Upon a Google search, I am finding this driver works when it feels like it. After a fresh install of F15 and updating to the latest kernel, (2.6.38.7-30), I get this from dmesg.

    dmesg |grep disabling

    [ 0.289734] pnp 00:02: disabling [mem 0xf0503900-0xf0503bff] because it overlaps 0000:00:09.0 BAR 14 [mem 0xf0500000-0xf05fffff]

    [ 0.290558] pnp 00:09: disabling [io 0x0022-0x0023] because it overlaps 0000:02:00.0 BAR 0 [io 0x0000-0x00ff]

    [ 0.290563] pnp 00:09: disabling [io 0x002e-0x002f] because it overlaps 0000:02:00.0 BAR 0 [io 0x0000-0x00ff]

    [ 0.290567] pnp 00:09: disabling [io 0x0068] because it overlaps 0000:02:00.0 BAR 0 [io 0x0000-0x00ff]

    [ 0.290571] pnp 00:09: disabling [io 0x006c] because it overlaps 0000:02:00.0 BAR 0 [io 0x0000-0x00ff]

    [ 0.290575] pnp 00:09: disabling [io 0x0072-0x0073] because it overlaps 0000:02:00.0 BAR 0 [io 0x0000-0x00ff]

    [ 0.290579] pnp 00:09: disabling [io 0x0080-0x0081] because it overlaps 0000:02:00.0 BAR 0 [io 0x0000-0x00ff]

    [ 0.290583] pnp 00:09: disabling [io 0x00b0-0x00b1] because it overlaps 0000:02:00.0 BAR 0 [io 0x0000-0x00ff]

    [ 0.290587] pnp 00:09: disabling [io 0x0092] because it overlaps 0000:02:00.0 BAR 0 [io 0x0000-0x00ff]

    [ 0.290592] pnp 00:09: disabling [io 0x00b2-0x00bf] because it overlaps 0000:02:00.0 BAR 0 [io 0x0000-0x00ff]

    and this from lspci


    lspci output

    00:09.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 4)


    02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8192E Wireless LAN Controller (rev 01)

    Is this supposed to disable at boot, or is there a bug in the kernel causing the problem?
    I also get firmware initialization failures, but I'll have to reboot into F15 to get the exact message---in Windblows7 now. Will post those lines later.

    ---------- Post added at 12:15 PM ---------- Previous post was at 10:22 AM ----------

    The output from Dmesg for rtl8192e drv

    [ 0.000000] PERCPU: Embedded 28 pages/cpu @ffff8800b7c00000 s83200 r8192 d23296 u1048576
    [ 0.000000] pcpu-alloc: s83200 r8192 d23296 u1048576 alloc=1*2097152
    [ 17.617103] Linux kernel driver for RTL8192 based WLAN cards
    [ 17.617160] rtl819xE 0000:02:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
    [ 17.617168] rtl819xE 0000:02:00.0: setting latency timer to 64
    [ 55.548042] rtl819xE:ERR in CPUcheck_firmware_ready()
    [ 55.548059] rtl819xE:ERR in init_firmware()
    [ 55.548073] rtl819xE:ERR!!! NicIFEnableNIC(): initialization is failed!
    [ 85.546060] rtl819xE:ERR in CPUcheck_firmware_ready()
    [ 85.546080] rtl819xE:ERR in init_firmware()
    [ 85.546094] rtl819xE:ERR!!! NicIFEnableNIC(): initialization is failed!

    also get MANY lines of this

    [ 85.557084] rtl819xE:No more TX desc@6, ring->idx = 0,idx = 0,52

Similar Threads

  1. Replies: 3
    Last Post: 7th January 2011, 05:21 PM
  2. F14 - RTL8192 staging drivers firmware problem
    By WillKemp in forum Hardware & Laptops
    Replies: 0
    Last Post: 8th November 2010, 05:05 AM
  3. Getting RTL8192E Wireless Working
    By sportscrazed2 in forum Hardware & Laptops
    Replies: 1
    Last Post: 2nd July 2010, 05:02 PM
  4. rtl8192e staging drivers
    By fnshman in forum Hardware & Laptops
    Replies: 24
    Last Post: 30th April 2010, 02:37 AM
  5. rtl8192e wireless problem
    By fnshman in forum Servers & Networking
    Replies: 2
    Last Post: 23rd February 2010, 06:35 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •