x86_64 livecd: no login screen, gnome-shell, or gnome-fallback at boot
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    Join Date
    Apr 2011

    x86_64 livecd: no login screen, gnome-shell, or gnome-fallback at boot

    Hello everyone. I'm a new linux user who decided to try out the F15 beta livecd (x86_64) to try out both Fedora and Gnome-shell. However, there seems to be a problem. The livecd loads and boots fine, up until where the fedora logo is filled up, but my screen subsequently displays the default desktop wallpaper and nothing else. It just stays that way - no GDM login and no gnome-shell or gnome-fallback. Rebooting X with Ctrl-Alt-Backspace doesn't help. Pressing alt-F2 fades the screen slightly and pressing ESC returns it to how it was, so there has to be something taking input, but nothing else appears. Interestingly, the right edge of the screen is a border for the cursor, but the cursor can disappear beyond the left edge of the screen.

    I did some searching with google, on the fedora bug database and on these forums, and the only thing I found that seemed relevant was the instructions for fixing a problem with selinux, as posted here: http://forums.fedoraforum.org/showthread.php?t=261937 however when I switched to command-line and followed the instructions I received the following output:

    Fedora release 15 (Lovelock)
    Kernel on an x86_64 (tty2)
    [root@localhost liveuser]# rep gnome-session-c /var/log/audit/audit.log | audit2allow -M nvidiaisbroken
    compilation failed:
    nvidiaisbroken.te:6:ERROR 'syntax error' at token '' on line 6:
    /usr/bin/checkmodule: error(s) encountered while parsing configuration
    /usr/bin/checkmodule: loading policy configuration from nvidiaisbroken.te
    [root@localhost liveuser]# semodule -i nvidiaisbroken.pp
    semodule: Failed on nvidiaisbroken.pp!
    I mucked about and also tried the following with no idea what I was doing:

    [root@localhost liveuser]# semodule -i nvidiaisbroken.te
    libsepol.module_package_read_offsets: wrong magic number for module package: expected 0xf97cff8f, got 0x646f6d0a
    libsemanage.parse_module_headers: Could not parse module data.
    semodule: Failed on nvidiaisbroken.te!
    I tried checking to see if nouveau was blacklisted in grub.conf but i get:

    bash: /boot/grub/grub.conf: No such file or directory.
    This error is reproducible and occurs at every startup. There is also the usual "mkdir: cannot create directory '/run': File exists" error on tty1 at startup but I understand that's normal.

    Hardware: I am running a DIY box with a nvidia GTS250 card (which may be the problem as it's not on the supported lists last i checked :c) and an Intel i3 processor. Will be happy to answer any other queries.

    What I would like to know is: is the problem with graphics card support (in which case will support be added soon?), a bug in the code (fixed or otherwise), or something which I can troubleshoot at the command line?

  2. #2
    Join Date
    Dec 2008
    Vancouver, BC

    Re: x86_64 livecd: no login screen, gnome-shell, or gnome-fallback at boot

    this reads like a graphics driver bug to me. Can you file it at http://bugzilla.redhat.com/ against F15 and the xorg-x11-drv-nouveau package, including the info suggested at https://fedoraproject.org/wiki/How_t..._Xorg_problems ? thanks!
    Adam Williamson | awilliam AT redhat DOT com
    Fedora QA Community Monkey
    IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora

Similar Threads

  1. Replies: 21
    Last Post: 23rd April 2011, 12:48 AM
  2. [SOLVED]
    Long delay between gdm-login and gnome-shell
    By tuxor in forum F15 Development
    Replies: 11
    Last Post: 31st March 2011, 01:20 PM
  3. GNOME problem: Failed to start GNOME Shell. Reverting to previous settings.
    By piopio in forum Installation, Upgrades and Live Media
    Replies: 12
    Last Post: 21st November 2010, 09:00 AM
  4. Login screen in gnome
    By vm_srikanth in forum Using Fedora
    Replies: 2
    Last Post: 3rd January 2009, 05:13 PM
  5. Replies: 3
    Last Post: 7th March 2006, 08:43 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts