HOWTO: WPA authenticated wireless networking on FC3
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 27
  1. #1
    bärtil Guest

    HOWTO: WPA authenticated wireless networking on FC3

    This is not very good howto but i hope it will help someone.. sorry my bad english!

    First dowload ndiswrapper, wpa_supplicant and winxp drivers for your card, move them to /root

    Untar and make ndiswrapper:
    Code:
    cd /root
    tar zxvf ndiswrapper-0.11.tar.gz
    cd ndiswrapper-0.11
    make install
    Download and install your winxp wlan drivers:
    Code:
    mkdir /root/xp_driver
    cd /root/xp_driver
    unzip ../driver.zip
    ndiswrapper -i /root/xp_driver/driver.inf
    Write configuration for ndiswrapper to modprobe.conf:
    Code:
    ndiswrapper -m
    Then configure network:
    Code:
    system-config-network
    select New-->Wireless connection-->ndiswrapper(wlan0)
    Mode:Auto, Network name:Auto, Channel:your AP channel, Rate:Auto, Key:leave blank
    Select dhcp or static, wichone you use.. Apply and close configuration tool
    Next make wpa_supplicant:
    Code:
    cd /root
    tar zxvf wpa_supplicant-0.2.5.tar.gz
    cd wpa_supplicant-0.2.5
    echo CONFIG_DRIVER_NDISWRAPPER=y >.config
    make
    cp wpa_supplicant wpa_passphrase wpa_cli /usr/local/bin
    then edit /etc/wpa_supplicant.conf to look like this:
    Code:
    ctrl_interface=/var/run/wpa_supplicant # for wpa_cli support
    
    network={
      ssid="myssid"
      psk="mysecret"
      key_mgmt=WPA-PSK
      proto=WPA
    }
    to get wpa_supplicant automatically load with ifup type
    Code:
    echo wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf -wB >> /etc/sysconfig/network-scripts/ifup-wireless
    and final type
    Code:
    ifup wlan0
    and networkin should came up, if not check configs match your AP's parameters
    if it works use system-config-network to make wlan0 start automatically at boot

  2. #2
    micha Guest
    Thanks for this how to, it works for me.
    Except when you need to change the wireless profile. You need to kill wpa_supplicant every time...

  3. #3
    micha Guest
    I found the solution to properly and automaticaly exit wpa_supplicant when the wireless interface is down.
    Code:
    echo killall wpa_supplicant > /etc/sysconfig/network-scripts/ifdown-wireless
    chmod +x /etc/sysconfig/network-scripts/ifdown-wireless
    Now each time you put down a wireless interface, wpa_supplicant is killed.

  4. #4
    bärtil Guest
    yeah, great!

  5. #5
    bentterp Guest
    Hmm, doesn't ndiswrapper clash with 4KSTACKS anymore? Or is that just so obvious that we don't even talk about it?

  6. #6
    bärtil Guest
    ndiswrapper works fine with FC3, you dont need to worry about 4STACKS.. by the way, anyone heard anything about 64bit wireless drivers?? i want to use 64bit version of FC3

  7. #7
    Join Date
    Oct 2004
    Location
    Bristol UK
    Age
    39
    Posts
    64
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    yes, no go until 64 bit drivers for windows get released i'm afraid, if you want wireless i'd stick with 32bit FC3 for now sorry, there is someone who's working on it, but god knows how long that's going to take

  8. #8
    bertj Guest
    What about an Dell TrueMobile-card with no winxp-drivers present?
    Because I won't get Open1x compiled on my FC3-desktop, this HOWTO is my only option to get it work.

    Thnx,
    Bert

  9. #9
    deucez Guest
    This is a great how to. I'm new to Linux and have used this along with some other information I found on the Internet to get my wireless card (BCM4306) working, but have a problem. When I try to start wlan0 I get the following message.

    ./ifup-wireless: line 96: wpa_supplicant: command not found

    Any ideas what I have done wrong?

    I'm running FC3 kernel 2.6.10-1.760.

    Thanks
    Eric

  10. #10
    imdeemvp Guest
    Thank for the info bartil....this may even help me since I am learning networking in windoz and fedora.

  11. #11
    meganbg Guest
    I did find a 64-bit broadcom driver, but there seems to be a memory leak somewhere in the network (I suspect the driver, but cannot prove it). I found the driver here <http://ubuntuforums.org/attachment.php?attachmentid=186>. Also, for me it has only worked with the as-distributed FC3 2.6.9 kernel. When I updated to 2.6.10, it stopped working...

  12. #12
    mincemeat Guest
    Quote Originally Posted by deucez
    When I try to start wlan0 I get the following message.

    ./ifup-wireless: line 96: wpa_supplicant: command not found

    Any ideas what I have done wrong?

    I'm running FC3 kernel 2.6.10-1.760.

    Thanks
    Eric
    Hi Eric. I'm sure you've figured it out by now, so if any other noobies are trying this...
    This worked for me. The last line in /etc/sysconfig/network-scripts/ifup-wireless should read:

    /usr/local/bin/wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf -wB

    BTW, Bartil, great tutorial. Thanks.

    Also, I have noticed that my system locks up with the Broadcom 4306 rev. 3 driver (14e4:4320) and the 2.6.10 kernel so meganbg isn't alone.

    Regards,
    Christian

  13. #13
    dragon Guest

    Identifying card / driver

    bertj,

    Check the ndiswrapper driver list page: http://ndiswrapper.sourceforge.net/p...index.php/List

    It has links to the drivers that appear to work for each card and card-specific instructions for some cards.

    Also, if you want to find the chipset of your card (which determines which driver you will need), try running:
    Code:
    /sbin/lspci
    this should produce something like:
    Code:
    02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5705M Gigabit Ethernet (rev 01)
    02:01.0 CardBus bridge: O2 Micro, Inc. OZ711EC1 SmartCardBus Controller (rev 20)
    02:01.1 CardBus bridge: O2 Micro, Inc. OZ711EC1 SmartCardBus Controller (rev 20)
    02:03.0 Network controller: Broadcom Corporation BCM4309 802.11a/b/g (rev 03)
    The last line is my wireless LAN card.

    Good luck!

  14. #14
    dragon Guest
    Quote Originally Posted by meganbg
    I did find a 64-bit broadcom driver, but there seems to be a memory leak somewhere in the network (I suspect the driver, but cannot prove it). I found the driver here <http://ubuntuforums.org/attachment.php?attachmentid=186>. Also, for me it has only worked with the as-distributed FC3 2.6.9 kernel. When I updated to 2.6.10, it stopped working...
    meganbg,

    I believe it's necessary to recompile ndiswrapper and reinstall the drivers when you upgrade the kernel. Try this and see how you go.

  15. #15
    dragon Guest
    Quote Originally Posted by mincemeat

    Also, I have noticed that my system locks up with the Broadcom 4306 rev. 3 driver (14e4:4320) and the 2.6.10 kernel so meganbg isn't alone.

    Regards,
    Christian
    Christian,

    The freeze may be caused by the driver being too large for the Fedora kernel. This is known as the 4K stack issue, where Fedora will freeze if you attempt to load a driver larger than 4K (although ndiswrapper will load, many Windows drivers are larger than this and this will cause the freeze).

    There are two possible solutions:
    1) Upgrade to a 16k stack kernel (16 k stack Fedora kernels provided at: http://ndiswrapper.sourceforge.net/p...dex.php/Fedora)
    2) Use a Windows 98 driver instead of 2000 / XP. Some of these are smaller, and so don't cause the prolem with the 4k stacks. See: http://ndiswrapper.sourceforge.net/p...index.php/List. This page provides suggestions as to which driver files to use (please note that multiple versions may be packaged in the same driver download, so you may need to pick out the individual driver files to install).

    Hope it helps.

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Replies: 0
    Last Post: 28th February 2009, 05:13 PM
  2. [F8] Yum with authenticated ISA proxy
    By CraigWatson in forum Servers & Networking
    Replies: 1
    Last Post: 4th July 2008, 11:22 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •