[SOLVED] Fedora 14 and Hyper-V
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    Join Date
    Nov 2010
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Fedora 14 and Hyper-V

    Hi Community,

    i'm running some virtual Fedora installations on a windows server 2008 with hyper-v. Most of them are Fedora 12 and 13. Everything works fine for some years.

    Yesterday i want to upgrade a F13 machine to F14 by netistall. The upgrade ran without any problems. After the reebot the machine was off the network. All the networkconfigs by DHCP are OK, IP address, gateways, DNS settings and so on. But the machine can't ping or connect to other hosts. I tried an VM from scratch with both F14 i386 and x86_64 - same ****.

    This is the first time i had such a problem by upgrading Fedora machines.

    Any hints?

    Regards

    Lissy

  2. #2
    Join Date
    Mar 2010
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 14 and Hyper-V

    Hi,

    I have seen similar behaviour (with F12, F13, RHEL6), and found that this
    problem is only present when:

    * the machine has more than 1 vCPU, and
    * the irqbalance service is running.

    In fact, we observed that the network service was successfully started, but that after
    ~10 seconds the machine was losing its network connection. This helped us to find
    out that irqbalance was implicated.

    I would be interested to know if you can reproduce this.

    cheers, jan

  3. #3
    Join Date
    Nov 2010
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 14 and Hyper-V

    Hi,

    I'm having the same problem since Fedora 14. DHCP works I get about 2-3k of data before it stops working.

    I have an image for fedora 12 that works with irqbalance enabled.

    Disabling irqbalance (chkconfig irqbalance off) seems to fix the problem.

    I have noticed the following errors from dmesg

    It says something like

    ---------[ cut here ]-------------
    WARNING: at net/sched/sch_generic.c:258 dev_watchdog+0xc6/0x12e()
    Hardware name: Virtual Machine
    NETDEV WATCHDOG: eth0 (tulip): transmit queue 0 timed out
    ...
    ...
    ...
    net eth0: 21140 transmit timed out, status fc67814, fffffe00
    00000068 00000070 fffffec8, resetting...
    net eth0: 21140 transmit timed out, status fc67814, fffffe00
    00000068 00000070 fffffec8, resetting...
    net eth0: 21140 transmit timed out, status fc67814, fffffe00
    00000068 00000070 fffffec8, resetting...

    Maybe something related to the Amazon cloud changes?

  4. #4
    Join Date
    Nov 2010
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 14 and Hyper-V

    Hi!

    The problem is solved! It was the irqbalance service which cuts off the machine. it doesn't matter if the VM had one or more CPU Kernels. It's the same on i386 and x86_64 systems.

    Thanks for your help!

    Regards

    Lissy
    Last edited by Bellsouth; 12th November 2010 at 05:54 PM.

Similar Threads

  1. How to Install Fedora 11 x64 in Hyper-V Server 2008 R2 Correctly ?
    By my407sw in forum Installation, Upgrades and Live Media
    Replies: 4
    Last Post: 16th September 2010, 05:42 PM
  2. Fedora 64 Bit doesn't detect harddrive on Hyper-V
    By BerndX in forum Using Fedora
    Replies: 0
    Last Post: 13th August 2010, 06:49 AM
  3. Fedora 8 64 bit under Hyper-V - networking issue
    By mobigital in forum Installation, Upgrades and Live Media
    Replies: 2
    Last Post: 6th October 2009, 01:06 PM
  4. Fedora 9 and Hyper-v -- network not working
    By jeff37801 in forum Servers & Networking
    Replies: 2
    Last Post: 5th October 2009, 09:55 PM
  5. Fedora 8 shows only up to 4gb memory in Hyper-V
    By mobigital in forum Using Fedora
    Replies: 2
    Last Post: 19th March 2008, 03:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •