FedoraForum.org - Fedora Support Forums and Community
Page 2 of 2 FirstFirst 1 2
Results 16 to 30 of 30
  1. #16
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    24

    Re: how to enable the nvidia driver in f14?

    Sorry I don't understand your question..
    Did you mean
    Code:
    sh NVIDIA-Linux-x86_64-260.19.12.run --uninstall
    yum install akmod-nvidia

  2. #17
    Join Date
    Nov 2008
    Posts
    129

    Re: how to enable the nvidia driver in f14?

    exactly! i would like to have the akmod instead of the original driver, but akmod-nvidia is too slow and hangs my system...

  3. #18
    Join Date
    Dec 2008
    Location
    Vancouver, BC
    Posts
    4,327

    Re: how to enable the nvidia driver in f14?

    it's exactly the same code. If it's 'slow', it's misconfigured somehow; probably nvidia-xconfig didn't configure everything that needs to be configured for the driver to work as packaged in fusion.
    Adam Williamson | awilliam AT redhat DOT com
    Fedora QA Community Monkey
    IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
    http://www.happyassassin.net

  4. #19
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    24

    Re: how to enable the nvidia driver in f14?

    Quote Originally Posted by AdamW
    it's exactly the same code...
    nvidia-xconfig configures xorg.conf once. And this same code works differently from one xorg.conf.

  5. #20
    Join Date
    Nov 2008
    Posts
    129

    Re: how to enable the nvidia driver in f14?

    so what should we write on xorg to make it work correctly? because the file in nvidia-xconfig is so simple that seems unusefull

  6. #21
    Join Date
    Dec 2008
    Location
    Canada
    Posts
    30

    Cool Re: how to enable the nvidia driver in f14?

    I too would like to know the answer to this question. akmod method fails at present, results in same driver not found error. Indeed, locate nvidia.ko returns nothing. Nouveau works fine in the meanwhile, but it seems a waste to have spent a little more for the nvidia 140m card if can't be used.

    My guess is that I just must wait a bit until the fusion repo rebuilds nvidia against latest kernel. Sound like an ok plan? I don't want to do things outside of yum, like build own from nvidia.

    Cheers, and I follow this thread with interest,

    Oh and the bug report too, thanks for link. Looks like it is being worked on now, but could be a while before fixed. And maybe not as simple as building new from nvidia itself. If I am reading bug correctly.

    AM
    Last edited by oOarthurOo; 27th October 2010 at 11:09 PM.
    A towel is about the most massively useful tool for fixing computers: Use it to dry your tears when something goes wrong; To wipe sweat off your face as you try to fix it; And to toss over and hide the broken machine when you decide to give up and walk away.

  7. #22
    Join Date
    Dec 2008
    Location
    Vancouver, BC
    Posts
    4,327

    Re: how to enable the nvidia driver in f14?

    I mean the code of the driver itself is the same. nvidia-xconfig should write a correct xorg.conf AFAIK.
    Adam Williamson | awilliam AT redhat DOT com
    Fedora QA Community Monkey
    IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
    http://www.happyassassin.net

  8. #23
    Join Date
    Oct 2010
    Posts
    1

    Re: how to enable the nvidia driver in f14?

    me too:
    Code:
    [root@localhost dook]# nvidia-config-display 
    Traceback (most recent call last):
      File "/usr/sbin/nvidia-config-display", line 28, in <module>
        import livnaConfigDisplay.ConfigDisplay
      File "/usr/lib/python2.7/site-packages/livnaConfigDisplay/ConfigDisplay.py", line 29, in <module>
        import xf86config
      File "/usr/lib64/python2.7/site-packages/xf86config.py", line 1, in <module>
        import ixf86config
    ImportError: /usr/lib64/python2.7/site-packages/ixf86configmodule.so: undefined symbol: xstrtokenize
    for install the nvidia driver I use this guide: http://www.fedoraonline.it/modules/s...e=3&itemid=332

    I'm using F14

  9. #24
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    24

    Re: how to enable the nvidia driver in f14?

    Quote Originally Posted by AdamW
    I mean the code of the driver itself is the same. nvidia-xconfig should write a correct xorg.conf AFAIK.
    If I run in 3th runlevel
    Code:
    # sh NVIDIA-Linux-x86_64-260.19.12.run
    # nvidia-xconfig
    # init 5
    $ glxgears
    16892 frames in 5.0 seconds = 3378.328 FPS
    All works fine. This means the xorg.conf is correct.

    If I install nvidia driver from RPMFusion
    Code:
    yum install akmod-nvidia
    Exactly the same correct xorg.conf from the first example. I get very slow 2d and
    Code:
    $ glxinfo
    name of display: :0.0
    X Error of failed request: BadWindow (invalid Window parameter)
    Major opcode of failed request: 138 (NV-GLX)
    Minor opcode of failed request: 4 ()
    Resource id in failed request: 0x3000003
    Serial number of failed request: 30
    Current serial number in output stream: 30
    in /var/log/Xorg.0.log I see
    Code:
    [   111.489] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
    [   111.490] (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
    [   111.490] (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
    [   111.490] (EE) NVIDIA(0):     you continue to encounter problems, Please try
    [   111.490] (EE) NVIDIA(0):     reinstalling the NVIDIA driver.
    The problem isn't in the correct xorg.conf IMHO.


    PS
    Anyone tried nvidia-graphics from Atrpms repo?
    Last edited by NickLee; 29th October 2010 at 11:51 AM. Reason: Update about Atrpms

  10. #25
    Join Date
    Dec 2008
    Location
    Vancouver, BC
    Posts
    4,327

    Re: how to enable the nvidia driver in f14?

    nicklee: I agree - as I keep saying, the problem is that the packaged driver expects various bits of post-install configuration to be done by nvidia-config-display and the 'nvidia' service, which currently doesn't happen because of the breaking in pyxf86config. If you can reconstruct all the configuration work that nvidia-config-display is supposed to do, theoretically you should wind up with a working driver, but I don't think anyone's bothered to walk through that step-by-step yet.
    Adam Williamson | awilliam AT redhat DOT com
    Fedora QA Community Monkey
    IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
    http://www.happyassassin.net

  11. #26
    Join Date
    Nov 2008
    Posts
    162

    Re: how to enable the nvidia driver in f14?

    AdamW: you mean something like this?

    Code:
    Section "Files"
            ModulePath   "/usr/lib64/xorg/modules/extensions/nvidia"
            ModulePath   "/usr/lib64/xorg/modules"
    EndSection
    
    Section "ServerFlags"
            Option      "AIGLX" "on"
    EndSection
    
    Section "Device"
            Identifier  "Videocard0"
            Driver      "nvidia"
            Option      "AddARGBGLXVisuals" "True"
    EndSection
    
    Section "Extensions"
            Option      "Composite" "Enable"
    EndSection
    I believe this is the absolute bare minimum on 64-bit fedora for enabling the nvidia driver and 3D features.

    Replace /usr/lib64 in the ModulePath lines if you're using 32-bit

  12. #27
    Join Date
    Dec 2008
    Location
    Vancouver, BC
    Posts
    4,327

    Re: how to enable the nvidia driver in f14?

    I didn't mean just xorg.conf, no. I think it does other stuff too, like moving libraries around. I forget the details.
    Adam Williamson | awilliam AT redhat DOT com
    Fedora QA Community Monkey
    IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
    http://www.happyassassin.net

  13. #28
    Join Date
    Nov 2008
    Posts
    162

    Re: how to enable the nvidia driver in f14?

    I don't think it does. all I did was install akmod-nvidia and it pulled in the nvidia drivers, crafted my xorg.conf (I cheated actually, and copied it from my archives) and bingo, it worked.

  14. #29
    Join Date
    Dec 2008
    Location
    Canada
    Posts
    30

    Re: how to enable the nvidia driver in f14?

    I gave up on trying to make the fusion one work. The bug noted above was the culprit I suspect. Purging all nvidia and livna stuff installed from fusion, downloading the binary from nvidia works just fine.

    Once downloaded, I rebooted into single user mode, telinit into 3, run the installer, reboot, and Bob's my uncle.
    A towel is about the most massively useful tool for fixing computers: Use it to dry your tears when something goes wrong; To wipe sweat off your face as you try to fix it; And to toss over and hide the broken machine when you decide to give up and walk away.

  15. #30
    Join Date
    Mar 2010
    Posts
    25

    Re: how to enable the nvidia driver in f14?

    I have a little problem.....
    I upgraded yesterday from F12 to F14 , now I have a new kernel and an old one, with the old one I could boot with akmod-nvidia and nvidia's binaries, the problem is I can't boot with the new kernel, to install nvidia's binaries, because it freezes on some nvidia driver thing....
    I added vga=791 to the boot parameters but it didn't work....
    and I can't run yum update because it needs the new kernel, the one I can't boot from....

    Thanks for helping

Page 2 of 2 FirstFirst 1 2

Similar Threads

  1. Should we enable nouveau back after installing NVIDIA driver?
    By kimsieng in forum Installation, Upgrades and Live Media
    Replies: 2
    Last Post: 17th October 2010, 04:05 PM
  2. nouveau nvidia display how to enable it
    By james2b in forum Using Fedora
    Replies: 5
    Last Post: 17th October 2010, 05:00 AM
  3. Nvidia Geforce Go 7400 cannot enable on fedora 12
    By giusemc in forum Using Fedora
    Replies: 4
    Last Post: 8th March 2010, 09:25 PM
  4. How do I re-enable the nouveau driver?
    By dth4h in forum Using Fedora
    Replies: 0
    Last Post: 11th December 2009, 05:41 PM
  5. Replies: 0
    Last Post: 28th November 2008, 05:21 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •