FedoraForum.org - Fedora Support Forums and Community
Results 1 to 7 of 7
  1. #1
    Join Date
    Oct 2006
    Posts
    17

    Exclamation kernel-2.6.34.6-47.fc13.x86_64 stops booting with 'No root device found'

    I applied updates this morning, which included kernel-2.6.34.6-47.fc13.x86_64. Upon rebooting, my system displays:

    WARNING: Deprecated config file /etc/modprobe.conf
    (this repeats 20 or so times)
    No root device found.
    Boot has failed, sleeping forever.

    and freezes. Rebooting and choosing the previous kernel (2.6.33.8-149) boots fine. My system has the Nvidia drivers from RPMFusion. I'm not using LVM or RAID on this system.

  2. #2
    Join Date
    Aug 2009
    Location
    Waldorf, Maryland
    Posts
    7,346

    Re: kernel-2.6.34.6-47.fc13.x86_64 stops booting with 'No root device found'

    Check your /boot/grub/grub.conf file.

    It almost sounds like something happened to the "root=" specification. It should
    be the same as for the older kernel entry.

    I have the same kernel, but no significant problems. The "WARNING" is just that.
    eventually the /etc/modprobe.conf file will go away, or you can check the contents
    of your modprobe.conf file against the contents of /etc/modprobe.d. If all required
    entries are present, just delete /etc/modprobe.conf.

  3. #3
    Join Date
    Oct 2006
    Posts
    17

    Re: kernel-2.6.34.6-47.fc13.x86_64 stops booting with 'No root device found'

    grub.conf looks the same for both kernels:

    title Fedora (2.6.34.6-47.fc13.x86_64)
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.34.6-47.fc13.x86_64 ro root=UUID=59b7f5b7-2cfb-49ec-a2c8-274b2f6a5b86 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rdblacklist=nouveau
    initrd /boot/initramfs-2.6.34.6-47.fc13.x86_64.img
    title Fedora (2.6.33.8-149.fc13.x86_64)
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.33.8-149.fc13.x86_64 ro root=UUID=59b7f5b7-2cfb-49ec-a2c8-274b2f6a5b86 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rdblacklist=nouveau
    initrd /boot/initramfs-2.6.33.8-149.fc13.x86_64.img

    The initrd does exist:
    -rw-r--r-- 1 root root 12853195 Sep 6 16:49 /boot/initramfs-2.6.34.6-47.fc13.x86_64.img
    The volume UUID matches the output of 'blkid'.

    modprobe.conf is empty. I've tried deleting it, but it gets recreated at the next boot.

  4. #4
    Join Date
    Aug 2009
    Posts
    8,474

    Re: kernel-2.6.34.6-47.fc13.x86_64 stops booting with 'No root device found'

    well, I found that to completely get rid of that empty modprobe.conf error, I had to boot into the latest kernel, delete the /etc/modprobe.conf file, then run dracut -f /boot/initramfs-$(uname -r).img $(uname -r)

    cleared the error for me until the next time an update of some package created a new modprobe.conf.

  5. #5
    Join Date
    Aug 2009
    Location
    Waldorf, Maryland
    Posts
    7,346

    Re: kernel-2.6.34.6-47.fc13.x86_64 stops booting with 'No root device found'

    You might try looking at the device used for root, then replacing the UUID=..
    with /dev/sdxxx of your root. It is odd that it doesn't find it.

  6. #6
    Join Date
    Oct 2006
    Posts
    17

    Re: kernel-2.6.34.6-47.fc13.x86_64 stops booting with 'No root device found'

    I uninstalled kernel-2.6.34.6-47.fc13.x86_64 this morning, and then did a yum update which brought in 2.6.34.6-54.fc13.x86_64. After installing it, my system boots normally into the new kernel. I don't know what they changed, but it's working now.

  7. #7
    Join Date
    Mar 2008
    Location
    Wales
    Posts
    96

    Re: kernel-2.6.34.6-47.fc13.x86_64 stops booting with 'No root device found'

    Odd, running (until I get a wifi connection, not doing kernel upgrades over a flaky 3g link) 2.6.34.6-47.fc13 (the .i686 variant though not the 64 bit) - but I am using lvm.

Similar Threads

  1. no root device found.
    By Abo Sahar in forum Hardware & Laptops
    Replies: 1
    Last Post: 14th August 2010, 12:57 PM
  2. Need kernel-2.6.33.5-112.fc13.x86_64
    By Arashdn in forum Using Fedora
    Replies: 2
    Last Post: 18th June 2010, 05:36 PM
  3. Where to find kernel-2.6.33-1.fc13.x86_64?
    By jvillain in forum Fedora 13 Development Branch
    Replies: 3
    Last Post: 10th April 2010, 12:58 PM
  4. kernel 2.6.33.1-19.fc13.x86_64
    By Landshark in forum Fedora 13 Development Branch
    Replies: 3
    Last Post: 30th March 2010, 08:15 PM
  5. kernel-2.6.32.2-15.fc13.x86_64 and akmod-nvidia-190.53-1.fc13.x86_64
    By chepioq in forum Fedora 13 Development Branch
    Replies: 12
    Last Post: 9th January 2010, 05:45 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •