Solution: r8169 "link down" bug
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2010
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Solution: r8169 "link down" bug

    I recently migrated to a new motherboard with an r8169 ethernet interface. I installed Fedora 13 and it had been running fine for several weeks when suddenly my network disappeared. Studying the syslogs turned up this:

    Code:
    Aug 29 18:49:21 lynnie kernel: r8169: eth0: link down
    Aug 29 18:49:21 lynnie kernel: ADDRCONF(NETDEV_UP): eth0: link is not ready
    A bit of googling revealed that this has been a known issue with the r8169 driver for several years. The device will randomly fail autonegotiation and refuse to come up, sometimes after weeks of working fine. The fix is to use ethtool to disable autonegotiation sometime between loading the driver module and when Network Manager tries to bring it up. I did this by adding the new file /etc/modprobe.d/r8169.conf with the following:

    Code:
    # turn off autonegotiation on the r8169 ethernet driver
    install r8169 /sbin/modprobe --ignore-install r8169 && /usr/sbin/ethtool -s eth0 autoneg off
    This appears to work. Hopefully it can be useful to someone else.

    Eric

  2. #2
    Join Date
    Sep 2010
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Solution: r8169 "link down" bug

    Quote Originally Posted by ebrombaugh
    [...]

    This appears to work. Hopefully it can be useful to someone else.

    Eric
    Thanks a lot, i searched in google without solution for me until i found this post!!!

    http://forum.mandriva.com/viewtopic.php?p=828277
    Thanks many times

  3. #3
    Join Date
    Nov 2010
    Posts
    110
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Solution: r8169 "link down" bug

    The solution you gave worked perfect for me. Such an easy workaround - Thanks!!

Similar Threads

  1. Replies: 0
    Last Post: 19th June 2008, 04:49 PM
  2. Solution for error message "Disabling IRQ #xx"
    By tbroberg in forum Hardware & Laptops
    Replies: 1
    Last Post: 26th January 2007, 01:53 AM
  3. Replies: 3
    Last Post: 13th December 2005, 04:22 AM
  4. Replies: 0
    Last Post: 23rd May 2005, 04:59 AM
  5. Fedora Core 3 install solution "running /sbin/loader" with ASUS P4S533-MX motherboard
    By whiterabbit in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 18th April 2005, 01:29 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •