[Acer Aspire 3820T] Fedora 13 brightness issue
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 15 of 15
  1. #1
    Join Date
    Jun 2010
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    [Acer Aspire 3820T] Fedora 13 brightness issue

    As the title says, I have a small problem with the brightness on my new Aspire 3820T. I have found a solution for the problem the only issue is that its for Ubuntu and Grub2.

    The solution from Ubuntu forum:
    Brightness issue:
    The brightness of the display can not be adjusted (that is true for the 64bit and 32bit kernel) using gnome-power-preferences or the Fn+arrow keys on the keyboard. Using the Fn+arrow keys, the brightness indicator in gnome is called and can be adjusted, but the actual brightness of the display does not change. There is a workaround for this problem that I found elsewhere (I don't remember):

    Code:
    sudo gedit /etc/default/grub
    Change the line GRUB_CMDLINE_LINUX="" into
    Code:
    GRUB_CMDLINE_LINUX="acpi_osi=Linux"
    then run
    Code:
    sudo update-grub

    My question is how this works with Fedora and it's Grub? Also the multitouch solution doesn't seem to work here, any idea? Othere than that everything seems to work here, although I havn't tried Suspend. [Edit] Suspends seems to work, no problem with CPU or other things reported in the Ubuntu thread

    I'm using Fedora 13 amd64 with KDE if that is to any help :P
    Last edited by nordmoen; 19th June 2010 at 11:09 PM.

  2. #2
    Join Date
    Jun 2010
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Red face Re: [Acer Aspire 3820T] Fedora 13 brightness issue

    Having the same problem on my Aspire 5732Z running Fedora 13 64-bit, but I use GNOME.

    When I tried the workaround I found I had no "grub" file in /etc/default.

    Could the "grub" file that needs to be edited be somewhere else?

    Thanks.

  3. #3
    Join Date
    Jun 2010
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: [Acer Aspire 3820T] Fedora 13 brightness issue

    The problem is that Ubuntu uses Grub2, but Fedora uses a fork of Grub 1(if I have understod it correct). To my shame I have just switched to Kubuntu which for the time beeing seems to work. But I hope someone have a fix for this.

  4. #4
    Join Date
    Apr 2009
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: [Acer Aspire 3820T] Fedora 13 brightness issue

    same question as "Ubiquetous ".....

  5. #5
    Join Date
    Jun 2009
    Location
    New Zealand
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: [Acer Aspire 3820T] Fedora 13 brightness issue

    Same issue here, on an Acer 5542, 64-bit, gnome. If I adjust the applet all the way down it goes to the lowest brightness setting, but there's no in-between.

  6. #6
    Join Date
    Apr 2009
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: [Acer Aspire 3820T] Fedora 13 brightness issue

    Solution here, Thanks David, it works fine on my Fedora 13 64 bit ver. Below is quote from the email from David.
    ========================
    Hi,
    I see your problem. What I wrote is for GRUB2 used by my Ubuntu, so if your Fedora is still using the first version, you should edit /boot/grub/grub.conf (you will need root account for this) and add "acpi_backlight=vendor acpi_osi=linux" (without the quotes, of course) at the end of each line that begins with "kernel". So for example your first Fedora block should become:

    title Fedora (2.6.33.5-124.fc13.x86_64)
    root (hd0,6)
    kernel /vmlinuz-2.6.33.5-124.fc13.x86_64 ro root=UUID=236fef23-35fb-4c49-924c-a1be77383ea2 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet acpi_backlight=vendor acpi_osi=linux

    initrd /initramfs-2.6.33.5-124.fc13.x86_64.img

    To be sure, first edit just this one block and leave the others as they are. If anything goes wrong, you will be able to choose the older kernel while booting (or you can edit these lines directly during booting - it is explained in the GRUB menu, which comes before your system and where you can choose different kernel). However, I am quite concerned, whether these changes will withstand. Obviously, your grub.conf is automatically generated by a program called Anaconda. I don't use Fedora, so I can't help you with this, but if you find that adding this works for you, you should try to find a way to tell Anaconda to add it to the file automatically every time your system gets new Linux kernel through updates. Otherwise, the changes would get erased after first kernel update.
    So, to sum up, I have no idea, whether it would work for you on your Fedora, but it fixed my Ubuntu completely. So fingers crossed :-)

    David
    ============================

  7. #7
    Join Date
    Jun 2009
    Location
    New Zealand
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: [Acer Aspire 3820T] Fedora 13 brightness issue

    Thanks desblood, but no luck here. I added the line and rebooted, then tried the keyboard shortcut - and now the slider in power management won't respond either, lol.

  8. #8
    Join Date
    Jun 2010
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: [Acer Aspire 3820T] Fedora 13 brightness issue

    Found the answer, only tested on openSUSE though.

    acpi_backlight=vendor acpi_osi=linux is correct, but there has to be a big 'L' in Linux

    Tested in openSuse and small L does nothing, but big lets me control brightness Only problem is that KDE brightness indicator doesn't work correct

  9. #9
    Join Date
    Jun 2010
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Talking Re: [Acer Aspire 3820T] Fedora 13 brightness issue

    *******************SOLVED************************* ***********

    Used desblood4's solution via David - see above. I'm on Fedor 13 64-bit on an Acer Aspire 5732z.

    Also had to use nordomen's suggestion to use capital/big L.

    My brightness function keys appear to work backwards from the way they do in Win 7, but then I thought they worked backwards from the way they appear to be labeled in Win 7; but it works and that's all I care about for now. I now have 10 brightness settings from completely black to what I think is full brightness (for some reason I think full brightness may be a tad dimmer than before). Oh .. and the pop-up appelet is now gone for brightness. Before the fix appelet poped up and the and the brightness scale would increase or decrease, but the actual brightness would not change. After the fix, the brightness appelet does not appear at all but brightness changes as described above.

    Not perfect - but way better than before. Thanks to everyone that helped.

  10. #10
    Join Date
    Jun 2010
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: [Acer Aspire 3820T] Fedora 13 brightness issue

    Quote Originally Posted by ubiquetous
    *******************SOLVED************************* ***********

    Used desblood4's solution via David - see above. I'm on Fedor 13 64-bit on an Acer Aspire 5732z.

    Also had to use nordomen's suggestion to use capital/big L.

    My brightness function keys appear to work backwards from the way they do in Win 7, but then I thought they worked backwards from the way they appear to be labeled in Win 7; but it works and that's all I care about for now. I now have 10 brightness settings from completely black to what I think is full brightness (for some reason I think full brightness may be a tad dimmer than before). Oh .. and the pop-up appelet is now gone for brightness. Before the fix appelet poped up and the and the brightness scale would increase or decrease, but the actual brightness would not change. After the fix, the brightness appelet does not appear at all but brightness changes as described above.

    Not perfect - but way better than before. Thanks to everyone that helped.
    Same as in KDE, problems with brightness idicator and it seems that openSuse doesn't understand that brightness works, unpluging the power adapter doesn't change brightness and the battery plasmoid with brightness slider neither works

    ---------- Post added at 11:58 PM CDT ---------- Previous post was at 11:45 PM CDT ----------

    More good news!

    Played around with the settings some more, removed 'acpi_backlight=vendor' and everything works perfectly here. Hopes this works for you

    Edit: fixed typos
    Last edited by nordmoen; 10th August 2010 at 11:02 PM.

  11. #11
    Join Date
    Nov 2010
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: [Acer Aspire 3820T] Fedora 13 brightness issue

    Great post!

    Thanks everybody for solving this problem! My eyes and my self are much happier now!
    I have an acer aspire 5742 and FC14.
    Just add the line to the first block as suggested; I tried also on the second one and I was not able to boot anymore.

    Thanks again. Best,

    Michele

  12. #12
    Join Date
    Apr 2011
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: [Acer Aspire 3820T] Fedora 13 brightness issue

    Before deciding to google the issue (which led me here), I've randomly discovered another solution - brightness value set in sysfs (or just "set") will be applied on reboot, so if after boot "/sys/class/backlight/acpi_video0/brightness" shows 0 out of 9, setting it to 9 (via "echo" or keys) and just rebooting sets max brightness right from the BIOS screens and grub (which are also dim with 0).
    Guess the same effect should also apply to suspend-to-disk (basically the same reboot) and suspend-to-ram, but I haven't tested it.

    Not that it's in any way better than setting brightness on the fly, which works for me with "acpi_backlight=Linux" added to cmdline (thanks!), still I thought I'd mention that in case that acpi setting won't work for someone (possibly with another laptop model or kernel).

  13. #13
    Join Date
    Jun 2011
    Location
    Italy
    Posts
    395
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: [Acer Aspire 3820T] Fedora 13 brightness issue

    Very useful thread to enable brightness control in notebooks with integrated graphics.
    Works well in an Asus ul30 with Intel Graphics Media Accelerator (GMA) 4500MHD.

    And Fedora 15, obviusly!
    Last edited by PiElle; 5th July 2011 at 08:21 PM. Reason: complete the post!

  14. #14
    Join Date
    Sep 2011
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: [Acer Aspire 3820T] Fedora 13 brightness issue

    Works in fedora 15 in emachines d528-2819 too

    Does anyone know if a permanent / better solution exists yet?

  15. #15
    Join Date
    Sep 2011
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: [Acer Aspire 3820T] Fedora 13 brightness issue

    How do i do this i have tried editing grub.conf and i keep getting a gtk error or when i open any conf it is blank.

Similar Threads

  1. Replies: 1
    Last Post: 21st July 2009, 12:45 PM
  2. Acer 4736Z Fedora 11 brightness control
    By ruturajv in forum Using Fedora
    Replies: 3
    Last Post: 21st July 2009, 02:01 AM
  3. Issue with Suspend on Acer Aspire 5100
    By OP2Patriot in forum Hardware & Laptops
    Replies: 1
    Last Post: 28th October 2008, 01:10 PM
  4. acer aspire 3680-2682 atheros wifi issue
    By Sulten in forum Hardware & Laptops
    Replies: 15
    Last Post: 27th June 2008, 02:52 AM
  5. Solved: Xwindow issue with FC5 on Acer Aspire 5500:
    By cmoraes in forum Hardware & Laptops
    Replies: 9
    Last Post: 15th April 2007, 08:14 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •