[SOLVED] Enabling the nvidia driver: /etc/rc.d/init.d/functions: line 526: 1263 Segmentation
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 13 of 13
  1. #1
    Join Date
    Jun 2010
    Posts
    4

    Enabling the nvidia driver: /etc/rc.d/init.d/functions: line 526: 1263 Segmentation

    I am running F13 x64. A day or so ago, I installed some updates that my applet alerted me about. One of them apparently was a kernel update to 2.6.33.5-124. I was running 2.6.33.5-112. After this, I would get stuck after the splash screen completed. So I rebooted and at GRUB i selected my old kernel, and logged into my system. From there I saw that I had a boot message alert in my notification area about my nvidia drivers not loading (I have been running nvidia-kmod with nouveau disabled in the kernel commandline). I don't remember exactly what the message was, but I loaded my nvidia gui config panel and it said I needed to run a command to reenable my nvidia-kmod drivers. So I did this, reloaded my X environment and used my nvidia config to write all the settings to my xorg.conf file(the way I had it before). I am still getting an alert that says
    Code:
    "Enabling the nvidia driver: /etc/rc.d/init.d/functions: line 526:  1263 Segmentation fault      "$@"    Failed"
    . I am still booting from my old kernel as well. I looked online to see what might be missing on that line, and I appended the beginning of that line what I found. When I rebooted, I was dumped to a terminal. I was not able to edit my init.d/functions file as it was read only. So I booted from a live cd and edited it back to the way it was to begin with. While I had the live cd loaded, I checked the init.d/functions file from that system and that line is identical to the one I am running now. After editing it, I am now able to boot my system back up normal (still selecting my old kernel version) and I am still receiving the error listed above. Any help would be much appreciated.

    Thanks,
    Thomas

  2. #2
    Join Date
    Jul 2005
    Location
    RainCity
    Posts
    1,884

    Re: Enabling the nvidia driver: /etc/rc.d/init.d/functions: line 526: 1263 Segmentat

    Have you seen Leigh123linux's guide to Nviida drivers?

  3. #3
    Join Date
    Jun 2010
    Posts
    4

    Re: Enabling the nvidia driver: /etc/rc.d/init.d/functions: line 526: 1263 Segmentat

    Yes. This isn't too far off from what I did anyway. But keep in mind that I have been running this system fine for several weeks now with F13, even with the kmod drivers. I only started having these troubles after the kernel update. Also on leigh123's guide, Quadro is listed as unsupported. This laptop has a Quadro NVS 160M.

  4. #4
    Join Date
    May 2009
    Location
    Manorville, New York, USA
    Posts
    1,677

    Re: Enabling the nvidia driver: /etc/rc.d/init.d/functions: line 526: 1263 Segmentat

    If it was working with whatever kmod you were using, why not install the corresponding akmod, then reboot, and it will build the kmod for you (If your lucky, since the card is unsupported).
    Registered Linux User #348347
    Have you been seduced by siduction? http://siduction.org/index.php
    Running Fedora 19/20, siduction and openSUSE 13.1 with KDE

  5. #5
    Join Date
    Jun 2010
    Posts
    4

    Re: Enabling the nvidia driver: /etc/rc.d/init.d/functions: line 526: 1263 Segmentat

    I realized when leigh posted that it was unsupported, that was like 2005. So that may be why Anyway, I will give that a shot and let you know. I have to move to another location for work for a bit. I will let you know what happened later.

  6. #6
    Join Date
    Oct 2008
    Posts
    498

    Re: Enabling the nvidia driver: /etc/rc.d/init.d/functions: line 526: 1263 Segmentat

    Hi,

    Similar issue here - with an ATI card, the open-source radeon driver and latest kernel: a black screen when X tries to come up.

    Booting the previous kernel works OK.

    Probably something is wrong the latest built, but I haven't had the change to dig deeper. In your /etc/grub.conf, just set the previous kernel as default boot for the time being.

    WWell,

  7. #7
    Join Date
    Dec 2008
    Location
    Vancouver, BC
    Posts
    4,328

    Re: Enabling the nvidia driver: /etc/rc.d/init.d/functions: line 526: 1263 Segmentat

    assen: that's a completely different issue. Please file a bug. Thanks.
    Adam Williamson | awilliam AT redhat DOT com
    Fedora QA Community Monkey
    IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
    http://www.happyassassin.net

  8. #8
    leigh123linux Guest

    Re: Enabling the nvidia driver: /etc/rc.d/init.d/functions: line 526: 1263 Segmentat

    Quote Originally Posted by siregghead
    I am running F13 x64. A day or so ago, I installed some updates that my applet alerted me about. One of them apparently was a kernel update to 2.6.33.5-124. I was running 2.6.33.5-112. After this, I would get stuck after the splash screen completed. So I rebooted and at GRUB i selected my old kernel, and logged into my system. From there I saw that I had a boot message alert in my notification area about my nvidia drivers not loading (I have been running nvidia-kmod with nouveau disabled in the kernel commandline). I don't remember exactly what the message was, but I loaded my nvidia gui config panel and it said I needed to run a command to reenable my nvidia-kmod drivers. So I did this, reloaded my X environment and used my nvidia config to write all the settings to my xorg.conf file(the way I had it before). I am still getting an alert that says
    Code:
    "Enabling the nvidia driver: /etc/rc.d/init.d/functions: line 526:  1263 Segmentation fault      "$@"    Failed"
    . I am still booting from my old kernel as well. I looked online to see what might be missing on that line, and I appended the beginning of that line what I found. When I rebooted, I was dumped to a terminal. I was not able to edit my init.d/functions file as it was read only. So I booted from a live cd and edited it back to the way it was to begin with. While I had the live cd loaded, I checked the init.d/functions file from that system and that line is identical to the one I am running now. After editing it, I am now able to boot my system back up normal (still selecting my old kernel version) and I am still receiving the error listed above. Any help would be much appreciated.

    Thanks,
    Thomas
    To fix the seg fault ( it's caused by your custom xorg.conf )
    Code:
    su
    mv /etc/X11/xorg.conf /etc/X11/xorg.conf.broken
    nvidia-config-display disable
    nvidia-config-display enable

  9. #9
    Join Date
    Jun 2010
    Posts
    4

    Thumbs up Re: Enabling the nvidia driver: /etc/rc.d/init.d/functions: line 526: 1263 Segmentat

    Quote Originally Posted by leigh123linux
    To fix the seg fault ( it's caused by your custom xorg.conf )
    Code:
    su
    mv /etc/X11/xorg.conf /etc/X11/xorg.conf.broken
    nvidia-config-display disable
    nvidia-config-display enable
    That did it perfectly. It also sped up my boot time. I did not even see my splash screen. the disable command stated that it was already disabled. However the enable worked just fine. Thanks again leigh!


    Thomas

  10. #10
    Join Date
    Nov 2009
    Posts
    20

    Re: Enabling the nvidia driver: /etc/rc.d/init.d/functions: line 526: 1263 Segmentat

    To fix the seg fault ( it's caused by your custom xorg.conf )
    Code:

    su
    mv /etc/X11/xorg.conf /etc/X11/xorg.conf.broken
    nvidia-config-display disable
    nvidia-config-display enable

    I had the same problem, and this worked for me, also. It fixed a segfault problem I was having with projectM as well. Thanks Leigh!

  11. #11
    Join Date
    Sep 2010
    Posts
    4

    Thumbs up Re: Enabling the nvidia driver: /etc/rc.d/init.d/functions: line 526: 1263 Segmentat

    Quote Originally Posted by leigh123linux
    To fix the seg fault ( it's caused by your custom xorg.conf )
    Code:
    su
    mv /etc/X11/xorg.conf /etc/X11/xorg.conf.broken
    nvidia-config-display disable
    nvidia-config-display enable
    I running F13 x64 on a Dell Latitude e6510 with an nvidia NVS 3100M card. The solution above worked for me. Thanks

  12. #12
    Join Date
    Sep 2010
    Posts
    4

    Re: Enabling the nvidia driver: /etc/rc.d/init.d/functions: line 526: 1263 Segmentat

    It seems I spoke too soon. The recommended solution made the segmentation fault go away, but made my laptop stop recognizing my external display when docked in a docking station. I had to revert back to my "broken" xorg.conf to get the docking station working.

  13. #13
    Join Date
    Feb 2010
    Posts
    12

    Re: Enabling the nvidia driver: /etc/rc.d/init.d/functions: line 526: 1263 Segmentat

    I'm running Fedora 13 (32 bit) and had the same problem with the nvidia init.d "$@" error after installing the Fedora 13 xorg-x11-drv-nvidia-173xxx... nVidia Driver for my GeForce 6150SE nForce 430 from the RPMfusion-nonfree Repo. So, I followed your instructions and it worked for me too, Kind of...

    Quote Originally Posted by leigh123linux
    To fix the seg fault ( it's caused by your custom xorg.conf )
    Code:
    su
    mv /etc/X11/xorg.conf /etc/X11/xorg.conf.broken
    nvidia-config-display disable
    nvidia-config-display enable
    After running, "mv /etc/X11/xorg.conf /etc/X11/xorg.conf.broken". I then ran, 'nvidia-config-display disable" But kept getting an error about no such command. So, I started thinking about it and remembered a pop up during my instalation that told me to run this command, "nvidia-xconfig". This sets up your xorg.conf file or makes one if you don't have one. I figured, since by renaming my xorg.conf file to xorg.conf.broken, I effectively have no xorg.conf file... All I really need is a good xorg.conf file. So, I ran "nvidia-xconfig" instead of running "nvidia-config-display enable". And after a Reboot, the init.d "$@" error was gone. So, I had to think it through, but your info was very helpful. It was indeed the custom xorg.conf settings for me too...

    Thanks,

    Don

Similar Threads

  1. Enabling nvidia 177.82 driver .. Solved
    By sjbaugh in forum Using Fedora
    Replies: 6
    Last Post: 1st December 2008, 08:57 AM
  2. F9 Nvidia driver Problem: blank screen with blue line on top
    By winston154 in forum Hardware & Laptops
    Replies: 40
    Last Post: 24th August 2008, 05:44 PM
  3. How to Install Nvidia driver from lash drive in command line
    By arguspanoptes in forum Using Fedora
    Replies: 13
    Last Post: 31st October 2007, 06:03 AM
  4. Starting SMB fails: /etc/init.d/functions: line 83: 8823
    By harryguy082589 in forum Servers & Networking
    Replies: 9
    Last Post: 16th September 2005, 09:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •