Xfce and touchpads in Fedora 13
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    Join Date
    Dec 2009
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Lightbulb Xfce and touchpads in Fedora 13

    In GNOME there is a nice gui menu for configuring your touchpad, including the option to enable click-on-tap (tapping the touchpad performs the same actions as pressing a mouse button). Xfce has no such menu, but enabling click-on-tap is as easy as adding a single line to a configuration file.

    Fedora 13 uses Xorg 1.8, which introduces a new method for configuring hardware such as touchpads. If you do an internet search for configuring touchpads with Xfce, you will discover a large number of posts dealing with <i>old</i> versions of Xorg, none of which will help you in Fedora 13! (It took me several hours to discover this, hence this post!)

    To enable click-on-tap in Fedora 13, you must edit the file /usr/share/X11/xorg.conf.d/50-synaptics.conf with root privileges. To do this, open Terminal and enter the following commands (press <enter> at the end of each line):

    Code:
    cd /usr/share/X11/xorg.conf.d
    su -c "mousepad 50-synaptics.conf"
    Enter your password when prompted. When the file opens in Mousepad, add the following, right above the line that says "EndSection":

    Code:
    Option "TapButton1" "1"
    (indent the new line with the Tab button so that it is in line with the lines above it)

    Save the file, close Mousepad and restart your computer. Your touchpad should now click when tapped!

    More advanced configurations are possible - see the Synaptics manual page and http://fedoraproject.org/wiki/Input_..._configuration for more information.

  2. #2
    Join Date
    Jun 2010
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Xfce and touchpads in Fedora 13

    Thanks! Didn't get it to work at first, my 50-synaptics.conf contained two InputClass Sections and at first I placed the correction code in the second one, but when I moved it to the first one the fix worked flawlessly.

Similar Threads

  1. XFCE 4.6.1 on Fedora 10 64bit
    By Achilleas in forum Using Fedora
    Replies: 0
    Last Post: 2nd June 2009, 03:22 AM
  2. Fedora 10 xfce xfce menu not working well
    By xroox in forum Hardware & Laptops
    Replies: 1
    Last Post: 1st June 2009, 06:47 AM
  3. Replies: 1
    Last Post: 19th March 2009, 04:08 AM
  4. Xfce on Fedora 8
    By Abijr in forum Using Fedora
    Replies: 7
    Last Post: 2nd February 2008, 06:23 PM
  5. Does Fedora included Xfce ????
    By bbmak in forum Installation, Upgrades and Live Media
    Replies: 2
    Last Post: 19th October 2007, 07:42 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •