Headphones do not mute speakers
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    Join Date
    Nov 2006
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Headphones do not mute speakers

    Hi All

    I recently purchased a Toshiba Qosmio x500 and installed Fedora 12. I've got all the hardware working.

    The only real difficulty that I can see is that when I plug my headphones into the headhphone jack the speakers are not muted. Every mixer application that I can run shows very minimalistic options; 4 at best. In kmixer the options shown are: Master, PCM, Mic, Mic1

    The information shown below seems to indicate that Fedora seems to have located some kind of Modem (Please Note the info about mixers on the bottom indicates it found something from conexant). And because of the order of things, It would seem that this device has taken precedence.

    Any help to properly configure my sound system would be greatly appreciated.

    Thanks in Advance

    Eli


    KDE Info Center shows that I am running:

    HDA Intel at 0xfo900000 irq 22
    HDA NVidia at 0xcdefc000 irq 17

    Audio devices:

    0: HDA Generic (DUPLEX)

    Synth devices: NOT ENABLED IN CONFIG

    MIDI devices: NOT ENABLED IN CONFIG

    Timers:
    31: system timer

    Mixers:
    0: Conexant ID 5067
    1: Nvidia ID d

  2. #2
    Join Date
    Jan 2010
    Posts
    892
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Headphones do not mute speakers

    To automatically do it I don't know how to do it although I have a few ideas.

    Anyway you can configure your system using pulseaudio installing the pavucontrol

  3. #3
    Join Date
    Sep 2008
    Location
    Arlov, Sweden
    Posts
    42
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Headphones do not mute speakers

    If you have Intel sound try this:
    create the file:
    "/etc/modprobe.d/sound.conf"
    with the line:
    "options snd-hda-intel model=toshiba"
    F17 x86_64 Gnome.

  4. #4
    Join Date
    Nov 2006
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Headphones do not mute speakers

    Thanks all for your help.

    After further digging I found a bug report at:

    https://bugzilla.redhat.com/show_bug.cgi?id=537986

    It turns out that the card was not fully supported in the Fedora repository .... yet .... . After a manual installation of the latest drivers from ALSA everything worked OK.

Similar Threads

  1. Headphones not overriding speakers
    By shortcut144 in forum Using Fedora
    Replies: 20
    Last Post: 3rd August 2009, 03:33 PM
  2. Headphones but no speakers
    By SomeDamFool in forum Hardware & Laptops
    Replies: 16
    Last Post: 3rd March 2009, 02:50 AM
  3. Replies: 1
    Last Post: 2nd December 2008, 08:35 AM
  4. audio from speakers and headphones
    By Jaylor in forum Hardware & Laptops
    Replies: 0
    Last Post: 16th June 2008, 12:55 AM
  5. plugging headphones does not mute speakers
    By piergi in forum Hardware & Laptops
    Replies: 7
    Last Post: 29th April 2008, 10:56 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •