Multiple Packages installed - Help
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    jvslice Guest

    Multiple Packages installed - Help

    I have been using apt-get for sometime and I am very happy, but today Ibroke apt-get and synaptic due to my mistake.
    During a update thecomputer hung and I killed Synaptic. Now when I try to run apt-get orSynaptic I receive the following messages "There are multiple versionsof "name of package" on your system"The packages are: openoffice.org, hwdata, xchat, openoffice.org-i18n,and k3b.
    I tried apt-get clean, followed by apt-get update andupgrade. Tried to uninstall the above packages but the program stallsand does not complete, need to kill -9 synaptic or apt-get.

    Thanks for the help

  2. #2
    Ug's Avatar
    Ug is offline Retired Community Manager
    Join Date
    Feb 2004
    Location
    London
    Posts
    2,999
    Best to double check that the clean has worked first.

    As super user, go to /var/cache/apt/archives and make sure that none of those files are in there, or in the partial folder. If they are, delete them and retry. If they're not post back.

  3. #3
    jvslice Guest
    Tried clean again,
    Went to /var/cache/apt/archives
    ls and found only a lock file
    File lock - empty
    cd to partial
    ls
    no files

    tried synaptic - same problem

  4. #4
    foolish Guest
    The error message states that there are multiple versions of the given packages installed, how you've managed this I don't know. I'm guessing you somehow managed to mess with some nasty rpm flags or something like that.

    Fix this by either uninstalling the packages you mentioned, then use apt to reinstall them or do a rpm -qa |grep packagename to get the installed package versions and remove one of the two or more duplicates.

    Please let us know how you got into this situation and how you fix it so that we all may avoid it in the future.

  5. #5
    jvslice Guest
    After checking other sources and help from others I was able to fix my problem.

    Here is what is did:

    su -
    rm -f /var/lib/rpm/__db.00*
    rpm -e --allmatches --nodeps <list of files which indicated that where duplicate"
    rpm --rebuilddb
    apt-get -f install

    NOTE: when I did this apt-get found one more file "openoffice.org-libs" , I guess that I didnot see this message when I first go in trouble

    re did the above procedure, installed the deleted files using synaptic and all is well

    thanks to all

Similar Threads

  1. Yum installation errors on multiple packages
    By Doug_Vitale in forum Using Fedora
    Replies: 12
    Last Post: 10th September 2007, 09:14 PM
  2. Replies: 6
    Last Post: 8th June 2005, 10:33 AM
  3. multiple version of packages installed
    By bakwas_internet in forum Using Fedora
    Replies: 1
    Last Post: 21st March 2004, 07:53 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •