MPlayer was compiled without libfaac. See README or DOCS
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 16
  1. #1
    Join Date
    Jul 2006
    Location
    Transgression
    Age
    40
    Posts
    1,182
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question MPlayer was compiled without libfaac. See README or DOCS

    Code:
    [root@hate ~]# yum provides "*libfaac*"
    Loaded plugins: presto, refresh-packagekit
    adobe-linux-i386/filelists                               | 140 kB     00:01     
    updates/filelists_db                                     | 3.6 MB     00:21     
    
    faac-1.28-2.fc12.x86_64 : Encoder and encoding library for MPEG2/4 AAC
    Repo        : installed
    Matched from:
    Other       : libfaac.so.0()(64bit)
    Filename    : /usr/lib64/libfaac.so.0
    Filename    : /usr/share/doc/faac-1.28/libfaac.pdf
    Filename    : /usr/share/doc/faac-1.28/libfaac.html
    Filename    : /usr/lib64/libfaac.so.0.0.0
    
    
    
    faac-devel-1.28-2.fc12.x86_64 : Development libraries of the FAAC AAC encoder
    Repo        : installed
    Matched from:
    Filename    : /usr/lib64/libfaac.so
    This did not work:
    Code:
    yum reinstall mplayer mencoder
    Neither did this:
    Code:
    yum remove mplayer mencoder
    yum -y install mplayer mplayer-gui mencoder
    Any ideas how to get around this?

  2. #2
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    8,151
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    faac is the AAC encoder. Did you also install the AAC decoder? faad2 ? To playback AAC files you need the decoder.

  3. #3
    Join Date
    Jul 2006
    Location
    Transgression
    Age
    40
    Posts
    1,182
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yeah, i have faad, faac, faad2, etc all installed, and most all multimedia codecs in general, as i do a lot of transcoding...

    Thanx.

  4. #4
    Join Date
    Mar 2004
    Posts
    617
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    In order to get around mplayer not being compiled with faac, you will need to recompile the src.rpm. According to this email (regarding ffmepg but would cover all multimedia software) the faac license is not gpl compliant. Therefore, they cannot compile any software which links to faac without disabling gpl portions.

    --SN

  5. #5
    Join Date
    Jul 2006
    Location
    Transgression
    Age
    40
    Posts
    1,182
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Wow, that sucks. Well, thanks for the info; i guess i have to get around to doing it. I just wonder what the faac license IS then.........

    Thanx

  6. #6
    Join Date
    Mar 2004
    Posts
    617
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    According to this, the faac license can be found in the README file which should be located in /usr/share/doc/faac-1.28/.

    I understand your frustration as well. There are many packages that I use which use faac or lame and I need to constantly recompile from the src.rpm. I guess it gives my cpu something to do instead of idle.

    --SN

  7. #7
    Join Date
    Jul 2006
    Location
    Transgression
    Age
    40
    Posts
    1,182
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ok, now for the million dollar question:

    How do i recompile mplayer from src.rpm to include the rpms that i have to faac and faad? I know how to "compile", in general, but i'm sure that this is going to be different since i have faad and faac rpms installed, and i've never compiled from a source rpm before (i don't know what to do with them).

  8. #8
    Join Date
    Mar 2004
    Posts
    617
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    First, be sure faac-devel and faad-devel are installed. Next, from the command line, run rpmbuild --rebuild --with faac mplayer-1.0-0.111.20091029svn.fc12.src.rpm (or whatever the .src.rpm is named).

    --SN

  9. #9
    Join Date
    Jul 2006
    Location
    Transgression
    Age
    40
    Posts
    1,182
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Great! Thanks for the help; i didn't really want to learn ffmpeg's commands when i already know mencoder so well

    ---------- Post added at 12:55 AM CST ---------- Previous post was at 12:47 AM CST ----------

    Code:
    [root@hate ~]# rpmbuild --rebuild --with faac mplayer-1.0-0.111.20091029svn.fc12.src.rpm
    error: cannot open mplayer-1.0-0.111.20091029svn.fc12.src.rpm: No such file or directory
    
    [root@hate ~]# yum install  mplayer-1.0-0.111.20091029svn.fc12.src.rpm
    No package mplayer-1.0-0.111.20091029svn.fc12.src.rpm available.
    
    [root@hate ~]# yum list  mplayer*.src.rpm --enablerepo=*
    Error: No matching Packages to list
    [root@hate ~]#
    I'm still new, so uhhh, how do i FIND the src.rpm?
    Thanks

  10. #10
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    8,151
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Code:
    # yum install rpm-build rpmdevtools redhat-rpm-config
    Code:
    $ yumdownloader --source mplayer
    As a regular user, in your regular user home directory, do:
    Code:
    $ rpmdev-setuptree
    $ rpmbuild --rebuild --with faac mplayer-1.0-0.111.20091029svn.fc12.src.rpm
    Of course, if the .src.rpm file isn't in the directory that you issue the rpmbuild command from, include the full path to it.

    If it builds, you'll find the new mplayer rpm in ~/rpmbuild/RPMS/i686/. Chances are fairly high, however, that you'll still be missing a few *-devel rpm packages that you'll have to install before it will succeed.

  11. #11
    Join Date
    Jul 2006
    Location
    Transgression
    Age
    40
    Posts
    1,182
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks man, i got most of the way through this, but i keep getting stuck on an error:
    Code:
    [Vector@hate Desktop]$ rpmbuild --rebuild --with faac mplayer-1.0-0.111.20091029svn.fc12.src.rpm
    ....
    warning: user mockbuild does not exist - using root
    warning: group mockbuild does not exist - using root
    error: line 37: Unknown tag:  BuildRequires:  faac-devel
    [Vector@hate Desktop]$
    But i DO have faac-devel install, as well as faad-devel and faac2-devel....

  12. #12
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    8,151
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    That should probably be "--with-faac" instead of "--with faac". Try that and see if it flies any better. I just did a copy and paste from SuperNu's post with his command line for the mplayer rebuild and didn't catch that.

    ---------- Post added at 10:48 PM CST ---------- Previous post was at 10:33 PM CST ----------

    Maybe also look at the output of, and maybe post it here, of:
    Code:
    cat ~/rpmbuild/SPECS/mplayer*spec | grep BuildRequires
    Last edited by PabloTwo; 6th January 2010 at 04:45 AM.

  13. #13
    Join Date
    Jul 2006
    Location
    Transgression
    Age
    40
    Posts
    1,182
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Code:
    [Vector@hate Desktop]$ rpmbuild --rebuild --with-faac mplayer-1.0-0.111.20091029svn.fc12.src.rpm
    --with-faac: unknown option
    [Vector@hate Desktop]$ rpmbuild --rebuild --with=faac mplayer-1.0-0.111.20091029svn.fc12.src.rpm
    --with=faac: unknown option
    [Vector@hate Desktop]$ 
    [Vector@hate Desktop]$ cat ~/rpmbuild/SPECS/mplayer*spec | grep BuildRequires
    BuildRequires:  SDL-devel
    BuildRequires:  a52dec-devel
    BuildRequires:  aalib-devel
    BuildRequires:  alsa-lib-devel
    BuildRequires:  cdparanoia-devel
    BuildRequires:  desktop-file-utils
    BuildRequires:  em8300-devel
    BuildRequires:  enca-devel
    %{?_with_faac: BuildRequires:  faac-devel}
    BuildRequires:  faad2-devel >= %{faad2min}
    BuildRequires:  fontconfig-devel
    BuildRequires:  freetype-devel >= 2.0.9
    BuildRequires:  fribidi-devel
    BuildRequires:  giflib-devel
    BuildRequires:  gtk2-devel
    BuildRequires:  ladspa-devel
    BuildRequires:  lame-devel
    BuildRequires:  libGL-devel
    BuildRequires:  libXinerama-devel
    BuildRequires:  libXScrnSaver-devel
    BuildRequires:  libXv-devel
    BuildRequires:  libXvMC-devel
    BuildRequires:  libXxf86dga-devel
    BuildRequires:  libXxf86vm-devel
    BuildRequires:  libcaca-devel
    BuildRequires:  libdca-devel
    BuildRequires:  libdv-devel
    BuildRequires:  libdvdnav-devel >= 4.1.3-1
    BuildRequires:  libjpeg-devel
    BuildRequires:  libmpcdec-devel
    BuildRequires:  libtheora-devel
    BuildRequires:  libvdpau-devel
    BuildRequires:  libvorbis-devel
    BuildRequires:  lirc-devel
    BuildRequires:  live555-devel
    BuildRequires:  lzo-devel >= 2
    BuildRequires:  pulseaudio-lib-devel
    BuildRequires:  schroedinger-devel
    BuildRequires:  speex-devel >= 1.1
    BuildRequires:  twolame-devel
    BuildRequires:  x264-devel >= 0.0.0-0.26.20091026
    BuildRequires:  xvidcore-devel >= 0.9.2
    BuildRequires:  yasm
    %{?_with_arts:BuildRequires: arts-devel}
    %{!?_without_amr:BuildRequires: opencore-amr-devel}
    %{?_with_directfb:BuildRequires: directfb-devel}
    %{?_with_esound:BuildRequires: esound-devel}
    %{?_with_jack:BuildRequires: jack-audio-connection-kit-devel}
    %{?_with_libmad:BuildRequires:  libmad-devel}
    %{?_with_nemesi:BuildRequires:  libnemesi-devel >= 0.6.3}
    %{?_with_openal:BuildRequires: openal-devel}
    %{?_with_samba:BuildRequires: libsmbclient-devel}
    %{?_with_svgalib:BuildRequires: svgalib-devel}
    %{?_with_xmms:BuildRequires: xmms-devel}
    BuildRequires:  docbook-dtds
    BuildRequires:  docbook-style-xsl
    BuildRequires:  libxml2
    BuildRequires:  libxslt
    [Vector@hate Desktop]$
    Ha, i think that i'll just sit down for a day and read ffmpeg's manual again, and drop mencoder. Thanks for the help.

  14. #14
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    8,151
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Well, it appears that "--with faac" was the correct syntax, as that didn't throw off any error when you used it the first time around. I would have to look over the whole mplayer spec file to understand

    %{?_with_faac: BuildRequires: faac-devel}

    And even then, I'm not sure I would as that is a bit unfamiliar to me. That line might be inside a 'conditional' statement. I'd suggest having a good read of the mentioned README and/or DOC file. You might get a better explanation of what needs to be done. You could find those files either from your current installed mplayer or in ~/rpmbuild/BUILD/mplayer*/somewhere

  15. #15
    Join Date
    Feb 2010
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I know this is a little old, but I ran into the same problem rebuilding with faac and I think I found the problem. I wanted to post in case anyone else ran into the same problem. Apparently, whoever made the faac support conditional in the spec file added an extra space which causes the error you listed above. For me, replacing:

    %{?_with_faac: BuildRequires: faac-devel}
    %{?_with_faac:BuildRequires: faac-devel}

    in the spec file got it working again. Of course I don't know how to replace the spec file in the actual source rpm, so I had to edit it in my rpmbuild tree and then rebuild with "rpmbuild -ba --with faac SPECS/mplayer.spec" from there instead. Such a simple thing as a misplaced space to cause me such frustration.

    Edit: Apparently, I could have just used -bs with rpmbuild to get the source package. Learn something new every day when you read the man pages...
    Last edited by phil4v7; 5th February 2010 at 04:53 PM.

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Enabling libfaac in ffmpeg
    By djbushido in forum Using Fedora
    Replies: 9
    Last Post: 27th November 2009, 09:31 PM
  2. unable to yum libfaac
    By samfraser in forum Using Fedora
    Replies: 3
    Last Post: 23rd September 2009, 02:27 PM
  3. Replies: 0
    Last Post: 31st August 2009, 06:37 AM
  4. Replies: 6
    Last Post: 9th October 2008, 09:28 PM
  5. libfaac?
    By frharris27 in forum Installation, Upgrades and Live Media
    Replies: 3
    Last Post: 8th May 2006, 04:04 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •