FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2007
    Posts
    367

    touchpad: Once disabled, always disabled

    I once disabled my touchpad because I would rub against it while typing and it would move my mouse elsewhere. I have since re-enabled it from the same place (system -> preferences -> pointing device) but it remains disabled at next boot up.

    I know it's a per-user setting, because when I logon as another user to the same laptop, touchpad remains enabled..

    Not having a mouse around and a touchpad that is disabled is most distressing, as I get stuck! Anyone know how to renable the mouse for a user, or just to reset the settings of the touchpad..

    -turgut

  2. #2
    Join Date
    Jul 2009
    Posts
    1,234
    I have the opposite problem. After every reboot, the touchpad reenables itself. I want the touchpad to stay off until I tell the software to enable it again. I also use System > Preferences > Pointing Device.
    Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)

  3. #3
    Join Date
    Oct 2005
    Posts
    309
    Quote Originally Posted by tkalfaoglu
    I once disabled my touchpad because I would rub against it while typing and it would move my mouse elsewhere. I have since re-enabled it from the same place (system -> preferences -> pointing device) but it remains disabled at next boot up.

    I know it's a per-user setting, because when I logon as another user to the same laptop, touchpad remains enabled..

    Not having a mouse around and a touchpad that is disabled is most distressing, as I get stuck! Anyone know how to renable the mouse for a user, or just to reset the settings of the touchpad..

    -turgut
    Try to issue this command as a normal user
    Code:
    synclient TapButton1=1
    This should enable tapping for the current user.. If it works, then you can make this command auto executed after each reboot
    Code:
    [Faris@localhost ~]$ cat /dev/urandom > /dev/dsp
    http://farisguides.webs.com

  4. #4
    Join Date
    Jul 2009
    Posts
    1,234
    I found the solution to my problem. Uninstall gpointing-device-settings and install gsynaptics with the following command...
    Code:
    rpm -Uvh --oldpackage ftp://mirrors.kernel.org/fedora/releases/11/Everything/i386/os/Packages/gsynaptics-0.9.16-1.fc11.i586.rpm
    Then add gpointing* and gsynaptics* to the exclude list in /etc/yum.conf...
    Code:
    exclude=gsynaptics* gpointing*
    Finally, disable the touchpad in System > Preferences > Touchpad.

    EDIT: Bug report filed... https://bugzilla.redhat.com/show_bug.cgi?id=528485
    Last edited by David Batson; 12th October 2009 at 02:24 PM.
    Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)

Similar Threads

  1. touchpad: Says disabled, but works anyway
    By tkalfaoglu in forum Hardware & Laptops
    Replies: 2
    Last Post: 31st January 2009, 04:16 AM
  2. Touchpad mouse won't stay disabled
    By theAdmiral in forum Hardware & Laptops
    Replies: 2
    Last Post: 30th November 2008, 06:17 PM
  3. Touchpad cannot be disabled in Fedora 10
    By findparadise in forum Alpha, Beta & Snapshots Discussions (Fedora 10 Only)
    Replies: 2
    Last Post: 6th November 2008, 06:55 PM
  4. Need help disabled a certain touchpad action
    By OP2Patriot in forum Hardware & Laptops
    Replies: 3
    Last Post: 4th September 2007, 02:36 PM
  5. Synaptics touchpad disabled at login
    By WebRuss in forum Hardware & Laptops
    Replies: 0
    Last Post: 23rd September 2006, 03:11 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •