GRUB does not load on MBR using LiveCD
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    Join Date
    Apr 2006
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unhappy GRUB does not load on MBR using LiveCD

    Hi,

    I had Win XP on my T61. I installed Fedora 11 from Gnome LiveCD. Now I cant even see GRUB. The laptop boots directly into Win XP.

    I had the partitions like this:

    /dev/sda1 - Win XP - NTFS - 75 GB
    /dev/sda2 - Win Recovery - NTFS - 5 GB
    /dev/sda3 - /boot - ext3 - 1 GB
    /dev/sda4 - Logical extended partition
    /dev/sda5 - / - ext4 - 10 GB
    /dev/sda6 - swap - 3 GB

    Installed GRUB on the MBR (/dev/sda, and not on any partition). Once i completed installing Fedora 11 from the LiveCD and rebooted, the laptop directly boots into Win XP. No sign of Fedora there.

    How do I get to install GRUB now? Can anyone help me please?

    Thanks,
    Kris

  2. #2
    Join Date
    Jun 2006
    Posts
    7,544
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hello dakaujunk,

    It's not uncommon for GRUB to be busted or misconfigured immediately after a new installation. But it's rare IMO for Anaconda not to do the default boot loader option of installing GRUB stage1 in the master boot record of the drive that boots from BIOS when that option is not changed. Anyway, you can teach yourself how to re-install GRUB using that LiveCD in another thread here...That thread also mentions the Super Grub Disk which is an alternative method.

  3. #3
    Join Date
    Apr 2006
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi stoat,

    I have got quite a unique experience I guess. I have tried the following:

    SGD using a CDROM - complains there is no GRUB to find or install
    Fedora 11 DVD ISO - installation goes fine, but GRUB does not install. After restart, boots up straight into Win XP.

    The laptop does not have any aversion to Linux, since i had Mint 7 running on this before. Is there any way I can get GRUB to install on my laptop with Fedora 11?

    Thanks.

  4. #4
    Join Date
    Jun 2006
    Posts
    7,544
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by dakaujunk

    Is there any way I can get GRUB to install on my laptop with Fedora 11?
    Maybe. It's supposed to happen by default during installation. You have to stop it from happening. After-the-fact, you can re-install GRUB with the LiveCD (already mentioned) or with the DVD in rescue mode (heavily documented here). But GRUB has to have been installed in the first place for it to re-install. That's something I'm beginning to think did not happen. You can check by booting with the LiveCD, mounting the boot partition on the hard drive, and examining the contents of the /boot/grub folder. If GRUB was installed, it will contain about a dozen files including some GRUB stage1_5 image files, stage1, stage2, grub.conf, menu.lst, device.map, splash.xpm.gz. If GRUB was not installed, usually only the splashscreen file is sitting there. If that is the situation, then I don't know how to fix this.

    P.S.: If you never get to the bottom of this mystery, consider re-installing but this time choose the option to install GRUB in the first sector of the Fedora boot partition. Then you can configure the Windows boot loader to boot Fedora. It's kind of a surrender. But look, I boot Fedora that way by choice. It's not so bad.
    Last edited by stoat; 19th September 2009 at 02:57 AM.

  5. #5
    Join Date
    Apr 2006
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks stoat for the responsive comments. I figured the issue and a solution.

    As you said, I tried the option to install GRUB on the partition (instead of MBR) and it worked very differently. When I elected to install GRUB only on the install partition (/dev/sda3 in my case), GRUB was installed on MBR (quite surprising, considering thats what I needed in the first place). This seems to have been a reported issue in one of the RC versions(release candidate or some version similar to that). For some reason, this bug seems to bite ppl like me.

    Anyway, thanks a bunch for helping with comments.

  6. #6
    Join Date
    Jun 2006
    Posts
    7,544
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You know, I very faintly remember hearing of that before. Maybe some months ago. It would be interesting to read that again, but it sounds like something impossible to find.

Similar Threads

  1. How to REINSTALL GRUB with LiveCD F10
    By goxi in forum Using Fedora
    Replies: 17
    Last Post: 24th August 2011, 12:35 PM
  2. LiveCD, grub and MBR
    By juszczec in forum Installation, Upgrades and Live Media
    Replies: 2
    Last Post: 1st March 2008, 11:33 PM
  3. Fedora 7 Install off LiveCD Ends at grub prompt
    By mowestusa in forum Installation, Upgrades and Live Media
    Replies: 20
    Last Post: 19th July 2007, 02:20 AM
  4. GRUB won't load
    By ShibbyCoder in forum Using Fedora
    Replies: 1
    Last Post: 7th June 2005, 03:55 AM
  5. GRUB Won't Load... HELP!
    By spoon in forum Using Fedora
    Replies: 4
    Last Post: 7th June 2004, 05:00 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •