Fedora 11 Xorg troubles
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2008
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Fedora 11 Xorg troubles

    I have a 4 display setup on this dell fedora box
    1 single head nvidia card
    1 dual head nvidia card
    plus the on-board intel video

    All 4 screen worked fine under Fedora 10 w / this xorg.conf
    Quote:
    # nvidia-settings: X configuration file generated by nvidia-settings

    # nvidia-settings: version 1.0 (buildd@crested) Mon Nov 3 08:46:04 UTC 2008



    Section "ServerLayout"

    Identifier "Layout0"

    Screen 0 "Screen0" 1280 0

    Screen 1 "Screen1" LeftOf "Screen0"

    Screen 2 "Screen2" RightOf "Screen0"

    Screen 3 "Screen3" RightOf "Screen2"

    InputDevice "Keyboard0" "CoreKeyboard"

    InputDevice "Mouse0" "CorePointer"

    EndSection



    Section "Files"

    EndSection



    Section "Module"

    Load "dbe"

    Load "extmod"

    Load "type1"

    Load "freetype"

    Load "glx"

    EndSection



    Section "ServerFlags"

    Option "Xinerama" "0"

    EndSection



    Section "InputDevice"

    # generated from default

    Identifier "Mouse0"

    Driver "mouse"

    Option "Protocol" "auto"

    Option "Device" "/dev/psaux"

    Option "Emulate3Buttons" "no"

    Option "ZAxisMapping" "4 5"

    EndSection



    Section "InputDevice"

    # generated from default

    Identifier "Keyboard0"

    Driver "kbd"

    EndSection



    Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid

    Identifier "Monitor0"

    VendorName "Unknown"

    ModelName "DELL E173FP"

    HorizSync 31.0 - 80.0

    VertRefresh 56.0 - 75.0

    Option "DPMS"

    EndSection



    Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid

    Identifier "Monitor1"

    VendorName "Unknown"

    ModelName "DELL E196FP"

    HorizSync 31.0 - 83.0

    VertRefresh 56.0 - 75.0

    Option "DPMS"

    EndSection



    Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid

    Identifier "Monitor2"

    VendorName "Unknown"

    ModelName "CND 17 TFTHMM-F207"

    HorizSync 30.0 - 80.0

    VertRefresh 56.0 - 75.0

    Option "DPMS"

    EndSection



    Section "Monitor"

    Identifier "Monitor3"

    VendorName "Unknown"

    ModelName "Unknown"

    HorizSync 30.0 - 70.0

    VertRefresh 56.0 - 65.0

    EndSection





    Section "Device"

    Identifier "Device0"

    Driver "nvidia"

    VendorName "NVIDIA Corporation"

    BoardName "GeForce FX 5200"

    BusID "PCI:4:0:0"

    Screen 0

    EndSection



    Section "Device"

    Identifier "Device1"

    Driver "nvidia"

    VendorName "NVIDIA Corporation"

    BoardName "GeForce FX 5200"

    BusID "PCI:4:0:0"

    Screen 1

    EndSection



    Section "Device"

    Identifier "Device2"

    Driver "nvidia"

    VendorName "NVIDIA Corporation"

    BoardName "GeForce FX 5200"

    BusID "PCI:4:2:0"

    # Screen 3

    EndSection



    Section "Device"

    Identifier "Device3"

    #Driver "i810"

    # VendorName "Intel"

    BoardName "945G"

    # Option "AddARGBGLXVisuals" "True"

    # BusID "0:2:0"

    Driver "intel"

    VendorName "Intel Corporation"

    # BoardName "Mobile 915GM/GMS/910GML Express Graphics Controller"

    BusID "PCI:0:2:0"

    Option "NoAccel" "true"

    # Screen 2

    EndSection



    Section "Screen"

    Identifier "Screen0"

    Device "Device0"

    Monitor "Monitor0"

    DefaultDepth 24

    Option "TwinView" "0"

    Option "TwinViewXineramaInfoOrder" "CRT-0"

    #Option "metamodes" "CRT-0: nvidia-auto-select +0+0"

    SubSection "Display"

    Depth 24

    EndSubSection

    EndSection



    Section "Screen"

    Identifier "Screen1"

    Device "Device1"

    Monitor "Monitor1"

    DefaultDepth 24

    Option "TwinView" "0"

    #Option "metamodes" "CRT-1: nvidia-auto-select +0+0"

    SubSection "Display"

    Depth 24

    EndSubSection

    EndSection



    Section "Screen"

    Identifier "Screen2"

    Device "Device3"

    Monitor "Monitor3"

    DefaultDepth 24

    #Option "TwinView" "0"

    #Option "TwinViewXineramaInfoOrder" "CRT-0"

    #Option "metamodes" "nvidia-auto-select +0+0"

    SubSection "Display"

    Depth 24

    EndSubSection

    EndSection



    Section "Screen"

    Identifier "Screen3"

    Device "Device2"

    Monitor "Monitor2"

    DefaultDepth 24

    #Option "metamodes" "CRT-0: nvidia-auto-select +0+0"

    Option "Composite" "Enable"

    Option "RenderAccel" "True"

    Option "AddARGBGLXVisuals" "True"

    SubSection "Display"

    Depth 24

    EndSubSection

    EndSection




    but the box is now running Fedora11 and the display using the intel only works until the nividia drivers loads .. had this same problem in fedora 10 but fixed it by adding
    Option "NoAccel" "true"

    Here is the xorg.conf file that I use for Fedora 11 with the intel driver commented out
    Quote:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings: version 1.0 (buildmeister@builder62) Mon Mar 2 15:58:06 PST 2009


    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 1280 0

    Screen 1 "Screen1" LeftOf "Screen0"

    Screen 2 "Screen2" RightOf "Screen0"

    Screen 3 "Screen3" RightOf "Screen2"
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    EndSection

    Section "Files"
    FontPath "/usr/share/fonts/default/Type1"
    EndSection

    Section "Module"
    Load "dbe"
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx"
    EndSection

    Section "ServerFlags"
    Option "Xinerama" "0"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/input/mice"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"

    # generated from data in "/etc/sysconfig/keyboard"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbLayout" "us"
    Option "XkbModel" "pc105"
    EndSection

    Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "DELL E196FP"
    HorizSync 31.0 - 83.0
    VertRefresh 56.0 - 75.0
    Option "DPMS"
    EndSection

    Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier "Monitor1"
    VendorName "Unknown"
    ModelName "DELL E173FP"
    HorizSync 31.0 - 80.0
    VertRefresh 56.0 - 75.0
    Option "DPMS"
    EndSection

    Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier "Monitor2"
    VendorName "Unknown"
    ModelName "CND 17 TFTHMM-F207"
    HorizSync 30.0 - 80.0
    VertRefresh 56.0 - 75.0
    Option "DPMS"
    EndSection

    Section "Monitor"

    Identifier "Monitor3"

    VendorName "Unknown"

    ModelName "Unknown"

    HorizSync 30.0 - 70.0

    VertRefresh 56.0 - 65.0

    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce FX 5200"
    BusID "PCI:4:0:0"
    Screen 0
    EndSection

    Section "Device"
    Identifier "Videocard1"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce FX 5200"
    BusID "PCI:4:0:0"
    Screen 1
    EndSection

    Section "Device"
    Identifier "Videocard2"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce FX 5200"
    BusID "PCI:4:2:0"
    EndSection

    Section "Device"

    Identifier "Videocard3"

    BoardName "945G"
    # Driver "intel"

    VendorName "Intel Corporation"

    BusID "PCI:0:2:0"

    Option "NoAccel" "true"

    # Screen 2

    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinView" "0"
    Option "TwinViewXineramaInfoOrder" "CRT-0"
    Option "metamodes" "CRT-0: nvidia-auto-select +0+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

    Section "Screen"
    Identifier "Screen1"
    Device "Videocard1"
    Monitor "Monitor1"
    DefaultDepth 24
    Option "TwinView" "0"
    Option "metamodes" "CRT-1: nvidia-auto-select +0+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

    Section "Screen"
    Identifier "Screen2"
    Device "Videocard3"
    Monitor "Monitor3"
    DefaultDepth 24
    Option "TwinView" "0"
    Option "TwinViewXineramaInfoOrder" "CRT-0"
    Option "metamodes" "nvidia-auto-select +0+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

    Section "Screen"

    Identifier "Screen3"

    Device "Videocard2"

    Monitor "Monitor2"

    DefaultDepth 24

    #Option "metamodes" "CRT-0: nvidia-auto-select +0+0"

    Option "Composite" "Enable"

    Option "RenderAccel" "True"

    Option "AddARGBGLXVisuals" "True"

    SubSection "Display"

    Depth 24

    EndSubSection

    EndSection



    If i remove the # to let the intel driver load none of the displays work


    Any suggestions?

  2. #2
    Join Date
    Dec 2004
    Posts
    512
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Your /var/log/Xorg.0.log should give clues. I had similar problems (quite a while ago) and the issue was getting xorg to associate the right driver with the right screen. It changed on an upgrade and seemed a bit random. In particular, it did not seem to use the all the information in xorg.conf to determine this, so I ended up just trying different permutations until it worked.

  3. #3
    Join Date
    Aug 2008
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    any suggestions on permutations that you tried .. my xorg.0.log giv nothing useful to go on

Similar Threads

  1. fedora 10 yum troubles
    By leedude in forum Using Fedora
    Replies: 3
    Last Post: 13th December 2008, 08:41 PM
  2. fedora 8+xgl troubles :(
    By stephanie.steve in forum Using Fedora
    Replies: 0
    Last Post: 21st December 2007, 03:35 PM
  3. Yet another SB live troubles on Fedora 5
    By ishaypeled in forum Hardware & Laptops
    Replies: 5
    Last Post: 9th June 2006, 04:24 AM
  4. Fedora boot troubles
    By mrmemnoch in forum Using Fedora
    Replies: 10
    Last Post: 9th January 2006, 02:57 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •