rpmlib(FileDigests) <= 4.6.0-1 is needed by
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2008
    Posts
    280
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    rpmlib(FileDigests) <= 4.6.0-1 is needed by

    What does this error message mean?

    rpmlib(FileDigests) <= 4.6.0-1 is needed by pcsc-lite-1.5.2-2.fc12.i586

    I received it when trying to install the pcsc-lite rpm file with "rpm -ivh".

    Jim

  2. #2
    Join Date
    Sep 2006
    Location
    Connellsville, PA, USA
    Posts
    11,308
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It means that the RPM has been compiled on a Fedora Release with a higher (lower?) version of the RPM package than you currently have - i.e.: one which provides 'rpmlib(FileDigests) <= 4.6.0-1'. Why are you trying to install an F12 version of this package, and what is your current Fedora Release and arch?

    V

    P.S. I've seen this message, and there's no way around, even with '--force' and such: your RPM version does not support this feature.
    Last edited by Hlingler; 1st July 2009 at 11:29 PM.

  3. #3
    Join Date
    Oct 2005
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: rpmlib(FileDigests) <= 4.6.0-1 is needed by

    Yes it seems a small PITA.
    rpmlib(FileDigests) <= 4.6.0-1 is needed by ted-2.21-1.i586

Similar Threads

  1. F10 Help Needed ?
    By Dark Star in forum Using Fedora
    Replies: 1
    Last Post: 28th December 2008, 07:26 PM
  2. problem by rpmlib(PayloadIsLzma)
    By jam_gha in forum Using Fedora
    Replies: 0
    Last Post: 3rd December 2008, 04:51 PM
  3. What Cds Are Needed?
    By ihavenoname in forum Fedora Core 5 - Dev
    Replies: 3
    Last Post: 19th March 2006, 01:43 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •