F11 Boot Failure with Blinking Cursor and Message with Readahead In It
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 19
  1. #1
    Join Date
    Nov 2007
    Posts
    198

    Question F11 Boot Failure with Blinking Cursor and Message with Readahead In It

    I shutdown my MacBook 5,1 last night only to find this morning that it won't boot. I first received a fairly lengthy technical message (which I share what I wrote below) but after my second attempt at booting, the message was gone but it was still the same problem with a blinking cursor in the upper left hand corner and nothing else. When I hit the power button, it shows all of the kernel messages booting down like "Stopping Bluetooth Services [OK]".

    The message went something like this:
    audit(123456789): ...
    ...
    ...
    ...
    ...
    ... subj=system_u: system_r: readahead_t: s0 res=1
    I have a fairly vanilla install. Nothing crazy and it was just installed two or three days ago with updates applied right away. I do have akmod-nividia and akmod-wl packages installed. I also have it dual booting with Mac OSX.

    Any suggestions? The most information I have found online is this link here, but it wasn't much help at all. It may be suggesting a problem with Selinux?

    I appreciate any help. Thanks in advance.

  2. #2
    Join Date
    Nov 2007
    Posts
    198
    So, I tried disabling selinux by adding "selinux=0" to the fedora kernel line in the grub.conf file. This enabled me to get to my desktop again. I can use this as a fix, but I'd rather know that I have the security and such. Is there a better way?

  3. #3
    Join Date
    Nov 2007
    Posts
    198
    D'oh!

    I installed some updates which included some selinux updates and now I'm back in the same position as before. I was able to switch into a CLI mode using ctrl + alt + f1 and run dmesg. I'm not sure if this helps, but I got a message saying
    vmap allocation for size 16781312 failed:
    use vmalloc=<size> to increase size
    NVRM: RmInitAdapter failed!
    ...
    rm_init_adapter(0) failed

  4. #4
    Join Date
    Sep 2006
    Location
    Connellsville, PA, USA
    Posts
    11,308
    Looks like maybe the problem with nvidia driver from RPMFusion that's been biting others as well. Search forums, should be easy to find. Work-around posted (downgrade).

    V

  5. #5
    Join Date
    Nov 2007
    Posts
    198
    So, it was as simple as changing my xorg.conf file. Changing nvidia to nv in the Driver line worked.

    Code:
    Section "Device"
    	Identifier  "Videocard0"
    	Driver      "nv"
    	Option	    "AddARGBGLXVisuals" "True"
    EndSection

  6. #6
    Join Date
    Mar 2008
    Location
    The Great Inland Northwest
    Posts
    216
    Hi SendDerek,
    I wanted to read about your "Simple Web Server Tutorial"...But, the link doesn't work.

  7. #7
    Join Date
    Nov 2007
    Posts
    198
    Quote Originally Posted by sdlor
    Hi SendDerek,
    I wanted to read about your "Simple Web Server Tutorial"...But, the link doesn't work.
    Haha... oops. I'll fix that ASAP.

    In the meantime, I can't get the 'nv' change to stick. It resets itself on reboot everytime. I have the akmod-nvidia package installed, I wonder if it needs to be removed. Is there a command that sets the xorg.conf in stone?

  8. #8
    Join Date
    Sep 2006
    Location
    Connellsville, PA, USA
    Posts
    11,308
    Open livna-config-display from the menus, and tell it to keep it's paws off of xorg.conf (un-check the box that allows it to edit xorg.conf).

    V

  9. #9
    Join Date
    Nov 2007
    Posts
    198
    Quote Originally Posted by Hlingler
    Open livna-config-display from the menus, and tell it to keep it's paws off of xorg.conf (un-check the box that allows it to edit xorg.conf).

    V
    Wow... instant response. Thanks.

    It wouldn't happen to be able to be controlled through the command line would it? That's all I got right now (again). I'll give it a shot.

    Edit: Yup! Apparently there's a command line utility as well. This is right from the livna-config-display package site:
    If you would like to prevent the drivers from autoediting your xorg.conf any further, simply launch livna-config-display from the menu or by executing livna-config-display from a terminal and untick the option allowing livna-config-display to edit the configuration files. From this point on, the graphic driver's init service will still launched but no further modifications are made.
    Last edited by SendDerek; 20th June 2009 at 03:24 PM.

  10. #10
    Join Date
    Nov 2007
    Posts
    198
    Nope. I was wrong. There's no command line tool for that one. Is there a file I should edit or another command I need to run I wonder?

  11. #11
    Join Date
    Nov 2007
    Posts
    198
    Okay, I found the command line version of it.

    Code:
    livna-config-display --active false
    I tried it, rebooted, and got the blinking cursor. The good news is that the xorg.conf file wasn't modified. Looks like it's back to dmesg and var logs...

  12. #12
    Join Date
    Sep 2006
    Location
    Connellsville, PA, USA
    Posts
    11,308
    Yes, but who was the last to edit xorg.conf, you or livna-config-display? What driver does it currently specify?? I'm a bit baffled as to why simply un-checking that option would result in failure of X to start.

    V

  13. #13
    Join Date
    Nov 2007
    Posts
    198
    It's stuck at the "nv" driver option within xorg.conf that I was mentioning earlier. I'll be taking a look at it again soon.

  14. #14
    Join Date
    Nov 2007
    Posts
    198
    Huh.. well, strange. I kept having the same problem again and again. I was frustrated and changed "nv" back to "nvidia" and it's working again. Hah!

    I'll keep it.

    Thanks for all of your help. Who knows, I might be back here before long!

  15. #15
    Join Date
    Nov 2007
    Posts
    198
    Welp, I'm back.

    Very shortly after my last post, it started acting up again. It's strange though, every now and again I'll get my desktop. This is after I've played around with settings long enough. Doesn't seem to be any rhyme or reason. I'll keep searching google and the forums...

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Blinking Cursor
    By unix66 in forum Using Fedora
    Replies: 0
    Last Post: 24th August 2009, 06:46 AM
  2. Nothing but a blinking cursor after grub
    By John5342 in forum Installation, Upgrades and Live Media
    Replies: 5
    Last Post: 18th June 2009, 02:04 PM
  3. Blinking Cursor
    By flyboy in forum Installation, Upgrades and Live Media
    Replies: 0
    Last Post: 8th September 2005, 02:20 PM
  4. FC3 install hangs with blinking cursor
    By mozy in forum EOL (End Of Life) Versions
    Replies: 6
    Last Post: 6th December 2004, 07:09 PM
  5. non-blinking cursor
    By wanderingidea in forum Using Fedora
    Replies: 3
    Last Post: 20th November 2004, 09:50 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •