Encountering errors upon attempted OOo install (rpmdb: PANIC: fatal region error...)
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 8 of 8
  1. #1
    Join Date
    Mar 2009
    Posts
    25
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Encountering errors upon attempted OOo install (rpmdb: PANIC: fatal region error...)

    This has happened twice with attempted install through yum:

    Code:
    Downloading Packages:    
    (1/4): openoffice.org-writer-3.0.1-15.3.fc10.i386.rpm                  | 121 kB     00:01     
    (2/4): openoffice.org-brand-3.0.1-15.3.fc10.i386.rpm                   | 426 kB     00:04     
    (3/4): openoffice.org-writer-core-3.0.1-15.3.fc10.i386.rpm             | 5.1 MB     01:00     
    (4/4): openoffice.org-core-3.0.1-15.3.fc10.i386.rpm                    |  90 MB     08:54     
    -------------------------------------------------------------------------------------------------------
    Total                                                                  161 kB/s |  95 MB     10:06     
    Running rpm_check_debug                                                                                                      
    Running Transaction Test                                                                                                     
    Finished Transaction Test                                                                                                    
    Transaction Test Succeeded                                                                                                   
    Running Transaction                                                                                                          
      Installing     : openoffice.org-core                                                              1/4 
    rpmdb: /var/lib/rpm/Packages page 5191 is on free list with type 7                                                           
    rpmdb: PANIC: Invalid argument                                                                                               
    rpmdb: PANIC: fatal region error detected; run recovery                                                                      
    rpmdb: PANIC: fatal region error detected; run recovery                                                                      
    rpmdb: PANIC: fatal region error detected; run recovery
    [...]
    I've done a yum-complete-transaction --clean-only and restart after each attempt. I just can't seem to get it to install. Any ideas?

  2. #2
    scottro's Avatar
    scottro is offline Retired Community Manager -- Banned from Texas by popular demand.
    Join Date
    Sep 2007
    Location
    NYC
    Posts
    8,120
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You might try

    rm /var/lib/rpm/_*
    rpm --rebuilddb

    And see if that helps.


    (To minimize risk, you could copy the db files in /var/lib/rpm first, with something like cp -r /var/lib/rpm/_* <somewhere>, and then run the commands.
    --
    http://srobb.net

  3. #3
    Join Date
    Mar 2009
    Posts
    25
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Why the underscore? There's no files in there starting with an underscore...

  4. #4
    scottro's Avatar
    scottro is offline Retired Community Manager -- Banned from Texas by popular demand.
    Join Date
    Sep 2007
    Location
    NYC
    Posts
    8,120
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hrrm, that's odd (though I'm looking at CentOS. )

    Is there anything in there ending with db in the name??
    In that case, copy them somewhere, then do the remove, changing the _* to *db*

    Then run the rebuilddb option mentioned above.

    Usually, one has various files named _db.001, _db.002 and the like.
    --
    http://srobb.net

  5. #5
    Join Date
    Mar 2009
    Posts
    25
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Here's the files in there:

    Code:
    Basenames     Dirnames     Group       Name      Providename     Pubkeys      Requireversion  Sigmd5
    Conflictname  Filedigests  Installtid  Packages  Provideversion  Requirename  Sha1header      Triggername

  6. #6
    scottro's Avatar
    scottro is offline Retired Community Manager -- Banned from Texas by popular demand.
    Join Date
    Sep 2007
    Location
    NYC
    Posts
    8,120
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hrrm, just checked on Fedora and there should definitely be some _db.001 and such files in there.

    Please try the

    rpm --rebuilddb

    and see if that helps.
    --
    http://srobb.net

  7. #7
    Join Date
    Mar 2009
    Posts
    25
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by scottro
    Hrrm, just checked on Fedora and there should definitely be some _db.001 and such files in there.

    Please try the

    rpm --rebuilddb

    and see if that helps.
    Odd. While the process ran, I saw those db files appear, but after it had ended, the files were gone...

  8. #8
    Join Date
    Aug 2006
    Location
    /dev/realm/{Abba,Carpenters,...stage}
    Posts
    3,285
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Gone ? That's a bit odd indeed. Did you try a reboot and start over with the db files ?
    For safer browsing, use OpenDNS nameservers 208.67.222.222 and 208.67.220.220

    SELinux User Guide

    AutoPager

Similar Threads

  1. rpmdb: PANIC: fatal region error detected; run recovery
    By icy-flame in forum Using Fedora
    Replies: 6
    Last Post: 1st August 2013, 05:53 PM
  2. rpmdb fatal error during FC6 install
    By davideg in forum EOL (End Of Life) Versions
    Replies: 1
    Last Post: 23rd March 2007, 04:03 AM
  3. Replies: 1
    Last Post: 6th January 2007, 02:29 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •