.xsession-error log - disable ?
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 8 of 8
  1. #1
    Join Date
    Mar 2009
    Location
    Europe
    Posts
    304
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    .xsession-error log - disable ?

    Hello everybody,

    I noticed the xsession-error file in my main user's home folder grow up to a big size, it's usually at 2-3MB sometimes up to 20MB. I use Fedora 10 64bit and KDE4.2. I got no problems at all and the xsession-error logfile is full of weird entrys, almost everything is reporting to it, mplayer, xine, opera, firefox, dolphin and many other software I use.
    I dont think the most of these entrys are real and critical system errors, especially all the mplayer stuff.
    However, i'm not worried about the file size since Fedora 10 seems to delete the file on every log in, my problem is the disc access because all this never ending writings to hard disc kinda break things like the mount options noatime, nodiratime.
    I read something about you can redirect the logfile to /dev/null but that was for an ubunto distribution and I would like to get a how to for a save way to disable the xsession-error logfile, I got 8GB RAM so everything is in cache anyway after a long session, I really want to get rid of unnessesary hard disc access like that. If not recommend to disable it, can I direct it to an usb stick or ssd ?

    Thanks in Advance

  2. #2
    Join Date
    Sep 2006
    Location
    Connellsville, PA, USA
    Posts
    11,308
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    IMHO, a Bad Idea™ to disable the logging of errors: if something goes wrong, you have no record. Suggest that you edit (as root user) /etc/kde/kdm/kdmrc to change the output file, find and edit this line:
    Code:
    [X-*-Core]
    # The file (relative to $HOME) to redirect the session output to. This is
    # a printf format string; one %d will be replaced with the display name.
    # Default is ".xsession-errors"
    #ClientLogFile=.xsession-errors-%d
    Remove the comment symbol (pound sign: #), and specify full PATH to output file if other than user's HOME folder, as noted.

    V

    P.S. For the record: I assumed from your post that you installed KDE spin, but note that this is not necessary with Fedora default GDM, since GDM limits .xsession-errors log file size to 2500 lines (IMHO: not a good move, but too many people complainted about large logs).

  3. #3
    Join Date
    Mar 2009
    Location
    Europe
    Posts
    304
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thank you Hlingler for the quick response

    Yes I am afraid of not having real errors logged, I will just try to change the output to a ssd/usb device to cut down
    hard drive access. I set KDM to default but use both KDE and GNOME desktops. I decoded a huge movie file in 1080p with avidemux today and the xsession-errors grew up to 126MB, after a restart it was gone so I guess I just live with these large log files.

    Thanks alot

  4. #4
    Join Date
    Sep 2006
    Location
    Connellsville, PA, USA
    Posts
    11,308
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hee! Hee! Hee! My record is: 1.6 GB !!!

    That was F9-KDE-Live out-of-the-box.

    V

    P.S. The log file is wiped every time you re-start the desktop.

    P.P.S. NOTE that a re-start of X11 is required to apply such a change of log file.

    P.P.P.S. Note that some apps spew out copious warnings: just open Acrobat Reader in your web browser, and you may get 5000+ lines of garbage, and that's if it works.

  5. #5
    Join Date
    Aug 2008
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Lol

    mine is 130 gig wtf

  6. #6
    Join Date
    Mar 2009
    Location
    Europe
    Posts
    304
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    .xsession-error log in fedora 12

    After all the problems with gigabyte sized xsession-error logfiles in previous fedoras i'm curious the file does not exist anymore in fedora 12. is there something i have missed in the release notes ? i have (gladly) no more .xsession-errors logfiles in my /home directory nor anywhere else. gdm/gnome only here.

    well I spoke too soon, that logfile is back and growing with useless debug info. how can i completely disable xsession-errors log in my home directory ? 20GB disc writes a day for an uneeded logfile kills my SSD
    Last edited by Milena; 16th January 2010 at 08:03 PM. Reason: problem is not fixed

  7. #7
    Join Date
    Mar 2009
    Location
    Europe
    Posts
    304
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    does anybody know how to disable this log or direct it to another folder ?

    i were trying some tricks, ln -s /dev/null xsession-errors did not help it still creates the file with another name. editing the /etc/X11/xinit/Xsession script did not help either,

  8. #8
    Join Date
    Mar 2009
    Location
    Europe
    Posts
    304
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    oh well nobody knows...this seems to be an annoying problem in every distribution. to share my solution with people who want to get rid of gigabyte sized xsession-errors full of firefox and ffmpeg debug info and what else:

    i made a small script and put it into the startup apps, it seems xinit does not create a new xsession-errors log once it has been erased at session startup.

    Code:
    #!/bin/sh
    # deletes ~/.xsession-errors at startup so it does not write gigabytes of debug info
    rm -f ~/.xsession-errors
    simple and maybe not the best solution but it works for me.

Similar Threads

  1. .xsession-errors: X Error BadMatch... errors
    By Hlingler in forum Using Fedora
    Replies: 0
    Last Post: 8th August 2007, 09:28 PM
  2. please help Xsession
    By talkstock888 in forum Using Fedora
    Replies: 2
    Last Post: 13th July 2007, 03:21 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •