Akonadi control process not registered at D-Bus.
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 9 of 9
  1. #1
    Join Date
    Feb 2009
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Akonadi control process not registered at D-Bus.

    Test 9 brings up this error:

    Code:
    Test 9:  ERROR
    --------
    
    Akonadi control process not registered at D-Bus.
    Details: The Akonadi control process is not registered at D-Bus which typically means it was not started or encountered a fatal error during startup.
    How can I solve this?

    F10 x86_64
    akonadi-1.0.0-4.fc10.x86_64
    mysql-5.0.67-2.fc10.x86_64
    Last edited by Gandharva; 8th February 2009 at 12:43 PM.

  2. #2
    Join Date
    Feb 2004
    Location
    Omaha, NE USA
    Age
    48
    Posts
    463
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Test 9 from what?

    What are you doing exactly when you see this?

  3. #3
    Join Date
    Jun 2008
    Location
    Saudi Arabia
    Posts
    41
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I am getting the same thing. I have just upgraded KDE 4.1 to KDE 4.2 (the realesed upgrade not the testing or beta) and after rebooting into KDE4.2 Akonadi will start but then will give me an error at test 9, the same thing Gandharva is getting.

    How to resolve this issue?

    ---My system---
    Fedora 10 i386
    qt-mysql-4.4.3-10.fc10.i386
    mysql-server-5.0.67-2.fc10.i386
    akonadi-1.1.1-1.fc10.i386
    Fahad Alduraibi
    http://fadvisor.net/

  4. #4
    Join Date
    Feb 2009
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    *push*

    Any solution out there?

  5. #5
    Join Date
    Jun 2008
    Location
    Saudi Arabia
    Posts
    41
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    After doing some search I found the problem (at least with my machine). It was caused by me using the root account. I am not sure if it is MySQL or Akonadi who does not like it when you are logged in as root. (I think it is MySQL by looking at there website and the generated error messages , but I can run MySQL as root myself with no problems, but Akonadi cannot do that while I am root).

    So when I logged in as a normal user every thing worked fine and Akonadi started successfully. I believe that there is a way to change MySQL security restriction to allow things to work as root, but I did not look into that.

    I hated Gnome because they force you to log in as normal user and don't want you to be root. and I see KDE now doing the same thing

    I don't like it when they force you to do something, it is my machine and my data. I ran away from Windows, (also Gnome), so I can have more freedom with KDE with its unlimited options and settings, but now they seem to follow the others and not be different any more.

    My experience now with running as a normal user is:
    - doing changes are not as simple as before, you have to do "kdesu", "sudo" or "su" before changing or installing any thing, and that does not work as it should all the time. sometimes Dolphin will not show any file if it was started via kdesu!!!!
    - KVM (machine visualization) does not work well under normal users!!!

    This is my own opinion others might not agree but i don't care
    Fahad Alduraibi
    http://fadvisor.net/

  6. #6
    Mariano Suárez- Guest
    Maybe they have found out that "unlimited options" is simply an absurd and unmaintainable goal, like others have?

  7. #7
    Join Date
    Oct 2009
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I encounter the same errors too. Actually, I am using Gentoo. As fduraibi mentioned, it is just because mysqld can't start as root. I add "user=root" in the Akonadi local mysql configuration file (on my computer, it is /root/.local/share/akonadi//mysql.conf), and Akonadi server can be started successfully.
    So root user can use KDE too.

  8. #8
    Join Date
    Feb 2010
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Talking Same issue, solution worked :)

    I add "user=root" in the Akonadi local mysql configuration file (on my computer, it is /root/.local/share/akonadi//mysql.conf), and Akonadi server can be started successfully.
    Thank you jhuang, i use slackware 13 and your solution worked seamlessly .
    Last edited by d3ck0; 24th February 2010 at 10:25 AM. Reason: Added quoting

  9. #9
    Join Date
    May 2010
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Akonadi control process not registered at D-Bus.

    Thank you, jhuang, it works now!

Similar Threads

  1. Akonadi server crashes: no QMySQL driver
    By GeronimoS in forum Installation, Upgrades and Live Media
    Replies: 0
    Last Post: 2nd April 2009, 02:25 PM
  2. Kpilot and Akonadi
    By Emphyrio in forum Using Fedora
    Replies: 0
    Last Post: 21st February 2009, 05:08 AM
  3. Why akonadi?
    By arun_maurya in forum Using Fedora
    Replies: 1
    Last Post: 11th February 2009, 08:27 AM
  4. Process limit control
    By jazzfan in forum Using Fedora
    Replies: 1
    Last Post: 24th February 2008, 02:22 PM
  5. Replies: 4
    Last Post: 15th November 2007, 12:11 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •