FedoraForum.org - Fedora Support Forums and Community
Results 1 to 1 of 1
  1. #1
    Join Date
    Feb 2009

    How can I enable XIM as input method in Gnome? [SOLVED]

    I use Fedora 10 i386 with Gnome desktop environment.
    I wanted to redefine some Compose key combinations. So I decided to use xim and local ~/.XCompose file instead of gtk-im-context-simple.
    I tried to test how it works and run
    GTK_IM_MODULE=xim gedit
    from terminal. And here the Compose key were completely ignored. But when I used multipress input method:
    GTK_IM_MODULE=multipress gedit
    it worked. I pressed the <Compose>,A,A,A... and it cycled like "a", "b", "c", "", "2".
    I tried viqr input method:
    GTK_IM_MODULE=viqr gedit
    and it also worked.

    Is there any way to enable xim as input method for non-root user?


    After I put these lines into ~/.xinputrc
    xim starts working as expected.
    Last edited by DarDar; 2nd February 2009 at 04:20 PM. Reason: Solution has been found

Similar Threads

  1. input method error?
    By sunote in forum Using Fedora
    Replies: 4
    Last Post: 23rd May 2008, 03:56 AM
  2. Input Method disappeared?!!
    By thesun in forum Using Fedora
    Replies: 5
    Last Post: 15th March 2008, 06:07 PM
  3. how to config input method
    By darksilver in forum Using Fedora
    Replies: 0
    Last Post: 14th July 2005, 04:05 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts