FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    Join Date
    Feb 2005
    Posts
    1,108

    SATA File Copy Slow

    I'm getting very slow file transfer rates with my SATA Drives.
    I've got 2 Seagate 7200.11 500GB hdds
    When copying from one hard drive to another, the transfer speed is just over 10MB/sec. The transfer speed is the same when copying files within the same hdd.
    At times it suddenly shoots to 40MB/sec but most of the time its around 10MB/sec
    I tried different file systems ext3,reiserfs,fat32 but got the same performance

    The weird thing is that hdparm shows the disks capable of much higher speeds
    Code:
    /dev/sdb:
     Timing cached reads:   1490 MB in  2.00 seconds = 744.51 MB/sec
     Timing buffered disk reads:  308 MB in  3.00 seconds = 102.58 MB/sec
    I googled for the issue and seems many have faced similar problems. However none seem to have figured out how to fix it.
    I using Fedora 9 on a Intel865 chipset.
    I'm facing the same issue with a PC at work running Fedora9 on Intel945
    Any pointers ?

  2. #2
    Join Date
    Feb 2005
    Posts
    1,108
    No one, huh ?

  3. #3
    Wayne Guest
    Please don't bump threads, while waiting for a reply you can use Google...

    Wayne

  4. #4
    Join Date
    Feb 2005
    Posts
    1,108
    Did a google before starting this thread. Couldn't find a satisfactory answer.
    The search goes on though

  5. #5
    stevea Guest
    First can you explain exactly what you do to measure the ~10MBPS rate.
    No offense intended, but many ppl don't really understand the consequences of commands.
    hdparm is a raw disk read test. It says nothing of writes which are typically slower
    and under a file system (like ext3) things are much slower yet. If you got a solid 40MPS I
    would think that might be decent.


    So have you tried to figure out what is the bottleneck ?
    You can test read access time of a directory on one if these disks and ...

    dir=/mnt/dir
    du -s --si $DIR
    time tar -cf /dev/null $DIR



    Similarly you can try dd'ing to a file or untaring a tarball from another disk to test write speed,
    I'd be very interested in the results as I am interesting in purchasing some 7200.11's
    Last edited by stevea; 11th January 2009 at 12:02 PM.

  6. #6
    Join Date
    Feb 2005
    Posts
    1,108
    The 10MB/sec rate was obtained while copying a 3.4GB ISO from one disk to another.
    The transfer rate hovered around the same while copying multiple files, each of size ~400MB.

    I tried the command tar cf /dev/null /disks/sda8/KNOPPIX_V5.1.1CD-2007-01-04-EN but I just got the message
    tar: Removing leading `/' from member names

Similar Threads

  1. horribly slow file copy
    By seeker010 in forum Using Fedora
    Replies: 17
    Last Post: 8th October 2008, 05:58 AM
  2. copy file over ftp
    By Coruba67 in forum Using Fedora
    Replies: 2
    Last Post: 20th April 2007, 10:54 AM
  3. Why do files copy so slow
    By Dan in forum Using Fedora
    Replies: 20
    Last Post: 29th September 2006, 07:42 AM
  4. tooo slow when copy file from ieee1394 DVD Recorder
    By perigee in forum Hardware & Laptops
    Replies: 1
    Last Post: 10th February 2005, 01:01 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •