No sound in Unreal Tournament 2004 with Fedora 10 64-bit .. Solved
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 17
  1. #1
    Join Date
    Dec 2006
    Posts
    312
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    No sound in Unreal Tournament 2004 with Fedora 10 64-bit .. Solved

    Hello everyone,

    I installed Unreal Tournament 2004 on my Fedora 10 64-bit and there's no sound.

    I've used this game in Fedora 9 64-bit and sound was there.

    I've tried selecting different devices in "System->Preferences->Hardware->Sound" and I also tried the latest patch (3355) for this game. Still no sound.


    When I start the game from terminal I get:
    Code:
    [user@localhost System]$ ./ut2004-bin
    open /dev/[sound/]dsp: Invalid argument
    Game launches just fine, but no sound.

    Same output is being displayed when I try to run "ut2004-bin-linux-amd64" executable.


    Another strange thing is that during installation there wasn't a regular windowed install wizard, but all install ran in terminal using "curses."



    How can I get the sound working in this game? Thanks!

  2. #2
    Join Date
    Feb 2005
    Location
    Maryland USA
    Posts
    189
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    if you are using 2.6.27.7-159.fc10.x86_64 kernel try going back to 2.6.27.7-130.fc10.x86_64. the 159 kernel has major issues with sound.

  3. #3
    Join Date
    Dec 2006
    Posts
    312
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ok, just tried it. I really use the last kernel, i.e. 2.6.27.9-159.

    The oldest kernel that I have on my system is 2.6.27.7-134.

    Still no sound with that kernel. I even reinstalled UT2004 under that older kernel. Plus I also tried all possible combinations in "System->Preferences->Hardware->Sound" with no positive result.

    Don't know what else to try...

  4. #4
    Join Date
    Dec 2006
    Posts
    312
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    BTW, I don't have any problems with sound in all other appls that I've installed so far on F10.

  5. #5
    Demz Guest
    have you gone into the Games preferences an looked there?

  6. #6
    leigh123linux Guest
    Moved to the gamers lounge .


    Try


    Code:
    su
    yum install alsa-plugins-pulseaudio.i386

  7. #7
    Join Date
    Dec 2006
    Posts
    312
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Demz: in game audio settings there's no options related to driver that I can change. There's a "Sound mode" and only one option there called "OpenAL"


    I installed "alsa-plugins-pulseaudio.i386", rebooted, and still no sound. Tried various settings in "System->Preferences->Hardware->Sound" again, but still no sound.

    When starting from command prompt I still get error:
    Code:
    open /dev/[sound/]dsp: Invalid argument
    it must be something related to that error.

  8. #8
    Demz Guest
    http://osdir.com/ml/video.ogle.user/.../msg00018.html

    http://www.google.com.au/search?q=open+%2Fdev%2F[sound%2F]dsp%3A+Invalid+argument&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a

    i found those 2 links by googling the bottom one i'll let you look at them

  9. #9
    Mensdux Guest
    Hi there! I had the same problem as premudriy but I'd solve it. So, I don't know what library exatly does that but I had installed ALL pulseaudio and Alsa plug-ins, and this library (who'd missed) libstdc++.so.5 (can't find it so I'd installed ALL libstdc++ xx.x .

    Now, when I lauch the game, I had the same bad noise as before BUT, the sound start and everithing is good. I'm sorry to can't help you much but maybe with these information someone'll find the problem.


    WARNING! I'd noticed UT2004's problems are on both Fedo 10 and Ubuntu (both 64 bits version), but there is a problem just with the sound and Sabayon4. I know Sabayon makes Frankenstein with config files so, it can be a way.

  10. #10
    Join Date
    Apr 2008
    Posts
    558
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Configure openal to use alsa rather than "oss" - see thread.

  11. #11
    Join Date
    Dec 2006
    Posts
    312
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by brebs
    Configure openal to use alsa rather than "oss" - see thread.

    Thank you, Brebs! Info in that thread did the trick! Thanks to everyone for helping.


    I'll just post what I did for anyone else having the same problem. I had to do it just a bit differently on F10-64 than in the original thread because libSDL-1.2.so.0 already is a symbolic link to a newer file libSDL-1.2.so.0.11.2. So,


    1. Copy and paste the following in your /etc/openalrc file:
    Code:
    (define devices '(alsa null))
    (define alsa-device "default")
    (define speaker-num 2)
    (define sampling-rate 44100)
    2. For running 64-bit binary of UT2004, i.e. "ut2004/System/ut2004-bin-linux-amd64" on your 64-bit system:

    in terminal run:
    Code:
    ln -sfn /usr/lib64/libopenal.so.0.0.0 /PATH_TO_YOUR_GAME/ut2004/System/openal.so
    ln -sfn /usr/lib64/libSDL-1.2.so.0.11.2 /PATH_TO_YOUR_GAME/ut2004/System/libSDL-1.2.so.0

    2a. For running 32-bit binary of UT2004, i.e. "ut2004/System/ut2004-bin" on your 64-bit system:

    in terminal run:
    Code:
    ln -sfn /usr/lib/libopenal.so.0.0.0 /PATH_TO_YOUR_GAME/ut2004/System/openal.so
    ln -sfn /usr/lib/libSDL-1.2.so.0.11.2 /PATH_TO_YOUR_GAME/ut2004/System/libSDL-1.2.so.0
    su-
    yum install compat-libstdc++-33-3.2.3-64.i386



    P.S.: How do I mark thread as solved? Before I used to modify my first thread and type [SOLVED] in front of the tread name, but in a list of threads in forum that [SOLVED] doesn't show up.
    Last edited by premudriy; 10th January 2009 at 06:07 AM.

  12. #12
    Demz Guest
    i can mark it as Solved for you

  13. #13
    Join Date
    Apr 2008
    Posts
    558
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Those "ln" commands are very bad and wrong. Please edit them to instead be:
    Code:
    ln -sfn
    "man ln" shows what those options do. Should be symbolic links rather than hard links, for starters. And "f" to overwrite the existing symlinks, and "n" to basically do what's intended without trying to be too clever.
    Last edited by brebs; 10th January 2009 at 05:59 AM.

  14. #14
    Join Date
    Dec 2006
    Posts
    312
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ok, fixed it.

  15. #15
    Join Date
    Nov 2006
    Posts
    52
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I'm trying to ut2004 working right too. It runs, but very crappily. It will often freeze for a fraction of second, making it unplayable which is weird cause I've got a AMD Phenom quad and an NVIDIA 8500. Anyways, I noticed the poster above said something about a "ut2004-bin-linux-amd64" file in ut2004/System, but I don't have that file. Where does that file come from, and how do I get it?

Page 1 of 2 1 2 LastLast

Similar Threads

  1. No sound in Unreal Tournament 2004
    By cdlaforc in forum Using Fedora
    Replies: 9
    Last Post: 25th January 2006, 03:46 PM
  2. FC4 and Unreal Tournament 2004
    By N3LDAN in forum Using Fedora
    Replies: 2
    Last Post: 24th August 2005, 11:59 PM
  3. Unreal Tournament 2004
    By rantanplan in forum Linux Chat
    Replies: 5
    Last Post: 6th June 2005, 10:30 AM
  4. Unreal Tournament 2004
    By kwarrior in forum Using Fedora
    Replies: 3
    Last Post: 18th March 2005, 03:03 PM
  5. Unreal Tournament 2004 on amd x86-64
    By darkprok in forum Using Fedora
    Replies: 5
    Last Post: 23rd November 2004, 11:33 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •