FedoraForum.org - Fedora Support Forums and Community
Results 1 to 7 of 7
  1. #1
    Join Date
    Dec 2008

    I enabled desktop effects in KDE/Gnome - now unusable - bug or driver?

    As the title suggests, I am rather new to Linux and just installed Fedora 10. While "tweaking" the desktop settings, I decided to enable several visuals for the windows (animations, shading, etc.), and now I have a screen full of black and grey boxes corresponding to the windows that were there, but KDE is now unusable as I can't see anything.

    I thought a box popped up when I selected "apply" that said the settings would revert after a period of time if I didn't click okay, but apparently it didn't work.

    Is there a way that I can reset the desktop to the default settings? I would assume that I'll need to log in as root and delete some things with an editor? Can I do this from Gnome?

    I couldn't find anything similar when I searched.

    Last edited by llebcire; 29th December 2008 at 05:23 PM. Reason: Updated thread title

  2. #2
    Join Date
    May 2008

    my method was

    log in with gnome and create a new user and use this one instead. Move you files there and change ownership to the new user. Then delete the old user.

    Maybe there are some better ways. But one known working way is better than 100 better ones if they are unknown.

  3. #3
    Join Date
    Dec 2008

    More info

    After deleting/recreating account several times, here's what I've found -

    If I enable desktop effects (default) in Gnome I get a white screen, no mouse. Pressing control-alt-delete gets me to the log off screen, if I cancel I get to the desktop effects window that I can close and all is good.

    If I enable in KDE (default options), I get a black screen with a mouse, only option is to control-alt-delete, log off, log in under different user and delete/recreate my account.

    Bug or driver issue? Fresh install of Fedora 10 with no updates.

    Gateway GT5648E (got it cheaper than building my own this Spring)
    Vista Home Premium SP1/Fedora 10
    AMD Athlon 64 X2 Dual Core 6000+
    3 gig ram (PC2-5300)
    ECS MCP61P-AM motherboard (nVidia chipset?)
    AC'97 ALC888 7.1 Audio
    MARVELL 88E8056 10/100 Ethernet
    TSSTcorp CD/DVDW TS-H652D (Samsung?)
    NVIDIAŽ GeForceŽ 6150SE (on MOBO)
    320gb Seagate Barracuda 7200 ST3320820AS SATAII

    Drive is currently 10 gig recovery, 258 gig for Vista, and 29 gig Linux.

    3 additional drives installed - 2 WD WD1600JD 160 gig SATA's (used to run Raid 0 on XP) and 1 WD WD1600JB 160 gig IDE.

  4. #4
    Join Date
    May 2008

    Smile and without those effects?

    well I don' t use at all those desktop-effects. Are the so important in fact? I heard I had to install the proprietary nvidia-driver to use the desktop-effects. So I declinded.

  5. #5
    Join Date
    Jan 2009
    I also had that problem on KDE4+Fedora10. I got a black screen and "shadows" of windows and menus.
    On Gnome, when I tried to enable effects I had a message informing that it was impossible to enable them.
    I solved the problem on KDE by logging in to Gnome and deleting the directory .kde4 in my home dir.
    Last edited by nikto; 4th January 2009 at 09:59 PM. Reason: speling of Gnome was wrong

  6. #6
    Join Date
    Mar 2009

    Smile delete .kde at home direcotry will work.

    I got the same problem, I solved it by deleting .kde folder at my home directory.

  7. #7
    Join Date
    Jul 2005
    You don't generally have to be as drastic as killing the whole .kde configuration directory.

    Start by logging in as another user and becoming the super user (or login as root if you've enabled that) or go to a console window Ctrl-Alt-F2 login and login as yourself. Edit your /home/myloginname/.kde/share/config/kwinrc file.

    Remove the Effects sections and Compositing sections for a start. You may, at times, need to eliminate the plasmarc file completely as well.

    Then restart as normal. If all else fails-you simply can't use any text based editor, you are running a login manager that won't let you log in as root (Stupid Fedora design decisions!) then just delete kwinrc.

    When you log in again as your normal old self, the defaults will be picked for the settings that are missing or the files will be recreated. If you can't login as root from the GUI, I suggest fixing that ASAP. Don't login as root unless it's an emergency, but this qualifies, and not being able to do it to fix situations like this is silly.

Similar Threads

  1. How can I reset f8 to last settings
    By zagloba in forum Using Fedora
    Replies: 0
    Last Post: 15th January 2008, 06:55 AM
  2. Reset Firewall to default settings
    By P4rD0nM3 in forum Security and Privacy
    Replies: 20
    Last Post: 30th December 2007, 02:24 PM
  3. Reset User settings back to intial values
    By ajamison in forum Using Fedora
    Replies: 6
    Last Post: 21st March 2007, 09:12 PM
  4. Reset video card settings in FC2?
    By mijohnst in forum Hardware & Laptops
    Replies: 1
    Last Post: 18th June 2005, 05:46 AM
  5. Reset Network Settings
    By StoneBrooks in forum Servers & Networking
    Replies: 2
    Last Post: 17th February 2005, 04:50 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts