I am desperately trying to set up samba on my machine, with no success. I enabled smbd and nmbd for runlevels 3 and 5; for good measure, I activated them manually, too (services smbd restart etc.), and using samba-swat created sensible config files.

Code:
[root@localhost /]# ps ax|grep mbd
 5247 ?        Ss     0:00 smbd -D
 5249 ?        S      0:00 smbd -D
 5264 ?        Ss     0:00 nmbd -D
 5647 pts/1    S+     0:00 grep smb
Here is the output of testparm:
Code:
[root@localhost /]#testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[linux-tmp]"
Processing section "[homes]"
Processing section "[printers]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
        workgroup = MYGROUP
        username map = /etc/samba/smbusers
        idmap uid = 16777216-33554431
        idmap gid = 16777216-33554431
        guest ok = Yes

[linux-tmp]
        path = /tmp
        read only = No

[homes]
        read only = No
        guest ok = No

[printers]
        path = /var/spool/cups
        printable = Yes
        browseable = No
[root@localhost /]#
lmhosts contains the following:
Code:
[root@localhost /]# cat /etc/samba/lmhosts
127.0.0.1 localhost
Finally, I disabled selinux and, for a short testing window, even disabled the firewall, and yet, when trying to access the shares FROM THE SAME MACHINE, using konqueror, I got the following:


Can anyone help me figure out how to make samba work?