ps/2 keyboard grey buttons stopped working
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    Join Date
    Jan 2006
    Posts
    78

    Question ps/2 keyboard grey buttons stopped working

    ps/2 keyboard grey buttons (arrows,home,end,page up,page
    down,insert and delete stopped working in GNOME after upgrade from FC9 to FC10. While they work fine in console
    (init level 3) and even in GDM.
    Arrows work fine on users created after upgrade.

    An interesting fact:
    While there is no short cut is setup on arrows
    - each pressing on arrow calls screenshort application.

    Does anybody know how to fix the problem or where to dig? ;-)

  2. #2
    Join Date
    Oct 2008
    Location
    England, Lincolnshire
    Posts
    1,572
    System > Personal > Keyboard Shortcuts

    Would be a good place to start.

    Though it could be a bug because I get this issue now with all my virtual machines (Even prior to installing, while trying to set them up with installer)
    Fedora user since FC6.
    Linux user since 2003.
    Registered Linux ID: #456478
    Primary OS: CentOS 7 x86_64
    Secondary OS: Fedora 22 x86_64

  3. #3
    Join Date
    Jan 2006
    Posts
    78

    Question

    Quote Originally Posted by JakeS
    System > Personal > Keyboard Shortcuts

    Would be a good place to start.

    Though it could be a bug because I get this issue now with all my virtual machines (Even prior to installing, while trying to set them up with installer)
    By writing in previous message "While there is no short cut is setup on arrows" I meant that there is not short cut for arrows or any other grey key.

    Of course I already examined System > Personal > Keyboard Shortcuts

    PS Probably someone knows how to disable shortcuts in GNOME?
    In this case I at least will be able to locate the problem.

    Thanks in advance.

  4. #4
    Join Date
    Oct 2008
    Location
    England, Lincolnshire
    Posts
    1,572
    Ok, just to let you know. It is a bug.

    https://bugs.launchpad.net/gentoo/+bug/255008

    It's probably reported on fedora. not sure. but anywho:

    Try some of the things there. I can't check right now due to I'm not using my Fedora.

    EDIT: Try this:

    setxkbmap -model evdev -layout gb -option lv3:ralt_switch
    Worked for my guest.

    Note: change GB to us if you have an yank keyboard.
    Last edited by Jake; 19th December 2008 at 12:27 PM.
    Fedora user since FC6.
    Linux user since 2003.
    Registered Linux ID: #456478
    Primary OS: CentOS 7 x86_64
    Secondary OS: Fedora 22 x86_64

  5. #5
    Join Date
    Jan 2006
    Posts
    78
    Quote Originally Posted by JakeS
    Ok, just to let you know. It is a bug.

    https://bugs.launchpad.net/gentoo/+bug/255008

    It's probably reported on fedora. not sure. but anywho:

    Try some of the things there. I can't check right now due to I'm not using my Fedora.

    EDIT: Try this:

    Worked for my guest.

    Note: change GB to us if you have an yank keyboard.
    Thank you, I already opened a bug
    https://bugzilla.redhat.com/show_bug.cgi?id=476918

  6. #6
    Join Date
    Jan 2006
    Posts
    78

    Unhappy

    The most strange thing is that it works fine on new users.

    Maybe something tells me that gnome is using my local configs, I wish I new where to look for this configs. I'd deleted it and let gnome to recreate it from scratch.

Similar Threads

  1. F11 KDE: Keyboard layout switching stopped working
    By illich in forum Using Fedora
    Replies: 0
    Last Post: 30th June 2009, 09:18 AM
  2. Keyboard stopped working with F8
    By tkoco in forum Hardware & Laptops
    Replies: 1
    Last Post: 29th January 2008, 01:59 AM
  3. keyboard stopped working on user account
    By Lagnaf in forum Hardware & Laptops
    Replies: 3
    Last Post: 1st January 2008, 09:21 PM
  4. FC5, keyboard stopped working for one user
    By pcwright in forum Hardware & Laptops
    Replies: 2
    Last Post: 15th December 2006, 09:15 PM
  5. Keyboard just randomly stopped working
    By jsdewey in forum Hardware & Laptops
    Replies: 6
    Last Post: 16th August 2006, 08:26 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •