How to: c cedilla on US-International Keyboard in Fedora 10
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 13 of 13
  1. #1
    el-aure Guest

    How to: c cedilla on US-International Keyboard in Fedora 10

    Hello all.
    Please forgive me if my very first post is not all that great looking; I am still kind of a newbie...

    Judging from the hundreds (if not thousands) of posts in various Forums for various Linux distributions, c cedilla is needed by a lot of multilingual people using a standard US keyboard.

    There are well documented solutions that work in Fedora 8 and 9.
    In Fedora 10 however, input method has changed and these solutions no longer work.

    After a lot searching, I finally found a simple solution for Fedora 10.
    The solution presented here works as long as you do not enable scim or xim.

    Step 1 - change default input method to cedilla
    sudo cp /etc/X11/xinit/xinput.d/none.conf /etc/X11/xinit/xinput.d/none.conf-backup
    sudo open gedit /etc/X11/xinit/xinput.d/none.conf
    change line
    GTK_IM_MODULE=gtk-im-context-simple
    to
    GTK_IM_MODULE=gtk-im-cedilla
    Step 2 - add your keyboard to input method cedilla
    sudo open gedit /etc/gtk-2.0/x86_64-redhat-linux-gnu/gtk.immodules
    sudo open gedit /etc/gtk-2.0/i386-redhat-linux-gnu/gtk.immodules
    change line
    "cedilla" "Cedilla" "gtk20" "/usr/share/locale" "az:ca:co:fr:gv:oct:sq:tr:wa"
    to
    "cedilla" "Cedilla" "gtk20" "/usr/share/locale" "az:ca:co:fr:gv:oct:sq:tr:wa:en_US"
    Step 3 - Logout + Login

    Step 4 - Check that your imput method is really cedilla
    cat ~/.gconf/desktop/gnome/interface/%gconf.xml
    <?xml version="1.0"?>
    <gconf>
    <entry name="gtk-im-module" mtime="1229379660" type="string">
    <stringvalue>gtk-im-cedilla</stringvalue>
    </entry>
    </gconf>
    Step 5 - You can now type c cedilla with 'c and 'C (single quote followed by letter c or C)

    This seems to be so simple; all the pieces are there already.
    Notes:
    1-It would be nice that Fedora 11 uses this approach (or something similar) and adds a new keyboard like "US-International (with cedilla)" to installation screen.
    2-It would be nice also that this gets incorporated into the the next Live CD as it would certainly help easier adoption of Linux.

  2. #2
    Join Date
    Sep 2008
    Posts
    11
    I am having problems to follow your instructions.

    1. I have no idea if scim or xim is enabled in my computer and how to do it.

    2. The command
    sudo open gedit /etc/gtk-2.0/i386-redhat-linux-gnu/gtk.immodules
    opens an empty file... there is no line to edit.

    3. Even if it were, your instruction appears in my screen as
    "cedilla" "Cedilla" "gtk20" "/usr/share/locale" "az:ca:co:fr:gv:oc{a small face showing the tongue}t:sq:tr:wa"

    I found this thread not because of c cedilla, but because I cannot use accented characters since I upgraded to Fedora 10 (described in http://forums.fedoraforum.org/showth...=1#post1178600). I was expecting that the keyboard problem was related to the new approach you mentioned here, thus hoping to test it and see if the dead keys come back to the normal way.

  3. #3
    Join Date
    Jun 2009
    Posts
    1
    The way I temporarily solved my cedilla problem was to create a secondary keyboard layout (Brazilian Portuguese), which has the cedilla by default just next to the "L" key.
    Then everytime I need a cedilla, I use the shortcut Shift + CapsLock to quickly switch the keyboard layout from "USA International with dead keys" (my default layout) to Brazilian Portuguese (my secondary layout); I get the cedilla I need using the ";" key, then switch back to USA International layout.
    Far from ideal, but it works for me...

    System > Preferences > Hardware > Keyboard
    (Layouts tab)

  4. #4
    Join Date
    Sep 2008
    Posts
    11
    I loved Fedora since Fedora Core 5. I am grateful to Fedora because it was the system I adopted to abandon Windows in 2003/2004. However, Fedora 10 was a bad experience. I moved to Fedora 10 in order to put webcams to work. Unfortunately, Fedora 10 was not only unable to find two Logitech models I have, but also turned the keyboard in a problem. In addition, I use Wacom tablets that were very hard to configure.
    I am sorry to say that I cannot test any solution now. I solved all these issues by installing Ubuntu. Although the webcam was found and installed, it is still not operational (the webcam shows images under Ekiga, but Skype and aMSN could not find it). On the other hand the keyboard is fully operaional, as you can ee :-) The Wacom tablet was automatically installed with the correct configuration. Ubuntu seems simpler, less professional than Linux's geeks may want, but it is very friendly to final users.

  5. #5
    Join Date
    Mar 2008
    Location
    France
    Posts
    73

    Use US international layout.

    C - cedilla is available on the US international keyboard layout but it is not very easy to find

    On the "USA alternative international keyboard (former us_intl)" most accented characters are formed by hitting a punctuation mark followed by a letter.

    for example
    (I will also name the result in case it does not render correctly)
    `a = > a-grave
    'e = > e-acute
    ^o = > o-circumflex (Not ctrl-o, but shift-6 o on a US keyboard)
    "u = > u-umlaut
    ~n = > n-tilda

    Then there are the codes that require you to use the RIGHT Alt key

    Right-Alt-e Euro
    Right-Alt-5 Euro
    Right-Alt-,c lower case c cedilla (Right-alt-comma then c)
    Right-Alt-,C Upper case c cedilla

    If, however you use the "US international (Altgr Dead Keys)" layout

    then c-cedilla is just right-alt comma
    I think the "US international (Altgr Dead Keys)" may have a few more keys useful for western europeans (I couldn' t find the British Pound () or German double-ess () on the "former us_intl" layout but on the "Altgr dead keys" layout they are where you would expect them to be - right-alt-$ () and right-alt-s ().)

    However I don't find the positions of the other accented keys particularly easy to remember so I normally use the former us_intl layout for writing in French and the regular USA layout for everything else.

    To change or add layouts in Gnome go to System | Preferences | Keyboard and select the layouts tab. You can add as many countries and variants as you wish - I now have the US layout with the three variants mentioned above.

    If you click on Layout Options you can select the keys you use to change layouts - I use the two shift keys pressed simultaneously, but there are several other possibilities.

    Finally when you are done with that dialog you can right-click on the bar at the top of the gnome window and select "Add To Panel" . You will find an item in the drop down list named "Keyboard indicator". Mine displays USA, USA2 or USA3 depending which variant I have selected and I can cycle through the variants by clicking on the indicator or hitting the shift keys.

    I'm not expecting you to undo the work you have already done especially if you have a system that works for you but try this next time you install a system. I have used the same technique since I switched my main machine from Windows to Fedora 7 and it has always worked right through to my current installation of Fedora 11

    Finally - a warning for noobs: If you read this and want to test all the possibilities of every key be careful with the function keys. Hit ctrl-alt-F2 and you will be taken to a black screen with a text mode login prompt and no way of getting to your browser to find out what to do next. If this happens just hit ctrl-alt-F1 and your desktop should re-appear (Use the LEFT alt key for this)

  6. #6
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    5,701
    There is a simple way to have and that is to also define the French Canada keyboard as an alternative.

    Then with this keyboard, you will have ALL the USA characters, the Euro, and the French characters. This layout does not however provide for the Spanish characters.

    I use the ca(fr) keyboard exclusively, after getting used to it.
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

  7. #7
    Join Date
    Jan 2008
    Location
    So Paulo
    Age
    37
    Posts
    31

    Re: How to: c cedilla on US-International Keyboard in Fedora 10

    This did not work for me with F14... any suggestions?

    EDIT

    Got it! I had to install the package gtk2-immodules (installed gtk3-immodules too), and AFTER that, editet /etc/gtk-2.0/i386-redhat-linux-gnu/gtk.immodules (i'm using 32 bit version of fedora 14, if you're using the 64 bit, make sure you edit the right file as mentioned in the first post).
    Last edited by christianvl; 6th November 2010 at 02:20 AM. Reason: solved the problem

  8. #8
    Join Date
    Jan 2008
    Location
    So Paulo
    Age
    37
    Posts
    31

    Re: How to: c cedilla on US-International Keyboard in Fedora 10

    Ok, new problem.

    The "c + ' = " is solved, only for GTK apps. Just installed Opera (10.63), a QT app (please correct me if Iḿ wrong) and the problem returned...

    I don't have KDE installed and was not planning on it (but don't have anything against it). So I've decided to try something I've found on http://www.uluga.ubuntuforums.org/sh....php?t=1474091 (I know, that's Ubuntu/Debian and I'm running Fedora 14), but it always worth the shot:

    Code:
    $ im-switch -s default-xim
    Command not found
    Any ideas how to solve this problem without installing KDE?

    EDIT

    Problem solved:

    For QT applications:

    Code:
    # gedit /usr/share/X11/locale/en_US.UTF-8/Compose
    Find and replace every ć to and Ć to (match case!). That's about it...
    Last edited by christianvl; 10th November 2010 at 12:49 AM. Reason: SOLVED

  9. #9
    Join Date
    Mar 2008
    Location
    France
    Posts
    73

    Re: How to: c cedilla on US-International Keyboard in Fedora 10

    Quote Originally Posted by christianvl
    Ok, new problem.

    The "c + ' = " is solved, only for GTK apps. Just installed Opera (10.63), a QT app (please correct me if Iḿ wrong) and the problem returned...

    I don't have KDE installed and was not planning on it (but don't have anything against it). So I've decided to try something I've found on http://www.uluga.ubuntuforums.org/sh....php?t=1474091 (I know, that's Ubuntu/Debian and I'm running Fedora 14), but it always worth the shot:

    Code:
    $ im-switch -s default-xim
    Command not found
    Any ideas how to solve this problem without installing KDE?

    EDIT

    Problem solved:

    For QT applications:

    Code:
    # gedit /usr/share/X11/locale/en_US.UTF-8/Compose
    Find and replace every ć to and Ć to (match case!). That's about it...
    That all seems much more complicated than just loading the appropriate keyboard layout (see post 5, above), and I find it most frustrating reading how you did it.

    Could you satisfy my curiosity and let me know why you have to go to so much effort?

    Thanks in advance,

    DP

  10. #10
    Join Date
    Jan 2008
    Location
    So Paulo
    Age
    37
    Posts
    31

    Re: How to: c cedilla on US-International Keyboard in Fedora 10

    I couldn't find any keyboard layout that would satisfy my needs... I use my computer to type in Portuguese (Brazil), but my computer has a USA keyboard... using the "US international" layout, I could type everything I need in portuguese, however, the "" was composed in a complete different way that all brazilians are used to (right alt + comma, instead of our usual acute accent + c).

    This is really annoying and was very distturbing when I had to use the computer with other people (specially some clients)...

    Anyway, having to keep switching the layout did not seem a good idea for me too. This way I had a more permanent solution (btw, found in a brazilian forum). This problem, is very common in Brazil with people deciding to use the system in english, with an US keyboard, but typing in portuguese.

    It seems (i'm not sure) that if i had opted to use the system in portuguese, I would not have this trouble. I just preffer to use it in english as it was the original language.

    Thank you for your concern and interest. Maybe in the near future there will be a keyboard layout for US keyboard in Brazil.

  11. #11
    Join Date
    Mar 2008
    Location
    France
    Posts
    73

    Re: How to: c cedilla on US-International Keyboard in Fedora 10

    Thanks for your response. Now that I know you are trying to maintain the environment that you are accustomed to I fully understand.

    My wife thinks I am crazy because my French notebooks have AZERTYUIOP keyboards but I still choose to use the US keyboard layout and type blind, even switching to US international when I want to type in French.

    And before anyone tuts about Americans not integrating properly - I'm British and just prefer the American layout.

  12. #12
    Join Date
    Jan 2012
    Location
    Washington DC
    Posts
    1

    Re: How to: c cedilla on US-International Keyboard in Fedora 10

    Quote Originally Posted by el-aure
    Hello all.
    Please forgive me if my very first post is not all that great looking; I am still kind of a newbie...

    Judging from the hundreds (if not thousands) of posts in various Forums for various Linux distributions, c cedilla is needed by a lot of multilingual people using a standard US keyboard.

    There are well documented solutions that work in Fedora 8 and 9.
    In Fedora 10 however, input method has changed and these solutions no longer work.

    After a lot searching, I finally found a simple solution for Fedora 10.
    The solution presented here works as long as you do not enable scim or xim.

    Step 1 - change default input method to cedilla

    change line

    to

    Step 2 - add your keyboard to input method cedilla

    change line

    to

    Step 3 - Logout + Login

    Step 4 - Check that your imput method is really cedilla


    Step 5 - You can now type c cedilla with 'c and 'C (single quote followed by letter c or C)

    This seems to be so simple; all the pieces are there already.
    Notes:
    1-It would be nice that Fedora 11 uses this approach (or something similar) and adds a new keyboard like "US-International (with cedilla)" to installation screen.
    2-It would be nice also that this gets incorporated into the the next Live CD as it would certainly help easier adoption of Linux.
    Awesome, these instructions fixed the same problem on CentOS 6.2! Beleza!

  13. #13
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    5,701

    Re: How to: c cedilla on US-International Keyboard in Fedora 10

    Quote Originally Posted by DrewP
    Thanks for your response. Now that I know you are trying to maintain the environment that you are accustomed to I fully understand.

    My wife thinks I am crazy because my French notebooks have AZERTYUIOP keyboards but I still choose to use the US keyboard layout and type blind, even switching to US international when I want to type in French.

    And before anyone tuts about Americans not integrating properly - I'm British and just prefer the American layout.
    The Canadian Standard Keyboard is what I use for Linux and Windows (same layouts exactly). I have the and all other accented characters. is great for PL1 language.

    I have all the American characters and all the French ones too.

    I paid $11.00 for my keyboard, they sell here in Montreal for well under $20.00

    What is not on the keyboard are some of the Spanish letters. Google translate helps me with those.
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

Similar Threads

  1. Java (Zend Studio) international keyboard problem
    By tkalfaoglu in forum Alpha, Beta & Snapshots Discussions (Fedora 10 Only)
    Replies: 0
    Last Post: 22nd November 2008, 08:48 AM
  2. International support in LiveCD
    By amreg in forum Using Fedora
    Replies: 7
    Last Post: 4th August 2008, 09:23 AM
  3. International Forums?
    By Arya in forum Suggestions & Feedback
    Replies: 4
    Last Post: 19th July 2006, 02:36 PM
  4. Google, the international spy?
    By Crux in forum Wibble
    Replies: 0
    Last Post: 8th February 2006, 01:09 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •