FedoraForum.org - Fedora Support Forums and Community
Page 1 of 11 1 2 3 ... LastLast
Results 1 to 15 of 161
  1. #1
    Join Date
    Aug 2008
    Posts
    587

    Exclamation How to: Fix PulseAudio and primary audio issues with Fedora 10 (F10)

    Well it's time for my contribution to this community with the new release of Fedora 10.. lots of people are having issues with the audio.

    So lets start:

    The quick and easy tutorial
    ... well... at least it worked for me...
    (how easy may vary depending on user experience)

    open a terminal and run the following command
    Code:
    su -c 'gedit /etc/pulse/default.pa'
    and replace the line:
    load-module module-hal-detect
    with:
    load-module module-hal-detect tsched=0
    (of course save your changes and then move on to the next step)


    Next run the following command:
    Code:
    su -c 'yum install pavucontrol pavumeter paman padevchooser paprefs alsa-plugins-pulseaudio gstreamer-plugins-pulse pulseaudio pulseaudio-core-libs pulseaudio-esound-compat pulseaudio-libs pulseaudio-libs-glib2 pulseaudio-libs-zeroconf pulseaudio-module-gconf pulseaudio-module-x11 pulseaudio-module-zeroconf pulseaudio-utils xine-lib-pulseaudio xmms-pulse'
    DO NOT RUN THE FOLLOWING COMMAND AS ROOT
    next, Run this command
    Code:
    pulseaudio -k
    and you're done... test out the audio and see how it works.

    edit:
    Also forgot to mention, be sure to have your audio settings under System > Preferences > Hardware > Sound
    for "Sound Playback" (not sound capture) set to PulseAudio Sound Server.







    Side Note:
    If you're experiencing random lock ups and you're not doing anything sound related.. multiple things can cause your desktop to freeze up.. such as stressing your network or having your firewall configured improperly, so it may not be pulseaudio at all.
    edit 2:
    Important Update:
    Some users have been complaining about a glitch in the software that dumps a message into their log files and causes random lock-ups.
    If you experience random lock-ups or a message being dumped into certain log files, remove the tsched=0 term to enable timer-based scheduling, which makes the audio less CPU intensive;
    the line should look like this afterwards:
    load-module module-hal-detect
    However you may experience pop and stuttering audio glitches if you remove it. If in some rare case you do, put it back.
    In other words, it's safe to remove tsched=0; everything else in the tutorial stays.
    run the command
    Code:
    $ pulseaudio -k
    after you get done editing the file (/etc/pulse/default.pa) then test the audio. (to edit just run the first command of the tutorial)
    Last edited by Silpheed2K; 28th July 2009 at 10:41 PM.

  2. #2
    Join Date
    Apr 2005
    Location
    earth
    Posts
    1,336
    Hey Slipheed2K
    That seemed to cure the poping I was getting in dosbox!
    Thanks!
    Pat Jr.
    x--x--x
    http://www.gnu.org/philosophy/free-sw.html
    Freedom is never Free.
    Pat Jr.

  3. #3
    scottro's Avatar
    scottro is offline Retired Community Manager -- Banned from Texas by popular demand.
    Join Date
    Sep 2007
    Location
    NYC
    Posts
    8,129
    I'll add a link to the 5 common problems as it's worked for at least one person.

  4. #4
    Join Date
    Dec 2008
    Location
    Moscow, Russia
    Posts
    40
    Listen, this may sound stupid, but is this the case of audio multiple streaming? If I got my skype running and launch lastfm I get a Pulse audio error, and firefox won't give me sound unless skype and lastfm are closed.

    Sorry. Thanks.
    K.

  5. #5
    Join Date
    Aug 2008
    Posts
    587
    Quote Originally Posted by kovshenin
    Listen, this may sound stupid, but is this the case of audio multiple streaming? If I got my skype running and launch lastfm I get a Pulse audio error, and firefox won't give me sound unless skype and lastfm are closed.

    Sorry. Thanks.
    K.
    It isnt one specific case, as the title suggests it addresses mostly all of the audio issues, so follow the tutorial and you should be fine. (should fix your problem)

  6. #6
    Join Date
    Dec 2008
    Location
    Moscow, Russia
    Posts
    40
    Quote Originally Posted by Silpheed2K
    It isnt one specific case, as the title suggests it addresses mostly all of the audio issues, so follow the tutorial and you should be fine. (should fix your problem)
    Yes, that seems to have solved the problem. Thank you very much!
    Running F11 on HP Pavilion dv2000
    My Web Developer Blog

  7. #7
    Join Date
    May 2004
    Location
    PA
    Age
    38
    Posts
    466
    Excellent work!

    Is this "pulseaudio -k" command permanent?
    oget, the "Pulse against"

    Thnigs that rule: Angelina, TKT, Linux, Supergravity, Alcohol...

  8. #8
    Join Date
    Aug 2008
    Posts
    587
    Quote Originally Posted by ogetbilo
    Excellent work!

    Is this "pulseaudio -k" command permanent?
    you only need to use that command once... "pulseaudio -k" kills the current pulseaudio daemon and restarts it.

  9. #9
    Join Date
    Jun 2004
    Location
    Florida Panhandle
    Posts
    17

    Thumbs up

    Thank you. Pulseaudio now working great in Gnome Fedora 10.

  10. #10
    Join Date
    Oct 2008
    Posts
    299
    Sweet, works great now in all the various sounds apps.
    Intel Core 2 Quad Q8400 CPU (2.66 GHz)
    3gb RAM
    500GB HD
    Debian Lenny x86_64 & Windows 7 Ultimate x64
    NVIDIA GeForce 9800 GTX+ Superclocked - Fattypack

    Second(Server) PC:
    512mb RAM
    80gb TiVO HD(Lololol, took it from TiVO, old one broke)
    PC-BSD 7.1.1 x86
    Ossom router decked out with DD-WRT as a bridge providing net
    Sign the Online Petition to bring Crysis 2 to Linux/Mac!

  11. #11
    Join Date
    Dec 2008
    Posts
    2
    This solution did not work for me...

    I have an Audigy 2 ZS sound card like many others and it "just worked" in past releases of Fedora. I've tried everything suggested in the thread below and the only option that works is to install fc9 pulseaudio packages.

    http://forums.fedoraforum.org/showthread.php?t=203708

    Unfortunately, using the fc9 packages breaks stuff like the GNOME sounds, etc.

    I've found that the only thing affected by fc10 pulseaudio is video playback (i.e. your weekly tv show download). Music is hardly affected (small pops once in a while), and stuff like GNOME sounds and flash sounds are fine.

    Adding the tsched=0 option made my audio problems worse (GNOME would freeze when I'd try to watch a tv show). It's too bad because this option should theoretically make pulseaudio operate as it does in Fedora 9 (which worked).

    Has anyone out there verified this solution works for an Audigy 2 ZS?

    I'm thinking it might take until Fedora 11 before this is all straightened out... but I'm hoping not! Thanks!

  12. #12
    Join Date
    Dec 2008
    Location
    Manchester, England
    Age
    31
    Posts
    14
    Excellent! I can now watch flash videos (like the ones on YouTube) without the sound skipping horrendously Kudos to you, sir

  13. #13
    Join Date
    May 2008
    Posts
    26
    When I typed in "pulseaudio -k", the computer responded


    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    I: caps.c: Dropping root privileges.
    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    N: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary privileges:
    N: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us privileges. Dropping SUID again.
    N: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit privileges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
    W: main.c: High-priority scheduling enabled in configuration but not allowed bypolicy.


    I presume this makes no difference. Or are there some steps I should take, like adding myself to the group pulse-rt?

  14. #14
    Join Date
    Aug 2008
    Posts
    587
    You're fine and you dont need to do anything else.

  15. #15
    Join Date
    Dec 2008
    Posts
    15
    Hey thanks for the HOW-TO. Slight problem off the hop. When I enter

    su -c 'gedit /etc/pulse/default.pa'


    I get:

    bash: gedit: command not found


    after i put in my password of course.

    Then I did a bit of digging around and learned about a command called $EDITOR. So I tried that:

    su -c '$editor default.pa'

    then put in my password, then got:

    bash: default.pa: command not found

    Ha! Any suggestions? I'm using fedora 10, xfce version (didn't think desktop version would affect using the terminal... but I guess it does? not sure.)

Page 1 of 11 1 2 3 ... LastLast

Similar Threads

  1. Fedora 11: Complete guide to fix PulseAudio and video/audio VLC Media Player issues
    By Silpheed2K in forum Guides & Solutions (Not For Questions)
    Replies: 203
    Last Post: 17th June 2012, 04:17 PM
  2. Bluetooth Audio with PulseAudio
    By jtang613 in forum Guides & Solutions (Not For Questions)
    Replies: 25
    Last Post: 8th December 2009, 05:34 AM
  3. Replies: 13
    Last Post: 5th November 2009, 11:02 PM
  4. pulseaudio multiple audio sources
    By M4rc0 in forum Using Fedora
    Replies: 9
    Last Post: 2nd July 2009, 06:25 AM
  5. Primary audio device
    By mgaleano in forum Using Fedora
    Replies: 2
    Last Post: 29th June 2005, 12:44 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •