slapd not wirking after upgrade
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2007
    Posts
    4

    slapd not wirking after upgrade

    Hi all,

    This week I upgraded several servers to FC10 but for one I had a problem:

    slapd doesn't work anymore and init script exit with this error message:



    Checking configuration files for slapd: [FAILED]
    bdb(dc=tr1): Program version 4.6 doesn't match environment version 4.4
    bdb_db_open: database "dc=myldap" cannot be opened, err -30972. Restore from backup!
    backend_startup_one: bi_db_open failed! (-30972)
    slap_startup failed (test would succeed using the -u switch)
    stale lock files may be present in /var/lib/ldap [WARNING]


    I think that is a Barkley DB issue and not an openldap one.

    Config files are still the same I used in the previous version of Fedora and in /var/lib/ldap i have this files:

    drwx------ ldap ldap system_u:object_r:slapd_db_t .
    drwxr-xr-x root root system_u:object_r:var_lib_t ..
    -rw-r--r-- ldap ldap root:object_r:slapd_db_t alock
    -rw------- ldap ldap root:object_r:slapd_db_t cn.bdb
    -rw------- ldap ldap root:object_r:slapd_db_t __db.001
    -rw------- ldap ldap root:object_r:slapd_db_t __db.002
    -rw------- ldap ldap root:object_r:slapd_db_t __db.003
    -rw------- ldap ldap root:object_r:slapd_db_t __db.004
    -rw------- ldap ldap root:object_r:slapd_db_t __db.005
    -rw------- ldap ldap root:object_r:slapd_db_t __db.006
    -rw-r--r-- ldap ldap root:object_r:slapd_db_t DB_CONFIG
    -rw------- ldap ldap root:object_r:slapd_db_t displayName.bdb
    -rw------- ldap ldap root:object_r:slapd_db_t dn2id.bdb
    -rw------- ldap ldap root:object_r:slapd_db_t gidNumber.bdb
    -rw------- ldap ldap root:object_r:slapd_db_t id2entry.bdb
    -rw------- ldap ldap root:object_r:slapd_db_t log.0000000001
    -rw------- ldap ldap root:object_r:slapd_db_t memberUid.bdb
    -rw------- ldap ldap root:object_r:slapd_db_t objectClass.bdb
    drwxr-xr-x ldap ldap root:object_r:slapd_db_t orig3
    drwxr-xr-x ldap ldap root:object_r:slapd_db_t replica
    drwxr-xr-x root root root:object_r:slapd_db_t rpmorig
    -rw------- ldap ldap root:object_r:slapd_db_t sambaDomainName.bdb
    -rw------- ldap ldap root:object_r:slapd_db_t sambaPrimaryGroupSID.bdb
    -rw------- ldap ldap root:object_r:slapd_db_t sambaSID.bdb
    -rw------- ldap ldap root:object_r:slapd_db_t sn.bdb
    -rw------- ldap ldap root:object_r:slapd_db_t uid.bdb
    -rw------- ldap ldap root:object_r:slapd_db_t uidNumber.bdb

    The replica dir is because I use slurpd to build a slave ldap server.

    Any suggestion is appreciate.

    Thank you.

  2. #2
    Join Date
    Feb 2006
    Posts
    780
    Quote Originally Posted by storto
    Hi all,

    This week I upgraded several servers to FC10 but for one I had a problem:

    slapd doesn't work anymore and init script exit with this error message:



    Checking configuration files for slapd: [FAILED]
    bdb(dc=tr1): Program version 4.6 doesn't match environment version 4.4
    bdb_db_open: database "dc=myldap" cannot be opened, err -30972. Restore from backup!
    backend_startup_one: bi_db_open failed! (-30972)
    slap_startup failed (test would succeed using the -u switch)
    stale lock files may be present in /var/lib/ldap [WARNING]


    I think that is a Barkley DB issue and not an openldap one.
    The horror...

    Check the install for db4. You'll probably need to install an older db4 (4.4) in order to read your database files. You have to migrate/transform these to 4.6 if you want to drop the dependency on the 4.4 version.

    David

  3. #3
    Join Date
    Mar 2007
    Posts
    4
    thank you for your hint

    I solved the problem running the red hat version of the bdb db_checkpoint (slapd_db_checkpoint) and then I changed the owner of the log file:

    slapd_db_checkpoint -1 -h /var/lib/ldap
    chown -R ldap.ldap /var/lib/ldap/*

    Now it's works.

    tnx

    storto
    http://www.morzello.com

Similar Threads

  1. slapd became too slow to start ... all of a sudden
    By rdcampos_br in forum Using Fedora
    Replies: 0
    Last Post: 8th September 2006, 03:51 AM
  2. Upgrade process similar to apt-get dist-upgrade?
    By veganopolis in forum Using Fedora
    Replies: 2
    Last Post: 8th April 2005, 01:26 AM
  3. Upgrade process similar to apt-get dist-upgrade?
    By veganopolis in forum Programming & Packaging
    Replies: 1
    Last Post: 8th April 2005, 12:39 AM
  4. slapd wont start
    By projkt4 in forum Servers & Networking
    Replies: 7
    Last Post: 6th September 2004, 09:06 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •