Amarok won't play mp3s
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 21
  1. #1
    Join Date
    Jun 2008
    Location
    Melbourne, Australia
    Posts
    169

    Amarok won't play mp3s

    I upgraded my Fedora 9 box to Fedora 10 recently. However, since doing so, I am unable to play mp3s in Amarok. The included version is 1.94. After not being able to play mp3s, I downloaded 1.98 from Koji. This made no difference. Things were fine in Fedora 9.

    I have xine-lib, xine-lib-extras, xine-lib-extras-freeworld and libtunepimp installed. I've downloaded all the F10 updates and all updates from RPM Fusion.

    When I launch an mp3 from Nautilus, Amarok launches but doesn't do anything. If I attempt to add mp3s from within Amarok, it won't even add them to the play list. This is frustrating, as it's now the only outstanding issue I have since upgrading to F10. I have this issue on two separate boxes.

    Any suggestions?

    EDIT: I note that mp3s are playing fine in Kaffeine, so it doesn't appear to be an issue with xine-lib.
    Last edited by Pumpino; 25th November 2008 at 02:26 AM.

  2. #2
    Join Date
    Oct 2007
    Location
    Macon, MO
    Age
    49
    Posts
    330
    Pumpino, I have a thread over in the F10 forum with the same issue, may want to check it out. Not solved yet but, thought I'd share..

    Cory

    http://forums.fedoraforum.org/showthread.php?t=204897

  3. #3
    Join Date
    Jun 2008
    Location
    Melbourne, Australia
    Posts
    169
    Thanks for that. I hadn't seen your thread. Nice to know it's not just me!

  4. #4
    akaraivanov Guest
    Hi guys,

    I've got amarok working in F10. Here is what I did:

    * added RPM Fussion repository (I am not sure if it is really needed. Initially I was going for xine related rpms but xine currently seems broken in F10)
    * installed phonon and phonon-backend-gstreamer
    * run totem and tried to play some mp3 files. It complained that it cannot decode mp3 and suggested to search for plugins. Then found and installed couple of packages
    * at this point totem and amarok were both working with mp3.

    I have the following packages installed:

    > rpm -qa |egrep 'phonon|gstream|amarok'
    PackageKit-gstreamer-plugin-0.3.9-4.fc10.i386
    phonon-4.2.0-7.fc10.i386
    gstreamer-plugins-base-0.10.21-2.fc10.i386
    gstreamer-plugins-flumpegdemux-0.10.15-4.fc10.i386
    gstreamer-0.10.21-2.fc10.i386
    amarok-1.94-2.fc10.i386
    gstreamer-plugins-ugly-0.10.9-2.fc10.i386
    gstreamer-tools-0.10.21-2.fc10.i386
    gstreamer-python-0.10.12-1.fc10.i386
    totem-gstreamer-2.24.3-1.fc10.i386
    phonon-backend-xine-4.1.3-1.fc10.i386
    gstreamer-plugins-good-0.10.11-1.fc10.i386
    phonon-backend-gstreamer-4.2.0-7.fc10.i386

    Hope, that may help someone.

    Cheers,

    Alex.

  5. #5
    Join Date
    Jun 2008
    Location
    Melbourne, Australia
    Posts
    169
    Thanks. Installing phonon-backend-gstreamer has resulted in Amarok successfully playing mp3s. I was just about to switch to RhythmBox or Totem. *shudders*

  6. #6
    Join Date
    Jun 2008
    Location
    Melbourne, Australia
    Posts
    169
    After trying Amarok 2, I think I will switch to another application like Rhythmbox! It's ugly and has less functionality than 1.4. :P

  7. #7
    BarBaar Guest
    Followed the steps as described above.. However, I still have no sound.

    When I play an album, I see all tracks being processed very quickly (+/- 3 secs for a track) without any sound..

  8. #8
    zecchinhg Guest
    su
    yum -y install amarok xine-lib-extras-freeworld

    You need to enable RPMFusion repositories first. Always works.

  9. #9
    oscar3332000 Guest

    Exclamation Amarok 1.4 Fedora 10

    Really amarok 1.94 is a poor beta version. So I had rebuilded amarok 1.4.10 for Fedora 10, I had some problems with libmtp but now it's ok.

    amarok-1.4.10-1.fc10.i386.rpm
    http://argsoft.net/rpms/amarok-1.4.10-1.fc10.i386.rpm

    amarok-visualisation-1.4.10-1.fc10.i386.rpm
    http://argsoft.net/rpms/amarok-visua....fc10.i386.rpm

    amarok-extras-freeworld-1.4.10-1.fc10.noarch.rpm
    http://argsoft.net/rpms/amarok-extra...c10.noarch.rpm

    for others architectures:
    amarok-1.4.10-1.fc10.src.rpm
    http://argsoft.net/rpms/amarok-1.4.10-1.fc10.src.rpm
    rebuild it with rpmbuild
    Code:
    rpmbuild --rebuild amarok-1.4.10-1.fc10.src.rpm
    on F10 pulseaudio produce some problems, verify on your amarok, gnome, kde, mplayer, xine,kaffeine... settings the driver; it could be alsa, oss, etc, but not pulseaudio

    please distribute these files until the next stable amarok version
    Last edited by oscar3332000; 1st December 2008 at 11:01 PM.

  10. #10
    Join Date
    Jan 2006
    Posts
    151
    In Amarok 1.98 I get a terrible amount of errors printed to .xsession-errors from amarok, including this nasty one:
    E: socket-client.c: socket(): Address family not supported by protocol

    I originally had no sound at all, and the phonon-backend-gstreamer rpm fixed that for me. Any ideas what this error means?

  11. #11
    Join Date
    Feb 2008
    Location
    Sydney
    Age
    30
    Posts
    435
    Quote Originally Posted by zecchinhg
    su
    yum -y install amarok xine-lib-extras-freeworld

    You need to enable RPMFusion repositories first. Always works.
    hi,

    dint work here..I installed only Gnome.. and then the command you've given.. I also though it always works.. Now things are looking different.. Dont quite knoqw why this is happening..

    regards,

    Ankur
    -------------------------------------
    "Live and let Live"
    My blog
    http://www.letmegooglethatforyou.com/
    #fedora, #fedora-india,#fedora-social @ freenode


    HP dv6226tx
    Fedora 13
    ---------------------------------------

  12. #12
    tmark78 Guest

    You don't have to use Amarok, TRY VLC

    Download VLC! It works perfect and plays video and Audio in almost any format I can think of!

  13. #13
    leigh123linux Guest
    Quote Originally Posted by sanjay_ankur
    hi,

    dint work here..I installed only Gnome.. and then the command you've given.. I also though it always works.. Now things are looking different.. Dont quite knoqw why this is happening..

    regards,

    Ankur

    Try
    Code:
    su
    yum install phonon-backend-gstreamer

  14. #14
    Join Date
    Feb 2008
    Location
    Sydney
    Age
    30
    Posts
    435
    Quote Originally Posted by leigh123@linux
    Try
    Code:
    su
    yum install phonon-backend-gstreamer
    hi,

    its showing the trck in now playing atleast.. not playing though.. stuck on 00 seconds.. anymore packages required? Shouldnt they have been resolved as deps when we insall using yum?

    regards,

    Ankur

    also.. yum is giving me this weird error ::
    Code:
    ERROR:dbus.proxies:Introspect error on :1.102:/org/freedesktop/PackageKit: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.DBus.Introspectable" member "Introspect" error name "(unset)" destination ":1.102")
    selinux?
    -------------------------------------
    "Live and let Live"
    My blog
    http://www.letmegooglethatforyou.com/
    #fedora, #fedora-india,#fedora-social @ freenode


    HP dv6226tx
    Fedora 13
    ---------------------------------------

  15. #15
    leigh123linux Guest
    Try

    Code:
    su
    yum install gstreamer* --exclude=gstreamer*devel
    as for yum

    http://forums.fedoraforum.org/showthread.php?t=206797

Page 1 of 2 1 2 LastLast

Similar Threads

  1. MP3s on my ipod dont work when i used amarok
    By C1ivey in forum Using Fedora
    Replies: 3
    Last Post: 21st January 2007, 05:20 PM
  2. Replies: 5
    Last Post: 6th December 2005, 01:32 AM
  3. How to play MP3s in KDE in FC2
    By L337h1uM in forum Using Fedora
    Replies: 8
    Last Post: 22nd October 2004, 04:05 PM
  4. can't play mp3s in fc2
    By sunilvarma in forum Using Fedora
    Replies: 4
    Last Post: 12th October 2004, 11:51 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •