Install Fedora on external USB 2.0 hard drive
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 3 1 2 3 LastLast
Results 1 to 15 of 41
  1. #1
    neomatic Guest

    Unhappy Install Fedora on external USB 2.0 hard drive

    Since one week I am trying to install Fedora 2.0 on my external USB 2.0 IBM hard drive (BIOS supports USB booting). For whatever reason, the Fedora installation process does not recognise my USB drive. I have researched on that topic but nobody seams to have solved that problem. Can anyone please help me to get Fedora installed on my external USB 2.0 hard drive???

    Thank you for your help.

  2. #2
    dwallom Guest
    I want to do the same. Were you successful?

    Don

  3. #3
    slartibartfast Guest
    I Need to do the same thing on an IBM T41 with a 40Gb IBM USB 2.0 drive
    Couldn't get Disk Druid to recognise the USB drive

  4. #4
    bobba99 Guest
    Hi,
    I have the same problem. Found this on the web :
    Haven't got it to work 100% yet, but I'm still trying.




    Booting (Red Hat) Fedora Core 2 Linux off of an USB HDD drive.
    95 % of this document is from http://www.simonf.com/usb authored by Simon Ilyushchenko. Simon's document is instructions for Redhat 9.0. Many thanks to his hard work and well written instructions. 5% is my work in modifying Simon's instructions to work for Fedora Core 2.

    Hardware: IBM R40 ThinkPad laptop. 1400 X 1050 pixel LCD display. External 40GB USB 2.0 HDD.

    First you need to install Linux. To avoid the possibility of messing up the internal HDD (which contains my Windows XP image), I removed the internal HDD drive and did not put it back into the laptop until the installation was complete. Remove one screw and the whole internal HDD slides right out.

    You must use the "linux expert" mode to in order for the installer to detect your USB hard drive.
    I had a 40GB drive, which I partitioned manually using Druid as follows: 102MB boot (sda1), 30GB root (sda2), 4GB swap (sda3), and 4GB VFAT (sda5) (sda4 is the extended partition). I highly recommend making a VFAT partition. This has become a handy way of transferring files back and forth between Linux and Windows XP.

    After the initial installation Linux will attempt to boot. But instead you will get a Panic error due to the boot image having no drivers loaded for USB.

    Double check that your BIOS is set up to boot from USB HDD before the internal HDD (or remove the internal HDD).

    Boot the system using the first installation CD, using "linux rescue" mode.

    Mount these partions manually and then change root to the hard disk's filesystem.

    mount /dev/sda2 /mnt/source
    mount /dev/sda1 /mnt/source/boot
    chroot /mnt/source
    You'll need to create a custom initrd image. Take your current image from /boot (see /etc/grub.conf for the exact name). In my case the exact name was "initrd-2.6.5-1.358.img".

    cp /boot/initrd-2.6.5-1.358.img /tmp/initrd.gzUnZIP the image.
    gunzip /tmp/initrd.gzMake a temporary directory to view the image with.
    mkdir /tmp/aNow mount the directory to view the contents of the image.

    mount -o loop /tmp/initrd /tmp/aThe file /tmp/a/linuxrc is the script that runs before the root partition is mounted. We need to make sure it can mount a USB partition.

    This was the original script:

    #!/bin/nash


    mount -t proc /proc /proc
    setquiet
    echo Mounted /proc filesystem
    echo Mounting sysfs
    mount -t sysfs none /sys
    echo "Loading jbd.ko module"
    insmod /lib/jbd.ko
    echo "Loading ext3.ko module"
    insmod /lib/ext3.ko
    echo Creating block devices
    mkdevices /dev
    echo Creating root device
    mkrootdev /dev/root
    umount /sys
    echo 0x0100 > /proc/sys/kernel/real-root-dev
    echo Mounting root filesystem
    mount -o defaults --ro -t ext3 /dev/root /sysroot
    pivot_root /sysroot /sysroot/initrd
    umount /initrd/procEdit your script to load the USB drivers.
    #!/bin/nash
    mount -t proc /proc /proc
    setquiet
    echo Mounted /proc filesystem
    echo Mounting sysfs
    mount -t sysfs none /sys
    echo "Loading jbd.ko module"
    insmod /lib/jbd.ko
    echo "Loading ext3.ko module"
    insmod /lib/ext3.ko echo "*** Loading scsi_mod ***"
    insmod /lib/scsi_mod.ko
    echo "*** Loading sd_mod ***"
    insmod /lib/sd_mod.ko
    echo "*** Loading usb-storage ***"
    insmod /lib/usb-storage.ko
    echo "*** Loading usb-uhci ***"
    insmod /lib/ehci-hcd.ko
    echo "*** Sleeping 5 seconds ***"
    /bin/sleep 5echo Creating block devices
    mkdevices /dev
    echo Creating root device
    mkrootdev /dev/rootecho "*** Reread partition table ***"
    /sbin/sfdisk -R /dev/sdaumount /sys
    echo 0x0100 > /proc/sys/kernel/real-root-dev
    echo Mounting root filesystem
    mount -o defaults --ro -t ext3 /dev/root /sysroot
    pivot_root /sysroot /sysroot/initrd
    umount /initrd/procCopy kernel modules into the initrd image. For example, if you are running kernel 2.6.5-1.358 (uname -r to find out),

    cd /lib/modules/2.6.5-1.358/kernel/drivers

    cp usb/ehci-hcd.ko /tmp/a/lib
    cp usb/storage/usb-storage.ko /tmp/a/lib
    cp scsi/scsi_mod.ko /tmp/a/lib
    cp scsi/sd_mod.ko /tmp/a/lib
    Find out what libraries sleep and sfdisk use from the output of ldd:

    ldd /bin/sleep
    ldd /sbin/sfdisk
    Copy the libraries into /tmp/a/lib. In my case it was:

    mkdir /tmp/a/lib/tls
    cp /lib/tls/libm.so.6 /tmp/a/lib/tls
    cp /lib/tls/libpthread.so.0 /tmp/a/lib/tls
    cp /lib/tls/libc.so.6 /tmp/a/lib/tls
    cp /lib/tls/librt.so.1 /tmp/a/lib/tls
    cp /lib/ld-linux.so.2 /tmp/a/lib
    Copy the executables over:

    cp /bin/sleep /tmp/a/bin
    cp /sbin/sfdisk /tmp/a/sbin
    Everything you need is now in the image, so unmount the image.

    umount /tmp/aZIP it back up.

    gzip /tmp/initrdCopy it back into the boot partition.

    cp /tmp/initrd.gz /boot/usbinird.imgUpdate your /boot/grub/grub.conf to use the new usbinitrd.img. Here is what my grub.conf looks like:

    # grub.conf generated by anaconda
    #
    # Note that you do not have to rerun grub after making changes to this file
    # NOTICE: You have a /boot partition. This means that
    # all kernel and initrd paths are relative to /boot/, eg.
    # root (hd0,0)
    # kernel /vmlinuz-version ro root=/dev/sda2
    # initrd /initrd-version.img
    #boot=/dev/sda
    default=0
    timeout=10
    splashimage=(hd0,0)/grub/splash.xpm.gz
    title Fedora Core (2.6.5-1.358) USB 2.0 Boot
    root (hd0,0)
    kernel /vmlinuz-2.6.5-1.358 ro root=LABEL=/ rhgb quiet
    #The following line is the custom made USB 2.0 boot image.
    initrd /usbinird.img
    #The following line was the original boot image.
    #initrd /initrd-2.6.5-1.358.img
    Your machine should now boot from the external USB 2.0 HDD!

    Last updated May 30, 2004.

  5. #5
    snorri Guest
    Quote Originally Posted by bobba99
    Hi,
    I have the same problem. Found this on the web :
    Haven't got it to work 100% yet, but I'm still trying.
    I've gotten it to work with FC1 using a similar process to that outlined. The important thing is to work out what modules your usb drivers need. With FC1 I added

    usbcore
    usb-storage
    usb-hci
    ehci-hcd

    in that order to the front of the linuxrc script in the initrd image. Order is important! Doesn't work for instance if you load usbcore up last as the others depend on it.

    However with just the usb modules it still failed as it wasn't getting enough time to actually find the usb hard drive. So I added the sleep function as well and it all worked fine. The fdisk wasn't necessary.

    If anyone wants some help with this post here and I'll check back in now and then.

    Cheers,
    Snorri.

  6. #6
    koukos Guest
    I have made a bootcd iso, with grub, and a script for making it, so i can boot my usb disk on a computer that cannot support usb boot. I am searching for web space. As soon as i upload it, i will post a link here.

  7. #7
    dave_os Guest
    Has anyone (else) got this to work with FC3?
    I followed the Doc page by Allen Benusa (http://www.benusa.com/linux/boot.htm), taking note of some of the FC3 specific things mentioned in the original page by Simon Ilyushchenko (http://simonf.com/usb/), however I don't even get into my modified initrd script under FC3 - I get a kernel panic during kernel boot [right after audit(1103181601.520:0): Initialized) I get:
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)]

    Which suggests I'm not every getting as far as the initrd script to load the USB drivers.

    I'd be interested to hear from anyone who has this working under FC3.

  8. #8
    basophobic Guest
    Same here dave_os! I had installed FC3 on an external USB HDD with success but got stuck with kernel panic during kernel boot. I have altered the /tmp/a/init file as on the previous links (btw...should we need to create a new linuxrc as in FC2 or just play with the init file?)

    Any suggestion is appreciated!

  9. #9
    basophobic Guest
    SOLVED FOR FEDORA CORE3.
    I found this on http://www.linuxforums.org/forum/post-145456.html and I quote for convenience:

    my set up is / on /dev/sda3, and /boot on /dev/sda1, yours may differ:

    Code:
    mount /dev/sda3 /mnt/source
    mount /dev/sda1 /mnt/source/boot
    chroot /mnt/source


    Next, create the initrd, with the usb driver included:
    Code:
    mkinitrd --preload=ehci-hcd --preload=usb-storage --preload=scsi_mod --preload=sd_mod /boot/initrd.img 2.6.9-1.667smp


    If you are running a different kernel version than 2.6.9-1.667, then put it there instead, and if you dont have dual processor/hyper-threading, then leave out the smp.

    Now, you have to edit your grub.conf:
    Code:
    vi /boot/grub/grub.conf

    put the new initrd file name "initrd.img" in place of whats there. save and exit.

    I used this and IT WORKED!

    Hope this helps you!

  10. #10
    dave_os Guest
    basophobic is right - I tried this under FC3 with Lacie USB 2.0 60GB P2 HDD and it worked.
    Now my only problem is installing X (as I did a miniminal install to save time mucking around )
    A bit more detail on my experience/config on the linuxforum basophobic mentioned (http://www.linuxforums.org/forum/post-145456.html)

    I'm working with the oringator of the solution posted by bobba to get the FC3 relevant info linked in.

  11. #11
    ducky Guest
    hello,

    i'm wondering if anyone would be able to help me. i installed FC3 onto a hd in an external enclosure. i can boot from usb. there is no internal hdd

    i installed in linux expert mode and used automatic partitioning.

    when the install finishes and i boot using linux rescue - i cannot follow basophobic's instructions.

    when i type mount /dev/sda3 /mnt/source it simply comes back with invalid argument.

    anyone have a solution? i'm a complete linux newbie.

  12. #12
    Wongster Guest
    Hi guys,

    I was full of envy when all I saw from your posts that you're able to install FC3 to your usb using linux expert. I tried numerous time using that but Druid still didn't see my usb hd. I had to remove the hd from its enclosure to have it inserted into the hd bay on my notebook.

    After installing FC3, I put the hd back into its enclosure and try to boot up. Kernel panic... like most of you. I use the rescue disc and try to mount sda manual as my usb hd wasn't recognised. Problem is, I can't mount it at all....

    Anyone can help?

    Wongster

  13. #13
    warcious Guest
    Hi guys,

    I habe the same problem. I can not use linux "expert" mode, cause Fedora2, Fedora3 won't recognize my hdd.
    I have tried with my USB memory, and both Fedora2 and Fedora3 (druid) can see it and I can install.

    Maybe there is a problem with our 2.5" USB HDD cases ????
    I have the most typical one that you can find easily on EBAY with the name "VAIO" typed on the metal cover box.

    Anyone got any advice?

    Sincerely,
    Warcious

  14. #14
    deucez Guest
    I just wanted to say thanks for the info on how to do this. I'm new to Linux and would like to start using it more, but didn't want to dual boot on my work laptop. So this gave me the perfect opportunity to learn where ever I am. I picked up a 40gb Smartdisk Firelite drive and FC3 installed and booting a couple of hours.

  15. #15
    Wongster Guest
    Hi Warcious,

    I don't think its a problem with my enclosure. I successfully installed Mandrake Official 10.1 on a USB HD using expert mode. The good thing about Mandrake is that it runs straight after installation! I don't have kernel panic problem and there is nothing to change. Just install, reboot, and I'm in!

    That's why I still puzzled about why FC3 doesn't seem to see my USB hd even using "linux noprobe" and loading the usb-storage module during installation.

    Hope someone can help, or at least point me to some places where I can continue my search. I've been googling for a long long time for a solution.

    Wongster

Page 1 of 3 1 2 3 LastLast

Similar Threads

  1. How to install F10 on Ps3 EXTERNAL HARD DRIVE
    By botossi in forum Mac Chat
    Replies: 0
    Last Post: 6th April 2009, 08:59 PM
  2. Install Fedora 9 on external mybook hard drive
    By Clean14 in forum Installation, Upgrades and Live Media
    Replies: 0
    Last Post: 24th May 2008, 07:48 AM
  3. Install Fedora on an external hard drive?
    By DigitalDingo in forum Using Fedora
    Replies: 2
    Last Post: 15th November 2006, 08:40 PM
  4. How to install from an external USB Hard Drive
    By freddy94 in forum Installation, Upgrades and Live Media
    Replies: 5
    Last Post: 19th November 2004, 05:18 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •