Nvidia 177.82 howto for F10
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 12 1 2 3 11 ... LastLast
Results 1 to 15 of 175
  1. #1
    leigh123linux Guest

    Nvidia 177.82 howto for F10

    1. Install the release key


    Code:
    su
    rpm -Uvh http://download1.rpmfusion.org/free/fedora/development/i386/os/rpmfusion-free-release-10-1.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/development/i386/os/rpmfusion-nonfree-release-10-1.noarch.rpm


    2. Install the driver

    Code:
    su
    yum install kmod-nvidia xorg-x11-drv-nvidia-libs xorg-x11-drv-nvidia


    Or if you like playing with unreleased Koji kernels

    Code:
    su
    yum install akmod-nvidia xorg-x11-drv-nvidia-libs xorg-x11-drv-nvidia


    64 bit users will also need to install the 32 bit libs for apps like Wine.

    Code:
    su
    yum install xorg-x11-drv-nvidia-libs.i386

    3, Reboot.
    Last edited by leigh123linux; 17th November 2008 at 11:14 AM.

  2. #2
    Join Date
    Oct 2006
    Posts
    4,757
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Nice! Thanks.

    nv works just fine now so I wasn't too concerned but was getting a little tired of the lifeless windows...

  3. #3
    Join Date
    Sep 2006
    Location
    Connellsville, PA, USA
    Posts
    11,308
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Because of the <insert any number> kernel the nvidia driver needs patching !
    So, what else is new?

    Really sorry, I just couldn't resist....

    V

  4. #4
    Join Date
    Jan 2006
    Location
    Anderson. SC
    Age
    70
    Posts
    185
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for the info.. Now I can make f10 work for me... had that crummy kernel-devel error even though it was on the machine... fought it this am and here you have a fix the same night....
    If It Ain't Broke Keep Tweaking Till It Is!
    [SIGPIC][/SIGPIC]

    :eek:-<CloneU2>- :eek:
    Powered By A Fedora-15 (x86_64) Engine !
    | EVGA nForce 680i SLI Motherboard | Intel-Q9400 2.66Ghz@3.4 Ghz With ULTRA ChillTek-(100% Load @ 97 F) | 8Gigs OCZ SLI Ram (2)| WD 320 gig hd | (2) WD 500 gig HD in Raid0| |Nvidia GTX 470 (superclocked) |650W PS | TV card | WIFI card |NZXT case|

  5. #5
    leigh123linux Guest
    Quote Originally Posted by cloneu2
    Thanks for the info.. Now I can make f10 work for me... had that crummy kernel-devel error even though it was on the machine... fought it this am and here you have a fix the same night....

    I haven't managed to get the driver to build on any kernel higher than kernel-2.6.27-0.208.rc1 at the moment .

  6. #6
    Join Date
    Jul 2008
    Posts
    1,348
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Make sure you are re-extracting the sources when trying to compile for a new
    kernel. I was running into problems after awhile by not doing that. Since I use
    rawhide kernels, and they change constantly, I wrote a little build script to auto-
    mate the tediousness. I've attached it below.
    1. Download script to director with patch and driver.
    2. Strip off the .txt extension (optional)
    3. Change to init 3 (script checks this too)
    4. sh nvidia-build.sh --uninstall
    5. sh nvidia-build.sh [any extra args, like -a]
    6. init 5

    The script passes -Nn to the nvidia-installer, pass any others on the command line.
    You can skip the runlevel check by passing --no-x-check, but the installer will still
    do its checks for a running module and such, so this is only useful when you aren't
    currenly using the nvidia driver.

    Feel free to modify, update, pass it around to friends and pets, whatever.

    I'm currently running the nvidia driver on kernel-2.6.27-0.237.rc2.fc10.x86_64.
    Attached Files Attached Files

  7. #7
    leigh123linux Guest
    Quote Originally Posted by vallimar
    Make sure you are re-extracting the sources when trying to compile for a new
    kernel. I was running into problems after awhile by not doing that. Since I use
    rawhide kernels, and they change constantly, I wrote a little build script to auto-
    mate the tediousness. I've attached it below.
    1. Download script to director with patch and driver.
    2. Strip off the .txt extension (optional)
    3. Change to init 3 (script checks this too)
    4. sh nvidia-build.sh --uninstall
    5. sh nvidia-build.sh [any extra args, like -a]
    6. init 5

    The script passes -Nn to the nvidia-installer, pass any others on the command line.
    You can skip the runlevel check by passing --no-x-check, but the installer will still
    do its checks for a running module and such, so this is only useful when you aren't
    currenly using the nvidia driver.

    Feel free to modify, update, pass it around to friends and pets, whatever.

    I'm currently running the nvidia driver on kernel-2.6.27-0.237.rc2.fc10.x86_64.

    Thank you for posting the patch on the Nv news forum

    http://nvnews.net/vbulletin/showpost...12&postcount=1

  8. #8
    Join Date
    Jul 2008
    Posts
    1,348
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    No problem - Thankfuly others had done some nicer stuff already so I decided to use
    their work instead of the primitive hack-job I started with on my own, then just added back
    the needed bits for the newer kernels.

    Let me know if you still have problems with newer kernels on a fresh extraction.
    I think one time I had to do a manual module build first.. To do that, just extract
    the driver, enter the usr/src/nv dir, and do "make module", provided that works,
    you should be able to install okay.

  9. #9
    leigh123linux Guest
    I still get the same error on the newer 2.6.27 kernels !

    Using: nvidia-installer ncurses user interface
    -> License accepted.
    -> Installing NVIDIA driver version 177.13.
    -> Not probing for precompiled kernel interfaces.
    -> Performing CC sanity check with CC="cc".
    -> Performing CC version check with CC="cc".
    -> Kernel source path: '/lib/modules/2.6.27-0.237.rc2.fc10.x86_64/source'
    -> Kernel output path: '/lib/modules/2.6.27-0.237.rc2.fc10.x86_64/build'
    ERROR: If you are using a Linux 2.4 kernel, please make sure
    you either have configured kernel sources matching your
    kernel or the correct set of kernel headers installed
    on your system.

    If you are using a Linux 2.6 kernel, please make sure
    you have configured kernel sources matching your kernel
    installed on your system. If you specified a separate
    output directory using either the "KBUILD_OUTPUT" or
    the "O" KBUILD parameter, make sure to specify this
    directory with the SYSOUT environment variable or with
    the equivalent nvidia-installer command line option.

    Depending on where and how the kernel sources (or the
    kernel headers) were installed, you may need to specify
    their location with the SYSSRC environment variable or
    the equivalent nvidia-installer command line option.
    ERROR: Installation has failed. Please see the file
    '/var/log/nvidia-installer.log' for details. You may find suggestions
    on fixing installation problems in the README available on the Linux
    driver download page at www.nvidia.com.

  10. #10
    Join Date
    Jul 2008
    Posts
    1,348
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Strange, I just removed and re-installed the driver with no problems.
    What errors do you get if you do a manual kmod compile from the
    extracted sources?

  11. #11
    leigh123linux Guest
    Quote Originally Posted by vallimar
    Strange, I just removed and re-installed the driver with no problems.
    What errors do you get if you do a manual kmod compile from the
    extracted sources?
    Here the output !

    [root@localhost ~]# cd /home/leigh/NVIDIA-Linux-x86_64-177.13-pkg2/usr/src/nv/
    [root@localhost nv]# make module
    If you are using a Linux 2.4 kernel, please make sure
    you either have configured kernel sources matching your
    kernel or the correct set of kernel headers installed
    on your system.

    If you are using a Linux 2.6 kernel, please make sure
    you have configured kernel sources matching your kernel
    installed on your system. If you specified a separate
    output directory using either the "KBUILD_OUTPUT" or
    the "O" KBUILD parameter, make sure to specify this
    directory with the SYSOUT environment variable or with
    the equivalent nvidia-installer command line option.

    Depending on where and how the kernel sources (or the
    kernel headers) were installed, you may need to specify
    their location with the SYSSRC environment variable or
    the equivalent nvidia-installer command line option.

    *** Unable to determine the target kernel version. ***

    make: *** [select_makefile] Error 1
    [root@localhost nv]# rpm -qa |grep kernel
    kernel-devel-2.6.27-0.237.rc2.fc10.x86_64
    kernel-2.6.27-0.208.rc1.git2.fc10.x86_64
    kerneloops-0.11-1.fc10.x86_64
    kernel-devel-2.6.27-0.226.rc1.git5.fc10.x86_64
    kernel-headers-2.6.27-0.237.rc2.fc10.x86_64
    kernel-2.6.27-0.226.rc1.git5.fc10.x86_64
    kernel-2.6.27-0.237.rc2.fc10.x86_64
    kernel-devel-2.6.27-0.208.rc1.git2.fc10.x86_64
    kernel-firmware-2.6.27-0.237.rc2.fc10.noarch
    [root@localhost nv]# uname -r
    2.6.27-0.237.rc2.fc10.x86_64
    [root@localhost nv]#

    Please could you upload your nvidia.ko for kernel-2.6.27-0.237 as your also running 64bit ( I can manually copy it to it's correct location )


    Thanks

    Leigh

  12. #12
    Join Date
    Jul 2008
    Posts
    1,348
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I'm pretty sure I found the problem, I forgot I had done this before, but I just updated to the 238 kernel.. It seems the packager is stripping out more stuff in the kernel-devel package. You have to enter the /usr/src/kernels/<kernel> for your current kernel and do "make prepare". This will recreate the include/asm symlink and a couple other things and then error out. Don't worry about the error. After you've done this, you should be able to compile the module. Kinda dumb, but there you go. If still not working, let me know and I'll upload the kmod. Check the nvnews thread as well, I made a slightly updated patch to remove usage of a deprecated symbol. Should be good, but I'm not a kernel-dev, so....
    Last edited by vallimar; 8th August 2008 at 04:44 PM. Reason: Typo fixes

  13. #13
    Join Date
    Jan 2006
    Location
    Anderson. SC
    Age
    70
    Posts
    185
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks guys.. did a rawhide (alpha) reinstall and then updated the kernel. Applied the patch and then did the other trick and IT COMPILED.. Got Nvidia driver working on a dual head and now I can play and see how long it takes to completely trash the system!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	F10.jpg 
Views:	470 
Size:	404.0 KB 
ID:	16972  
    Last edited by cloneu2; 8th August 2008 at 09:17 PM.
    If It Ain't Broke Keep Tweaking Till It Is!
    [SIGPIC][/SIGPIC]

    :eek:-<CloneU2>- :eek:
    Powered By A Fedora-15 (x86_64) Engine !
    | EVGA nForce 680i SLI Motherboard | Intel-Q9400 2.66Ghz@3.4 Ghz With ULTRA ChillTek-(100% Load @ 97 F) | 8Gigs OCZ SLI Ram (2)| WD 320 gig hd | (2) WD 500 gig HD in Raid0| |Nvidia GTX 470 (superclocked) |650W PS | TV card | WIFI card |NZXT case|

  14. #14
    leigh123linux Guest
    Quote Originally Posted by vallimar
    I'm pretty sure I found the problem, I forgot I had done this before, but I just updated to the 238 kernel.. It seems the packager is stripping out more stuff in the kernel-devel package. You have to enter the /usr/src/kernels/<kernel> for your current kernel and do "make prepare". This will recreate the include/asm symlink and a couple other things and then error out. Don't worry about the error. After you've done this, you should be able to compile the module. Kinda dumb, but there you go. If still not working, let me know and I'll upload the kmod. Check the nvnews thread as well, I made a slightly updated patch to remove usage of a deprecated symbol. Should be good, but I'm not a kernel-dev, so....
    Thanks


    Running ' make prepare ' has fixed the error !

  15. #15
    Join Date
    Oct 2006
    Location
    E. San Francisco Bay Area
    Posts
    194
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Seems the kernel-2.6.27-0.244 kernel update this morning breaks something. After installing this morning's update, the procedure described above, extracting and patching the installer and the doing a "make prepare" in /usr/src/kernels/`uname -r`, then running the installer, produces the same errors Leigh originally reported.

    Regards,
    Bert
    Those who dance are often mistaken for insane
    By those who cannot hear the music...

Page 1 of 12 1 2 3 11 ... LastLast

Similar Threads

  1. F11 Howto for the rpmfusion nvidia drivers
    By leigh123linux in forum Alpha, Beta & Snapshots Discussions (Fedora 11 Only)
    Replies: 66
    Last Post: 6th June 2009, 07:23 PM
  2. HowTo: DualHead on NVidia - Fedora 9
    By Alecfyz in forum Guides & Solutions (Not For Questions)
    Replies: 7
    Last Post: 14th October 2008, 07:20 PM
  3. HOWTO: nVidia + Twinview + Desktop effects + FC6
    By lordbeholder in forum Hardware
    Replies: 2
    Last Post: 15th December 2006, 07:20 PM
  4. FC5: Howto install nVidia drivers
    By louise in forum Guides & Solutions (Not For Questions)
    Replies: 0
    Last Post: 15th June 2006, 08:24 PM
  5. howto enable nvidia tv-out or dual display on FC3
    By nelwa in forum Using Fedora
    Replies: 3
    Last Post: 2nd March 2005, 03:43 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •