Wrong number of batteries
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    RGB Guest

    Wrong number of batteries

    Fedora 8, 64 bits on a Toshiba Satellite P200-17D. Using kde 3.5.9
    Since a couple of weeks, kpowersave shows two batteries instead of one. This issue started after a normal yum update but didn't revert after many other updates.
    The main problem with this is that kpowersave fails to calculate the battery status and then is not reliable.
    Any hint?
    Thanks!

  2. #2
    Join Date
    Aug 2007
    Location
    Liverpool, UK
    Posts
    729
    Same here. I have opened a bug report about this. Please add a "me too" to the bug report and post the output of "lshal | grep -i bat" in your response:

    https://bugzilla.redhat.com/show_bug.cgi?id=452356

    Cheers
    C

  3. #3
    RGB Guest
    Done! Thanks!

  4. #4
    Join Date
    Aug 2007
    Location
    Liverpool, UK
    Posts
    729
    Excellent, thanks!

    Meanwhile I have built a set of patched HAL RPMs that fix the problem and made them available here:

    http://www.cenolan.com/2008/07/fedor...d-twice-error/

    C

  5. #5
    RGB Guest
    Thanks!
    (BTW, nice site!)

  6. #6
    Join Date
    Aug 2007
    Location
    Liverpool, UK
    Posts
    729
    Just a FYI, the original RPMs I had on my site didn't fully fix the problem (battery charge/discharge rate was incorrect). I have now updated the RPMs on my site to include a new patch that does fully resolve the issue.

Similar Threads

  1. Using Laptop OEM Batteries
    By mndar in forum Hardware & Laptops
    Replies: 0
    Last Post: 31st August 2009, 07:55 AM
  2. F11 + Dual Batteries
    By alongwor in forum Hardware & Laptops
    Replies: 0
    Last Post: 29th June 2009, 08:43 AM
  3. SSL3_GET_RECORD:wrong version number:s3_pkt.c:284
    By marko in forum Servers & Networking
    Replies: 0
    Last Post: 31st July 2008, 07:47 PM
  4. ls lists wrong number of files
    By mjrice in forum Using Fedora
    Replies: 4
    Last Post: 17th June 2007, 03:17 PM
  5. Batteries not working
    By super_teds in forum Hardware & Laptops
    Replies: 1
    Last Post: 16th July 2005, 04:53 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •