grub error 25
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    Join Date
    Feb 2005
    Posts
    62

    grub error 25

    Hi,

    I was wondering if anyone could assist as although google brings back quite a bit on this error, I have to say I am a bit stumped. I installed Fedora 9 onto a spare partition on my machine (dual boot with Windows XP). All seemed fine when I got to the reboot stage but after the reboot, it appears I have a grub issue. Error shown is:

    GRUB Loading stage1.5.

    GRUB loading, please wait....
    Error 25

    I never get to the stage of seleting which OS to boot. Everything I have seen seems to suggest an issue with menu.lst but I cant see the issue:

    menu.lst:
    Code:
    # grub.conf generated by anaconda
    #
    # Note that you do not have to rerun grub after making changes to this file
    # NOTICE:  You have a /boot partition.  This means that
    #          all kernel and initrd paths are relative to /boot/, eg.
    #          root (hd2,1)
    #          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
    #          initrd /initrd-version.img
    #boot=/dev/sda
    default=1
    timeout=5
    splashimage=(hd2,1)/grub/splash.xpm.gz
    hiddenmenu
    title Fedora (2.6.25-14.fc9.i686)
    	root (hd2,1)
    	kernel /vmlinuz-2.6.25-14.fc9.i686 ro root=UUID=ad9ee8d1-a10e-4734-a457-e84df4c7abca rhgb quiet
    	initrd /initrd-2.6.25-14.fc9.i686.img
    title Other
    	rootnoverify (hd0,0)
    	chainloader +1
    device.map:
    Code:
    (fd0)	/dev/fd0
    (hd0)	/dev/sda
    (hd1)	/dev/sdb
    (hd2)	/dev/sdc
    This machine has 3 hard disks. sda1 and 2 are IDE drives and sda3 (where fedora is) is an sata drive. fdisk and blkid show the following:

    fdisk:
    Code:
    Disk /dev/sda: 80.0 GB, 80026361856 bytes
    255 heads, 63 sectors/track, 9729 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x02e202e1
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1   *           1        9728    78140128+   7  HPFS/NTFS
    
    Disk /dev/sdb: 81.9 GB, 81964302336 bytes
    255 heads, 63 sectors/track, 9964 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0xc32e4e61
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1   *           1        9964    80035798+   7  HPFS/NTFS
    
    Disk /dev/sdc: 250.0 GB, 250000000000 bytes
    255 heads, 63 sectors/track, 30394 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x00000080
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdc1               1       20397   163838871    7  HPFS/NTFS
    /dev/sdc2   *       20398       20422      200812+  83  Linux
    /dev/sdc3           20423       30394    80100090   8e  Linux LVM
    blkid:
    Code:
    /dev/sdb1: UUID="5640D03B40D02391" TYPE="ntfs" 
    /dev/sr0: LABEL="Fedora 9 i386 DVD" TYPE="iso9660" 
    /dev/sda1: UUID="440CB7FD0CB7E856" TYPE="ntfs" 
    /dev/sdc1: UUID="400C2E870C2E77D4" LABEL="Local Disk" TYPE="ntfs" 
    /dev/sdc2: LABEL="/boot" UUID="54d4bd39-60d4-439f-8e15-0269b8b8e3f5" TYPE="ext3" 
    /dev/sdc3: UUID="gM2XA7-F7Si-4NqC-nqB9-RSbo-4AVa-Xegyuk" TYPE="lvm2pv" 
    /dev/mapper/VolGroup00-LogVol00: UUID="ad9ee8d1-a10e-4734-a457-e84df4c7abca" TYPE="ext3" 
    /dev/mapper/VolGroup00-LogVol01: TYPE="swap" UUID="cff414ca-f766-463f-a027-a2e0bb5eff3f" 
    /dev/VolGroup00/LogVol00: UUID="ad9ee8d1-a10e-4734-a457-e84df4c7abca" TYPE="ext3" 
    /dev/VolGroup00/LogVol01: TYPE="swap" UUID="cff414ca-f766-463f-a027-a2e0bb5eff3f" 
    /dev/loop0: TYPE="squashfs"
    Does anyone have any idea whats going on? Any pointers would be appreciated. I have tried reinstalling grub a couple of times (one to the mbr on sda and the other to sdc) however the error 25 was present after both attempts. I have also run each of the grub manually and the grub.conf can be found and none of the commands seem to throw any errors.

    Cheers,
    Lee

  2. #2
    Join Date
    Jul 2005
    Posts
    66
    There has been some problems about grub and fedora 9.
    Mine broke after an update.
    I would advise you to boot using the rescue mode of our installation disk and then use install-grub to put it back on tracks.
    I have no idea why this happens, but it did on 2 machines I use already (though I didn't get any error number, just a "GRUB_" which would stay there)... scary stuff the first time.

    EDIT: check this thread Fedora 9 - Update - Grub Black Screen
    Last edited by Xinef; 14th June 2008 at 06:12 AM.

  3. #3
    Join Date
    Feb 2005
    Posts
    62
    Hi

    Many thaks for the suggestion however unfortunatly I have already tried that with no joy. Grub reinstalls without any errors however when it tries to load again after I reboot to get the error 25 again. I guess it must be a different problem to that in your link

    Cheers
    Lee

  4. #4
    Join Date
    Jul 2005
    Posts
    66
    Some people seem to have reported problems with outdated motherboard bios.
    Someone has fixed his error 25 using this:http://users.bigpond.net.au/hermanzo...skPage.html#25

    Finally, the error content seems to be:
    25 : Disk read error
    This error is returned if there is a disk read error when trying to probe or read data from a particular disk.
    Someone actually swapped his HDDs and installed grub on one that would work.
    I'd say, if you cannot fix it soft, check some bios settings or try to update it... (careful though)

  5. #5
    Join Date
    Jan 2006
    Posts
    2,799
    Also it looks like you installed the /boot partition after a large ntfs partition (160gb) so it may be that your motherboard bios can't handle 48 bit lba and thus can't read past about 128gb on the drive or so.

Similar Threads

  1. Fedora 9 Grub error Error 15 File not found
    By QuantumKnot in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 14th May 2008, 07:35 AM
  2. Grub won't chainload to grub: Error 13
    By nyjetshead in forum Using Fedora
    Replies: 3
    Last Post: 25th January 2008, 06:29 PM
  3. Boot-up error --- GRUB Loading stage2Read Error
    By xboomerx in forum Installation, Upgrades and Live Media
    Replies: 2
    Last Post: 19th November 2006, 05:42 PM
  4. Grub boot CD gives only Error 25 Disk Read Error
    By electron1948 in forum Installation, Upgrades and Live Media
    Replies: 2
    Last Post: 15th October 2005, 07:30 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •