can't connect to samba server
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 23
  1. #1
    paperdiesel Guest

    can't connect to samba server

    I set up a samba share on my fc2 laptop, and I can't seem to connect to it from Windows XP or another fc2 laptop. Here's my samba server config. Keep in mind that I want it simple, no hassle, guest access where anyone can read/write/delete, etc.

    config:

    [global]
    workgroup = boxes
    netbios name = arsenal
    hosts allow = 192.168.1. 192.168.2. 127.
    security = share

    [ paperarsenal ]
    comment = whatever
    path = /public
    read only = no
    writable = yes
    guests ok = yes
    browseable = yes
    public = yes

    the /public directory is drwxrwxrwx. What gives? I just know I'm missing something simple here..

  2. #2
    graffg Guest
    Hi!
    Check your firewall settings.

  3. #3
    bamboo_spider Guest

    agree with graffg

    Hi
    I agree with graffg , I too set up SAmba and nothing happened until i put off the firewall

    However before you do that run a search on your windows for you Linux machine , do a search for the computer by IP and by name you will get some results. Try this before you shut your firewall and then if it does not work then try it after putting off your firewall

    Once you get the computer on your win machine then share one folder that will be accessible to the win machine - map it and its done, I think

  4. #4
    paperdiesel Guest
    Quote Originally Posted by graffg
    Hi!
    Check your firewall settings.
    The firewall is disabled. Always has been. I have connectivity to the linux box from XP.. I can ping it, and when I try to browse the samba drive, I get a login/password. Do I need to add a guest account to linux or something? What gives?

  5. #5
    bamboo_spider Guest
    Hi
    I am new but managed to setup one way Samba (can access it from win xp not the otherway around)

    Try and make a login in FC which has the same name as the win machine and then try the suggestions give in my earlier post.

    Don't know anthing about command line so I do everything graphically.

    Also visit page in forum Software / Samba Mounting Problems

    Something is bound to work (thats a windows type reply ]

    Bamboo
    PIII Laptop
    20 GB HDD (make ??)
    386 mb RAM
    FC1 (no dual bootup)
    Uttaranchal India

  6. #6
    Jaws Guest
    Sorry for hijacking this thread -- but I am having the same problem. ._. Once I disabled my firewall though, samba started working. So my question is, how do I configure iptables to allow the samba server to communicate with the other computers on my network?

    Again, sorry for hijacking this thread. -_-

    -Jaws

  7. #7
    ghaefb Guest
    The easiest way is to flush all iptables rules.
    (must be root)
    Code:
    /usr/sbin/iptables -F

  8. #8
    Jaws Guest
    Quote Originally Posted by ghaefb
    The easiest way is to flush all iptables rules.
    (must be root)
    Code:
    /usr/sbin/iptables -F
    If I do that, will all my ports be open? I want this computer to be as safe as it can be, since it will be online 24 x 7, and it will be run as a server.

    Thanks.

    -Jaws

  9. #9
    wreichert Guest
    Seems the security=share is broken in the 3.0.3 FC2 samba. You shouldn't be prompted for a username / password with this setting. I installed the FC1 3.0.4 & everything works fine. Other option is to use the dev tree for yum, its currently at 3.0.5pre1.

    Wil

  10. #10
    Join Date
    May 2004
    Location
    UK
    Posts
    399
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by paperdiesel
    The firewall is disabled. Always has been. I have connectivity to the linux box from XP.. I can ping it, and when I try to browse the samba drive, I get a login/password. Do I need to add a guest account to linux or something? What gives?
    Yes, you need to set up a samba account on the linux box. The easiest way is to create users with exactly the same username/password as their WinXP accounts their trying to connect from.

    Ned

  11. #11
    Join Date
    May 2004
    Location
    UK
    Posts
    399
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Jaws
    If I do that, will all my ports be open? I want this computer to be as safe as it can be, since it will be online 24 x 7, and it will be run as a server.

    Thanks.

    -Jaws
    Yes, don't do that!

    You need to open ports 137, 138, and 139 used by the NetBIOS service so your Samba server can broadcast it's existance and clients can connect to it. Only open these ports for your internal lan

    $ iptables -A INPUT -p ALL -i eth0 -s 192.168.0.1 --destination-port 137:139 -j ACCEPT

    If you're unfamiliar with iptables, this will open traffic for all protocols (tcp, udp, icmp) to your local ethernet port 0 from ip 192.168.0.1 (your XP machine wanting to connect) on ports 137-139. Add additional lines for each ip address to be allowed to access or change to -s 192.168.0.0/24 which is the same as a 255.255.255.0 subnet mask to open up access from all IPs in the 192.168.0 range (or whatever private ip address range you're using on your lan).

    If you're worried, you can use something like the Shilds Up (www.grc.com) website after tinkering with your firewall to make sure you haven't opened anything that shouldn't be to the whole world - if you've done it right, samba should work and ports 137-139 should still be stealthed to the outside world

    Ned
    Last edited by Ned; 16th July 2004 at 05:11 AM.

  12. #12
    Jaws Guest
    Thanks Ned. That seemed to do what I wanted !

    -Jaws

  13. #13
    Join Date
    May 2004
    Location
    UK
    Posts
    399
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Jaws
    Thanks Ned. That seemed to do what I wanted !

    -Jaws
    No problem

    There are some excellent tutorials for iptables around on the web - it's not that difficult to learn - you don't need to be a programmer - and is sooo powerful. It's a REALLY worthwhile investment of your time

    Ned

  14. #14
    paperdiesel Guest
    Quote Originally Posted by wreichert
    Seems the security=share is broken in the 3.0.3 FC2 samba. You shouldn't be prompted for a username / password with this setting. I installed the FC1 3.0.4 & everything works fine. Other option is to use the dev tree for yum, its currently at 3.0.5pre1.

    Wil
    How do I gracefully get and install a newer version of samba? What's the yum command (I've never really used yum)?

    I don't think I should have to create the winxp user accounts on my linux box. The reason being that I have another linux box, sitting right next to it, running fedora core 1, and it has the exact same samba config (names changed), and works perfectly. I never added any winxp users to that box. I'm almost positive that security=share opens the drive to anyone.

    EDIT: Here's the LogWatch entry for samba:

    smbd/service.c:make_connection_snum(619) shea (edited IP addy) connect to service paperarsenal initially as user nobody (uid=99, gid=99) (pid 18556) : 1 Time(s)

    What gives?
    Last edited by paperdiesel; 16th July 2004 at 06:17 AM.

  15. #15
    wreichert Guest
    yum is a handy commandline tool for keeping your system up to date, its essentially the Debian apt command for rpms. Does lots of stuff but simply try 'yum update' & it'll automatically download & update all the packages on yer system.

    If you just want update samba files snag samba* from:

    http://mirrors.kernel.org/fedora/cor...6/Fedora/RPMS/

    I think the default user for samba connects is 'nobody', not completely certain tho.

    Wil

Page 1 of 2 1 2 LastLast

Similar Threads

  1. F8 connect to Samba share
    By rlclemens in forum Using Fedora
    Replies: 7
    Last Post: 25th August 2008, 08:39 PM
  2. Attempt to connect to Cups server. Server Error
    By richag77 in forum Using Fedora
    Replies: 2
    Last Post: 23rd January 2008, 12:34 PM
  3. Novell Server 5 connect trrough FC6? Server not found(0X8847)
    By vipul_patel in forum Servers & Networking
    Replies: 1
    Last Post: 11th December 2006, 05:14 AM
  4. New Samba server won't connect
    By topcat247 in forum Servers & Networking
    Replies: 2
    Last Post: 9th December 2006, 09:29 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •