Hello,

I'm trying to launch an application on the desktop (tried both GNOME and KDE) that requires su privileges.
I've added a line to sudoers like:

%authusers ALL=NOPASSWD:/usr/sbin/myapp

Since I don't want to give them the root pwd (what silly idea that is, always amazes me - Ubuntu guys got it right there!)

If I run the sudo myapp from a terminal within X, all is good. The problem is when I need to create a launcher (btw, only KDE gives me the option, but once set in KDE, GNOME will use it!).
If the command line for the launcher is 'sudo /usr/sbin/myapp' (without the run in a terminal option) then nothing happens.
If I use something like kdesu or gksu, then I'm asked for the root password (in spite of the entry in sudoers... both are very crude).
If I try to give some parameter to the terminal (something like vtsize 1x1) then I'm asked for a password.

At this point you guess what I need. A launcher that uses the information from sudoers without displaying an ugly terminal. Just the graphical app, running as root.

If you have any idea how to achieve this, I'll be grateful.

Pablo

Sometimes Linux is great, but some simple tasks can be so frustrating!!!