<---- template headericclude ----->
Fedora 9 GRUB errors
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 10 of 10
  1. #1
    Tylerious Guest

    Fedora 9 GRUB errors

    I wanted to try out Fedora 9 on my multi-boot box. I didn't want to overwrite Ubuntu's GRUB - I thought I'd just add an entry for Fedora. But I'm getting some problems. First off, my disk layout:

    /dev/hda1 Windows
    /dev/hda2 Shared NTFS
    /dev/hda3 Swap
    /dev/hda4 Extended partition
    /dev/hda5 Ubuntu 7.10
    /dev/hda6 Fedora 9
    /dev/hda7 Ubuntu 8.04

    I overwrote the OS that was in /dev/hda6 with Fedora. Installation went fine.

    I added this to my menu.lst (based off Ubuntu's entry):

    title Fedora 9
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.25-14.fc9.i686 root=UUID=e6672330-aade-4730-b266-f00b8113da3d ro quiet splash
    initrd /boot/initrd-2.6.25-14.fc9.i686.img
    quiet

    However, when it tries to boot from this, it gives me "Error 2: Bad file or directory type"

    Now for the really weird thing! If I go to the GRUB command-line and type "root(hd0,4)/<TAB>" it gives me a list of the folders in Ubuntu's / directory. If I type "root(hd0,5)/<TAB>" it gives me "Error 2: Bad file or directory type"!

    So GRUB cannot read anything in the Fedora partition? It's formatted as ext3; it should work, right?

    Edit: A post I saw elsewhere suggested that it might be a corrupt ext3 partition, but I can mount the Fedora partition from Ubuntu just fine.
    Last edited by Tylerious; 23rd May 2008 at 03:49 PM.

  2. #2
    Join Date
    Jun 2007
    Location
    Washington DC
    Posts
    338
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Can you post the out of the following command as user root in a terminal session:

    blkid

    thanks
    "You're as useless as a jiffy in a tickless kernel."

  3. #3
    Tylerious Guest
    Sure. "sudo blkid" yields.

    /dev/hda1: UUID="7A70CDD870CD9AF1" LABEL="Windows" TYPE="ntfs"
    /dev/hda2: UUID="8E2CC75F2CC74147" LABEL="Share" TYPE="ntfs"
    /dev/hda3: TYPE="swap" LABEL="SWAP-sda3" UUID="706fa272-055e-4249-8e2f-d9d1c9aed59a"
    /dev/hda5: UUID="3ab46163-35a8-46f4-a802-210e87c0277a" SEC_TYPE="ext2" TYPE="ext3" LABEL="Gutsy"
    /dev/hda6: LABEL="Fedora9" UUID="e6672330-aade-4730-b266-f00b8113da3d" SEC_TYPE="ext2" TYPE="ext3"
    /dev/hda7: UUID="2d95244b-720d-440a-b9c5-784b2735424c" SEC_TYPE="ext2" TYPE="ext3" LABEL="HardyFinal"

    I used this command to find the UUID to put in menu.lst. I also tried "/dev/sda6" and "LABEL=Fedora9" instead of "UUID=xxxxxxx" in GRUB, but none worked.

  4. #4
    Join Date
    May 2008
    Posts
    48
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I think you're suffering from the grub 256 bit inode problem. F9's ext3 formatter apparently creates inodes with 256 bits rather than 128. Most versions of grub can't handle this. You can check this by running:

    sudo tune2fs -l /dev/sda6 | grep -i 'inode size'

    grub 0.97-29ubuntu4 is supposed to fix the issue but I haven't been able to get it to work. I tried upgrading to grub2(on Kubuntu 7.10) but that didn't work.

    Are you using Ubuntu 8.04's version of grub?

  5. #5
    Join Date
    Jun 2007
    Location
    Washington DC
    Posts
    338
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    First off that isn't a Fedora problem with how it makes ext3 partitions ... it is an e2fsprog issue that was deals with how GrUB can't handle the new inode size ... the problem is more so with Debian than Fedora as in Fedora it is patched.

    Regardless, the mke2fs small option allows for 128 ... you really shouldn't be making a /boot partition larger than 1024 anyway ... so it would default to 128. If you for some reason need a /boot larger than 1024 then edit /etc/mke2fs.conf and change the default value for inode to 128 from 256 or pass -l to anaconda ... but this is with Fedora (anaconda) all distros should have a mke2fs.conf (but I am sure Ubuntu burries it under some weird wild-turkey named directory (sorry, pot shot I know ;-)
    "You're as useless as a jiffy in a tickless kernel."

  6. #6
    Tylerious Guest
    Well, you're right at the Fedora partition (hda6) has an inode size of 256.

    Not sure what you're recommending I do here, Floyd. I can't make Ubuntu/Debian patch GRUB/e2fsprog. I don't have a separate /boot partition. Sounds like I need to reinstall Fedora unless a patch is issued for Ubuntu. What do I do differently this time?

  7. #7
    Join Date
    May 2008
    Posts
    48
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Tylerious
    Well, you're right at the Fedora partition (hda6) has an inode size of 256.

    Not sure what you're recommending I do here, Floyd. I can't make Ubuntu/Debian patch GRUB/e2fsprog. I don't have a separate /boot partition. Sounds like I need to reinstall Fedora unless a patch is issued for Ubuntu. What do I do differently this time?
    The easiest way is to use Ubuntu to format the Fedora Partition. Then reinstall Fedora without formatting. I don't know if it's possible to select the inode size in F9's installer. The command like switch for e2fsprog is:

    mkfs.ext3 -I 128 /dev/sdaX
    Last edited by Mister B; 24th May 2008 at 07:05 PM.

  8. #8
    Join Date
    Jun 2007
    Location
    Washington DC
    Posts
    338
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well not sure you can when the filesystem is already made, before making:

    # mkfs.ext3 -I 128 /dev/sda1

    or edit the /etc/mke2fs.conf to change default inode, however, this would affect all future partitions.

    I recommend making a /boot partition all of its own, /dev/{h|s}da[1,2,3] and forcing it to be primary, and making it 100MB in Fedora at least the default size for smaller than 1024 is 128 and it will make /boot w/ 128 inode size. Or you can run the command with -I 128


    I would venture to say this is something with the packaged GrUB being used to boot with Ubuntu. Made a 256 /boot with Fedora, and no problem whatsoever.
    Last edited by PhillyFloyd; 24th May 2008 at 07:16 PM.
    "You're as useless as a jiffy in a tickless kernel."

  9. #9
    Tylerious Guest
    Reformatting with an inode size of 128 and reinstalling did the trick! Thanks!

    Now to get my wireless card working without an ethernet connection...

  10. #10
    Join Date
    Jun 2005
    Location
    Italy
    Posts
    1,108
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Mister B
    I think you're suffering from the grub 256 bit inode problem.
    I just wanted to thank you guys, especially Mister B, for this thread - I've been scratching my head for some time now regarding a dual boot Arch Linux/Fedora 9, having the same problem as Tylerious.
    - Captain...
    - Yes, Spock?
    - I can't believe my ears...

Similar Threads

  1. Grub Errors
    By 4z0smq20kk in forum Installation, Upgrades and Live Media
    Replies: 2
    Last Post: 1st August 2008, 03:21 AM
  2. my computer wont boot after i installed fedora C5 GRUB errors.
    By roodi2005 in forum Installation, Upgrades and Live Media
    Replies: 2
    Last Post: 30th October 2006, 06:00 PM
  3. Grub Geom errors on Windows dual-boot: Workaround, plain English
    By felch in forum Installation, Upgrades and Live Media
    Replies: 0
    Last Post: 8th August 2006, 04:02 PM
  4. grub error 15 and other boot errors
    By cricha5 in forum Installation, Upgrades and Live Media
    Replies: 0
    Last Post: 21st March 2006, 05:56 PM
  5. Errors during installation and after GRUB failure
    By spz in forum Installation, Upgrades and Live Media
    Replies: 5
    Last Post: 2nd September 2005, 05:37 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
[[template footer(Guest)]]