Error installing latest Symphony beta / Symphony 1 released
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 7 of 7
  1. #1
    Wayne Guest

    Error installing latest Symphony beta / Symphony 1 released

    As I still have a few Wordpro for OS/2 documents to convert I downloaded the latest IBM/Lotus Symphony beta 4 (Twice!) It fails to install with:

    Code:
    [root@Beerislife Download]# ./IBM_Lotus_Symphony_linux.bin
    
       IBM Lotus Symphony Beta - starting installation... please wait
    
    mktemp: too few X's in template `/tmp/symphony.tmp6542'
    tar: option requires an argument -- C
    Try `tar --help' or `tar --usage' for more information.
    ./IBM_Lotus_Symphony_linux.bin: line 23: ./setup.bin: No such file or directory
    This is not the (in)famous SELinux/Java problem, SELinux is disabled here.

    Any clues before I search my old CDs/DVDs to see if I have an older version...?

    Wayne

  2. #2
    Wayne Guest
    Once again, Google comes to the rescue.... and the answer is.......:

    #sed -i s/" \/tmp\/symphony.tmp\$RANDOM"/""/ IBM_Lotus_Symphony_linux.bin

    The answer was actually on the Symphony support forum.... Now I know where to look in future..... until I forget

    http://symphony.lotus.com/software/l...=6169&tstart=0

    Wayne
    Last edited by Wayne; 3rd June 2008 at 06:53 AM.

  3. #3
    Wayne Guest
    If you try Symphony beta 4 and get an error box on start-up along the lines of:

    "Could not initialise the application's security component.... blah, blah, blah"

    It's a bug in Eclipse and the answer is to:

    mkdir ~/.mozilla/eclipse

    Edit: for those unsure how to install Symphony, download the 'bin' file, open a Terminal, su to root and navigate to where the downloaded file is located and then type:

    # ./IBM_Lotus_Symphony_linux.bin

    Wayne
    Last edited by Wayne; 23rd May 2008 at 01:30 AM.

  4. #4
    Wayne Guest
    I've renamed the title of this thread slightly to reflect the fact that Symphony 1 has been released by IBM.... Grab it while it's hot! Downloads are a tad slow though. Available in several languages.

    http://symphony.lotus.com/software/l...hony/home.jspa

    It's free but you have to register.

    Edit: The fixes above still apply

    Wayne
    Last edited by Wayne; 3rd June 2008 at 01:19 AM.

  5. #5
    Wayne Guest
    Forget it, this is typical IBM second-rate rubbish. Firstly, the fix above doesn't work on Release 1, so you have to edit the bin file with vi to change the 'tmp' directory. When you've done that, the install proceeds normally.... until it goes to install. My /opt size is 2Gb with over 1Gb free, the installer says it needs 523Mb of free space, but then goes on to report that it needs 1Gb... then bombs..... Better to stick with OpenOffice.

    Edit: OK. I finally installed it in /usr/local/ibm

    It's obviously a tad faster than the betas but on my ancient hardware is no speed demon... If you like mucking about with vi, give it a shot

    I'll probably uninstall it, then remove something from /opt (Google Earth) and try and install it there, then reinstall Google Earth...

    Wayne
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Screenshot-Installation wizard for IBM Lotus Symphony-1.png 
Views:	309 
Size:	51.2 KB 
ID:	16269   Click image for larger version. 

Name:	Screenshot.png 
Views:	325 
Size:	374.0 KB 
ID:	16270  
    Last edited by Wayne; 3rd June 2008 at 02:56 AM.

  6. #6
    Wayne Guest
    Since posting here and reporting on the support forum, I've been told that the tmp directory bug has been fixed to:

    mktemp -df /tmp/

    That probably means I won't need to remove anything from /opt and it should install just fine with no changes if you download a fresh copy.

    Someone else has reported that the Web Browser part hangs in Fedora 9, which also happens here. As they officially do not support Fedora, don't hold your breath for a fix...

    http://www.fedoraforum.org/gallery/s...cutoffdate=all

    Wayne
    Last edited by Wayne; 3rd June 2008 at 06:53 AM.

  7. #7
    Wayne Guest
    The reason why the browser part of Symphony hangs is that it relies on xulrunner from the Firefox 1.5.x series, so you have to install Firefox 1.5.x for it to work. They support RH 5 which ships with FF 1. Once again, IBM drop the ball! No one uses that ancient browser any more! Or shouldn't be!

    Wayne

Similar Threads

  1. Anybody play with IBM's Lotus Symphony?
    By Silpheed2K in forum Fedora Focus
    Replies: 10
    Last Post: 9th June 2009, 11:07 AM
  2. Lotus Symphony 1.2 in Fedora 10 86x64
    By srgazh in forum Installation, Upgrades and Live Media
    Replies: 5
    Last Post: 14th January 2009, 02:10 PM
  3. IBM Symphony?
    By tho.mei in forum Using Fedora
    Replies: 7
    Last Post: 15th October 2007, 10:25 AM
  4. Lotus Symphony -- SELinux preventing install?
    By Murrquan in forum Using Fedora
    Replies: 5
    Last Post: 14th October 2007, 12:59 AM
  5. Silent Symphony
    By geminiguy in forum Linux Chat
    Replies: 6
    Last Post: 6th August 2007, 02:22 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •