FedoraForum.org - Fedora Support Forums and Community
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 25
  1. #1
    Join Date
    Dec 2007
    Posts
    32

    How do I enable 'tap to click' on mousepad?

    Hi, I understand that the new default behaviour of the synaptic driver is to disable tap to click by defualt (Boo!). I learnt from here that all you have to do is add
    Code:
           Option "TapButton1" "1"
           Option "TapButton2" "2"
    to xorg.conf to get the tap to click working.

    My xorg.conf file does not have any touchpad input devices. How do I add those two lines.

    This is my xorg.conf

    # Xorg configuration created by pyxf86config
    Code:
    Section "ServerLayout"
    	Identifier     "Default Layout"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "InputDevice"
    # keyboard added by rhpxl
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "us"
    EndSection
    
    Section "Device"
    	Identifier  "Videocard0"
    	Driver      "intel"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Videocard0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection

  2. #2
    Join Date
    May 2008
    Posts
    34
    This is how it should look like:
    PHP Code:
    Section "ServerLayout"
        
    Identifier     "Default Layout"
        
    Screen      0  "Screen0" 0 0
        InputDevice    
    "Keyboard0" "CoreKeyboard"
            
    InputDevice    "TouchPad" "CorePointer"
    EndSection

    #Another section for Touchpad
    Section "InputDevice"

        
    Identifier  "Touchpad"
        
    Driver      "synaptics"
           
    Option      "SendCoreEvents"
           
    Option      "Protocol" "auto-dev"
           
    Option      "TapButton1" "1"
           
    Option      "TapButton2" "2"
           
    Option      "TapButton3" "3"
           
    Option      "SHMConfig" "on"
    EndSection 

    Also take a look at this for more details:
    http://gentoo-wiki.com/HARDWARE_Synaptics_Touchpad

    Cheers, D
    Last edited by dejan.kitic; 15th May 2008 at 07:40 PM. Reason: Correct driver name is synaptics...Damn typos

  3. #3
    Join Date
    May 2006
    Posts
    2
    The driver is synaptics and not synaptic.

    Code:
    Driver "synpatics"

  4. #4
    Join Date
    Dec 2007
    Posts
    32

    Talking

    Thanks both of you! I copied dejan.kitic's post and changed it to synaptics... mousepad now works great! This is what my xorg.conf file looks like now:

    Code:
    # Xorg configuration created by pyxf86config
    
    Section "ServerLayout"
    	Identifier     "Default Layout"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Keyboard0" "CoreKeyboard"
            InputDevice    "TouchPad" "CorePointer" 
    EndSection
    
    Section "InputDevice"
    # keyboard added by rhpxl
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "us"
    EndSection
    
    #Another section for Touchpad
    Section "InputDevice"
    
        Identifier  "Touchpad"
        Driver      "synaptics"
           Option      "SendCoreEvents"
           Option      "Protocol" "auto-dev"
           Option "TapButton1" "1"
           Option "TapButton2" "2"
           Option "TapButton3" "3"
           Option      "SHMConfig" "on"
    EndSection 
    
    Section "Device"
    	Identifier  "Videocard0"
    	Driver      "intel"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Videocard0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection

  5. #5
    Join Date
    Oct 2005
    Location
    Germany
    Age
    33
    Posts
    38
    Is there a way of setting these values without using the xorg.conf file?

  6. #6
    Join Date
    Dec 2007
    Posts
    32
    MrGroover, The only way I found for enabling tap to click without editing grub was adding a line to my grub menu file. Unfortunately it wasn't as good as editing xorg.conf because scrolling on the touchpad didnt' work.

    You have to edit /boot/grub/menu.lst and add 'psmouse.proto=imps' to the line that begins with kernel. You can see this post. Again, the xorg.conf way worked better for me.

  7. #7
    Join Date
    Mar 2005
    Location
    Warrenville, IL (Chicago)
    Age
    39
    Posts
    117
    editing xorg.conf enabled tapping when X first starts, but if it goes to suspend, tapping doesn't work until X is restarted.

  8. #8
    Join Date
    Dec 2007
    Posts
    32
    tscheez, I've noticed that too. anyone know of a fix?

  9. #9
    Join Date
    May 2008
    Posts
    34
    Quote Originally Posted by jojohippo
    tscheez, I've noticed that too. anyone know of a fix?
    Thanks to Bob Kashani, there is solution:
    Install package from here, and touchpad will work just peachy.

    http://www.ocf.berkeley.edu/~bobk/packages/

    This resolves both tapping and suspend/resume problem, taken from
    https://bugzilla.redhat.com/show_bug.cgi?id=439386

    Cheers D

  10. #10
    Join Date
    Dec 2007
    Posts
    32
    Thansk dejan.kitic, touchpad works just peachy =)

  11. #11
    Join Date
    Oct 2005
    Location
    Germany
    Age
    33
    Posts
    38
    Quote Originally Posted by jojohippo
    You have to edit /boot/grub/menu.lst and add 'psmouse.proto=imps' to the line that begins with kernel.
    As long as the i810 driver isn't working in X, I don't want to use a xorg.conf file, because for me, it works better without that file. But I have an idea how to work out the problem, no xorg.conf file present and the still having the ability to configure the synaptics touchpad. There is a tool called synclient (its in the repos) and with this tool, one can adjust the parameters of the Synaptics without editing the xorg.conf file and without restarting X. My idea is to write a basic script that is called when X starts and this script will set the parameters for the touchpad as I want to have them.
    I'll just have to find out, how to tell xorg that a synaptics touchpad is present and not a generic ps2 mouse or something. I haven't look what X detects without the config file... Maybe your hint with the parameter in the menu.lst file is a good starting point...

  12. #12
    Join Date
    May 2008
    Location
    United Kingdom
    Posts
    90
    [QUOTE]Thanks to Bob Kashani, there is solution:
    Install package from here, and touchpad will work just peachy.

    After weeks of trying to get the touchpad working, you link to the driver solved it. Thank you very much.

    Bob

  13. #13
    Join Date
    May 2007
    Posts
    23
    How would I go about installing this new driver if I have a previous one already installed? Do I need to disable the old one first? Can I just rpm -e it?

    I tried using rpm -ivh synaptics-0.14.6-8.1.fc9.i386.rpm, but its getting conflicts from the 0.14.6-7.fc9.i386 version. I also installed gsynaptics for a gui, which I'm not sure if it needs to be removed as well.

  14. #14
    Join Date
    Jun 2006
    Location
    Germany
    Age
    29
    Posts
    57
    Have you tried "rpm -Uvh" ? If this also does not work you could force rpm with the "--force" option

  15. #15
    Join Date
    May 2007
    Posts
    23
    rpm -Uvh did it for me. Thanks!!!

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Needing left-click to open files upon single-click
    By theAdmiral in forum Hardware & Laptops
    Replies: 6
    Last Post: 30th October 2009, 03:55 AM
  2. Click "Enable Desktop Effects" = log out
    By tdcrooks in forum Using Fedora
    Replies: 6
    Last Post: 14th September 2009, 06:19 AM
  3. Mousepad, tap doesn't work
    By billgoldberg in forum Using Fedora
    Replies: 2
    Last Post: 11th June 2009, 04:00 PM
  4. Mousepad click
    By zlx in forum Using Fedora
    Replies: 2
    Last Post: 30th June 2008, 03:43 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •