FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    Join Date
    Oct 2006
    Worcestershire, UK

    F9's MonoDevelop RC1 in F8?

    I've installed the RPMs for Mono and MonoDevelop from the F9 repos to try to get some of the improvements in MonoDevelop (since F8 is still on Beta 2 built for F7). I've done it before to get slightly newer versions of Mono, but at the moment MonoDevelop doesn't want to recognise any addins.

    The app starts and you can edit files, but when it first starts then there is an error message of "the following addins couldn't be started". Each one has a blank line and is caused by a null argument exception.

    [ibboard@AnkhMorpork .config]$ rpm -qa|grep mono
    Console output from startup is attached.

    Is this a known issue (at which point why is it in the repos, even if it is Alpha?) or is this something odd with running it on F8? I've tried with a clean .config/MonoDevelop folder and it doesn't seem to make a difference.

    Attached Files Attached Files

  2. #2
    Join Date
    Oct 2006
    Worcestershire, UK
    I've still not been able to find a solution to this. For now I've had to resort to using a 1.0 noarch build from the openSuse build service, which seems to work properly. It means I've dropped back to Mono 1.2.x from F8 rather than the 1.9 build from F9, but older and working is better than not working and newer.

    It's strange that there's not even anything in Google for "monodevelop ArgumentNullException typeName" other than source code.

  3. #3
    Join Date
    Jun 2005

    Upgrading to Mono 1.9 and MonoDevelop 1.0 on F8

    Thanks for the tip about the openSuse build service.

    I was able to find repo files for the various pieces. I had to use the community, mono and rhel repos and remove the release and update (Fedora) channels, AND remove all the old mono/sharp stuff first. Then it went just fine.

    Attached is Smart Package Manager channel file. Replace disabled=yes to enabled=1 and they should work as .repo files. Those are, in any case, available at the openSuse site: http://download.opensuse.org/repositories/


    ps- well the zeroconf stuff didn;t install because of a dependency on avahi-0.7.5, Perhaps that will sort itself out in the future....
    Attached Files Attached Files
    Last edited by rshendershot; 16th March 2008 at 09:25 PM.

  4. #4
    Join Date
    Oct 2006
    Worcestershire, UK
    I've managed to stick with most of the Fedora Mono builds (latest version in Updates, I think) it was just MonoDevelop that I needed the OpenSuse version for so that I wasn't stuck with either a broken 0.19 from Rawhide or a rather behind 0.13 from F8.

  5. #5
    Join Date
    Oct 2005
    Yeah, openSuse build service is great. I always use the prebuilt Mono version from them, and then compile from source for MonoDevelop.
    More bleeding-edge, more bugs to file. They have a very active bugzilla. I did file some bugs on their bugzilla, all of them have been fixed very quick
    Linux User number : 451678
    AMD X2 3800+, ASUS M2NPV-VM, GeForce 6150 128MB (onboard), 2GB RAM Corsairs 667, ASUS VW192T LCD 19" Widescreen.
    Ubuntu 8.04 (Hardy Heron) x86
    HP Pavilion DV 5000
    Fedora 10 (Cambridge) x86
    Linux Machine Number: 359564

  6. #6
    Join Date
    Oct 2006
    Worcestershire, UK
    I still seem to be having the same problems, only now I'm running F9 instead of trying to run an F9 built app in F8. This thread implies it is nothing to worry about, but the fix requires the Rawhide RPM (there's a 0.3.1 in development) and that requires upgrading swathes of other things like gtk-sharp.

    Is there any other workable solution, as I'm not entirely sure whether all of the addins are actually working properly, and it's terrible software that throws a warning every time you start it up.

Similar Threads

  1. MonoDevelop
    By ShivaS in forum Alpha - Beta (Fedora 9 Only)
    Replies: 4
    Last Post: 15th June 2008, 01:44 PM
  2. MonoDevelop
    By HayZam in forum Using Fedora
    Replies: 2
    Last Post: 19th September 2007, 06:38 PM
  3. Monodevelop
    By jjesurun in forum Using Fedora
    Replies: 4
    Last Post: 4th September 2007, 08:40 PM
  4. help monodevelop
    By ronin1982 in forum Programming & Packaging
    Replies: 16
    Last Post: 29th November 2006, 04:44 PM
  5. Monodevelop
    By rcassick in forum Using Fedora
    Replies: 7
    Last Post: 29th July 2006, 10:57 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts