Shogo Demo
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 3 1 2 3 LastLast
Results 1 to 15 of 31
  1. #1
    Join Date
    Sep 2007
    Location
    Seba Beach, Alberta Canada
    Age
    26
    Posts
    482
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Shogo Demo

    I am trying to Install the Shogo: Mobile Armor Division demo on my computer, but I am having some troubles running the installer:

    [Hamish@localhost ~]$ sh ShogoDemo.run
    Creating directory ShogoDemo
    Verifying archive integrity...tail: cannot open `+6' for reading: No such file or directory
    Error in check sums 826083859 3765184320
    [Hamish@localhost ~]$

    Any Suggestions?
    Thank you,
    Hamish Paul Wilson

  2. #2
    Join Date
    Sep 2007
    Location
    Seba Beach, Alberta Canada
    Age
    26
    Posts
    482
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Opps, would a Mod please move to the Game Forums
    Thank you,
    Hamish Paul Wilson

  3. #3
    Join Date
    Jul 2004
    Location
    Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
    Age
    75
    Posts
    24,162
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Got it moved.
    Linux & Beer - That TOTALLY Computes!
    Registered Linux User #362651


    Don't use any of my solutions on working computers or near small children.

  4. #4
    Join Date
    Sep 2006
    Location
    Connellsville, PA, USA
    Posts
    11,308
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hello:

    Had the very same problem installing the (very old) loki games demos: the installer binaries were apparently created using an older version of the program that generates such installers. Took quite a while before I stumbled on the solution.

    Anyway, here's the secret cryptic techno-mystical Linux formula that allowed the binary installers to run (I installed as root user; do this immediately before running the installer, inside the folder where it's located):
    Code:
    [root@presario Fri Feb 22 15:08:53 ~]# export _POSIX2_VERSION=199209
    Then try the installer again. When done, don't forget to unset this environment variable:
    Code:
    [root@presario Fri Feb 22 15:08:53 ~]# unset _POSIX2_VERSION
    Regards,
    V

  5. #5
    Join Date
    Sep 2007
    Location
    Seba Beach, Alberta Canada
    Age
    26
    Posts
    482
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    That seemed to work, thanks.
    Thank you,
    Hamish Paul Wilson

  6. #6
    Join Date
    May 2004
    Location
    Mexico City, Mexico
    Age
    43
    Posts
    4,428
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Piga, were you able to run the game? I've been craving to play it once again, alas I cannot! I bought the Linux version some years ago, just out of sheer emotion that they actually ported it.
    If ain't broken, don't fix it! :eek:
    If can be improved, go for it! :cool:

    FedoraForum Community forums lurker.
    Fedora user since RHL 5.2 :cool:

  7. #7
    Join Date
    Sep 2007
    Location
    Seba Beach, Alberta Canada
    Age
    26
    Posts
    482
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Thetargos
    Piga, were you able to run the game? I've been craving to play it once again, alas I cannot! I bought the Linux version some years ago, just out of sheer emotion that they actually ported it.
    It runs, but it seems to display funny. The world is very dark. I have not tried to fix it yet though.

    To be Honest, I got the Shogo demo to test a theory about Blood 2 more than for Shogo itself.

    Any Suggestions about my Display Problem?
    Thank you,
    Hamish Paul Wilson

  8. #8
    Join Date
    Sep 2006
    Location
    Connellsville, PA, USA
    Posts
    11,308
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hello piga:

    Try starting Shogo from the command line, so that you can see what errors (if any) are being thrown out. Are there no in-game settings/adjustments for video/graphics?

    Regards,
    V

  9. #9
    Join Date
    Sep 2007
    Location
    Seba Beach, Alberta Canada
    Age
    26
    Posts
    482
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I brightened the game up a bit using the Shogo FAQ http://www.shogo-mad.com/faq/shogo.htm

    The graphics still have display problems, they look very pixelated. I managed to win the Demo though. I would also still prefer it a little brighter.
    Thank you,
    Hamish Paul Wilson

  10. #10
    Join Date
    Sep 2007
    Location
    Seba Beach, Alberta Canada
    Age
    26
    Posts
    482
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Fixed! Changed CPU only Software Render to OpenGL Hardware Accelerated Render. Everything works! I might just consider trying to get the full version.
    Thank you,
    Hamish Paul Wilson

  11. #11
    Join Date
    Sep 2006
    Location
    Connellsville, PA, USA
    Posts
    11,308
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by piga
    Fixed! Changed CPU only Software Render to OpenGL Hardware Accelerated Render. Everything works! I might just consider trying to get the full version.
    That's good to know: probably many older OpenGL apps (like the loki demos) behave better with this setting. Where is this setting?

    Thanx and Regards,
    V

  12. #12
    Join Date
    Sep 2007
    Location
    Seba Beach, Alberta Canada
    Age
    26
    Posts
    482
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I found it in the Shogo Launcher, display tab, Renderer and Resolution box.
    Thank you,
    Hamish Paul Wilson

  13. #13
    Join Date
    Sep 2007
    Location
    Seba Beach, Alberta Canada
    Age
    26
    Posts
    482
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Here is a screenshot of Shogo working if anyone is interested: http://img223.imageshack.us/my.php?image=shogoee5.png
    Thank you,
    Hamish Paul Wilson

  14. #14
    Join Date
    Sep 2007
    Location
    Seba Beach, Alberta Canada
    Age
    26
    Posts
    482
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I installed a new video card and Shogo runs faster, but displays darker (Just like the rest of the system). Can I adjust my video card/display settings to make it brighter?
    Thank you,
    Hamish Paul Wilson

  15. #15
    Join Date
    Sep 2006
    Location
    Connellsville, PA, USA
    Posts
    11,308
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hello piga:

    Other than in-game graphics settings (if any) and your monitor's built-in display adjustments (if any), you could look into your desktop settings - for me, that's KDE=>right-click on desktop=>Configure Desktop=>Display=>Monitor Gamma. Don't know where that would be in GNOME (System=>Preferences=>???). I don't know of any way to adjust video card brightness/contrast settings in, for example, /etc/X11/xorg.conf.

    Regards,
    V

Page 1 of 3 1 2 3 LastLast

Similar Threads

  1. xscreensaver-demo
    By rik_cross in forum Using Fedora
    Replies: 0
    Last Post: 11th October 2006, 07:29 PM
  2. Cold War demo -
    By Melio in forum Gamers' Lounge
    Replies: 0
    Last Post: 28th July 2006, 01:33 PM
  3. Darwinia Demo.
    By Thetargos in forum Gamers' Lounge
    Replies: 4
    Last Post: 8th July 2006, 07:34 PM
  4. XGL Demo CD
    By SoftPedia in forum Linux Chat
    Replies: 6
    Last Post: 23rd March 2006, 09:05 PM
  5. Quake 4 Demo
    By Druid in forum Using Fedora
    Replies: 15
    Last Post: 2nd January 2006, 01:49 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •