Apps cannot access working ALSA/PulseAudio devices on F8
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 8 of 8
  1. #1
    Join Date
    Nov 2007
    Posts
    17
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Apps cannot access working ALSA/PulseAudio devices on F8

    Hello Forum,

    I wasn't sure where to post this - the hardware is working but applications cannot access it, so I chose Software. Here's the issue:

    I have F8 (fully updated) on my Dell D620. I use Twinkle softphone with my Plantronics USB audio device + headset. After I came to understand PulseAudio at a reasonable level, I got it all working.

    Something has happened in the last day or two where now my applications (Twinkle in this case) cannot access the USB Audio device. Some other info:

    - the devices both show up in system-config-soundcard and both correctly play the test sound.
    - when I tap on the mic, I can hear it in the headset.
    - PA volume meter shows the mic is working.

    However, when Twinkle starts up, it tells me it cannot access the speaker or the mic. I'm new to PA and ALSA so I'm not sure where to go to even diagnose this. I've killed and restarted PA daemon and also rebooted the machine. Apart from the Fedora updates, nothing has changed software wise.

    Hope someone can steer me toward diagnosis and resolution and I can use my softphone again. BTW, Pulse is damn cool and I hope it isn't to blame for this little snafu

    Cheers & TIA,

    Chris

  2. #2
    sargek Guest
    I would just be happy to get Pulse Audio working at all. It does absolutely nothing and the volume control is unusable. I have been forced to completely disable Pulse and go back to Alsa, which in my opinion is not a step back. Did you have Pulse Audio working out of the box?

  3. #3
    Join Date
    Aug 2007
    Location
    Liverpool, UK
    Posts
    729
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I had similar problems in this thread and others have had problems since a pulseaudio yum update.

    The solution for me was to ensure that Console-Kit and avahi-daemon is enabled on startup. See also: http://fedoraguide.info/index.php/Fedora8

    HTH

  4. #4
    sargek Guest
    This may seem silly, but I refuse to enable avahi-daemon for a sound server. avahi-daemon is a mDNS/DNS-SD daemon which deals with IP addresses. For the life of me, I cannot see how this has anything to do with sound. Not trying to bash Pulse Audio, but Alsa does the job quite well and unless someone can convince me a sound server needs network resources, I'm sticking with Alsa. The reason I was interested in getting Pulse Audio working is because it's broken on my system and that drives me nuts!

  5. #5
    Join Date
    Aug 2007
    Location
    Liverpool, UK
    Posts
    729
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I don't think that seems silly at all (indeed I had avahi-daemon disabled for the same reasons!). I do not really understand why f8 made the step "up" to pulseaudio when alsa worked fine alone in f7. Pulseaudio seems to be the answer to a question that nobody was asking.

  6. #6
    Join Date
    Oct 2007
    Location
    Freedonia
    Age
    72
    Posts
    3,076
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    My sound works OK, except for the system sounds. I can't get it to use logon/logout sounds. And, if I tell it to use any file except the default ones, the application stops playing sounds until I restart it. When I had FC a6, sound Just Worked, now, it Just Doesn't Work. I'm beginning to think that Pulse Audio is the problem, not the answer. Who needs a sound server for a standalone machine, anyway? Does anybody know what happens if you try removing all of Pulse Audio?

  7. #7
    Join Date
    Nov 2007
    Posts
    17
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    My stuff is now working, so here's the update:

    I'm afraid I don't have a concrete fix to give to the community, but some combination of the below did the trick. I don't recall in what order i did these things, but I did them all and my stuff now works.

    - Check gstreamer-properties and discovered that the default output device was "custom". Returned this to PulseAudio.

    - Restore the audio config files using system-config-souncard (System > [Restore configuration files]). After doing this I had to again un-mute my mic and set it as the default input. Mics are apparently muted by default (makes sense).

    - rm ~/.pulse/volume-restore.table

    In doing all this, I discovered that what was happening was that Twinkle's ring (incoming) was conflicting with the audio of my newly-answered call. This is why I could make a call but could not receive one. I think what really fixed this was the removal of pulse config in my home directory (last bullet above).

    Another word about PulseAudio: I loaded F8 from the LiveImage and it installed PA but none of the PA utilities. Make sure to visit http://pulseaudio.org/wiki/AboutPulseAudio#Features and install all the *Related Software*. This makes PA from something of an anomaly into something you can use/tweak.

    Thanks to all who responded.

    -Chris

  8. #8
    Join Date
    Oct 2007
    Location
    Freedonia
    Age
    72
    Posts
    3,076
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Tried everything relevant to my issue, but no change. Not only that, some sounds play, others don't, including logon/logout, even if I don't mess with them. This is one reason I marked that poll about FC 6/8 that 6 was better: sound Just Worked before Pulesaudio was included.

Similar Threads

  1. PulseAudio vs ALSA
    By callejero in forum Using Fedora
    Replies: 1
    Last Post: 16th December 2008, 10:51 PM
  2. Pulseaudio, alsa, oss
    By kikker46 in forum Using Fedora
    Replies: 21
    Last Post: 4th August 2008, 12:06 PM
  3. OSS, ALSA, PulseAudio and other confusion
    By 1inxs in forum Installation, Upgrades and Live Media
    Replies: 6
    Last Post: 17th March 2008, 08:40 PM
  4. ALSA/pulseaudio Problem
    By Webgeek in forum Using Fedora
    Replies: 7
    Last Post: 5th February 2008, 09:28 PM
  5. Replies: 0
    Last Post: 4th February 2008, 04:02 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •