Errors in ¨Resolving Dependencies for Updates¨ while trying to ¨Apply Updates¨
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 3 1 2 3 LastLast
Results 1 to 15 of 45
  1. #1
    MACSimaKRECie Guest

    Smile [Solved] Errors- ¨Resolving Dependencies for Updates¨ while trying to ¨Apply Updates¨

    Recently i got Fedora8 installed on my hpCompaq PC
    I am trying to apply updates thru the Package Updater
    and have been getting error messages every time.
    For example, one is w.r.t. rsyslog package
    Now, this time, a de-selected it from the list,
    and still i am not able to complete the work -
    in fact the system has not yet come out of its
    ¨Resolving Dependencies for Updates¨ mode
    even after an overnightś time!
    Of course the indicator has reached 100% quite a while ago (a few hours ago)
    This is the third time that i am trying it!
    Maybe there is a better way of doing all this, if some one can be kind enough to inform me. . .
    Also, i wonder how i can install the new version of Firefox on my Fedora8 OS.
    The one that is available with the installation of Fedora8 is an earlier version i guess.
    Thanks a lot.
    Last edited by MACSimaKRECie; 25th December 2007 at 01:51 PM. Reason: Problem solved, Thanks to FedoraForum

  2. #2
    Wayne Guest
    List the repos you have enabled

    Wayne

  3. #3
    Demz Guest
    have you tried updating through command line? by going into Aplications > System tools > Terminal an logging in as root an updating that way
    Code:
    yum -y update pirut 
    yum -y update yum
    Last edited by Demz; 22nd December 2007 at 08:46 AM.

  4. #4
    MACSimaKRECie Guest
    Quote Originally Posted by Wayne
    List the repos you have enabled

    Wayne
    i am fairly(why, in fact quite) a newbie i guess, just managed to install fedora8 on my own after a lot of struggle (although i should say that i enjoyed going thru that struggle). so i tried just now to go to gnome help and typed REPOSITORIES in the search-line and hit the return-key when i got an error message that the application crashed, and that i can report the bug thru the bug-reporting tool, which i just completed now.
    So, i am not sure how i get the info on which REPOSITORIES are enabled at this point in time,
    maybe you can help me do it . . .
    Thanks a lot.

  5. #5
    Wayne Guest
    Do what Greg suggested and try doing it from a Terminal (command line) and post the output of:

    #yum update

    If you don't know how, open the Terminal and type:

    su

    give the root password and type:

    yum update

    Wayne

  6. #6
    MACSimaKRECie Guest

    As Wayne suggested, i followed Greg´s suggestions - and get the following

    As Wayne suggested, i followed Greg´s suggestions, that is to use the command
    #yum -y update
    in the terminal mode
    and got quite a bit of OK-output, and and the end some error messages as quoted here below:
    devel
    ---> Package rasqal.i386 0:0.9.14-2.fc8 set to be updated
    ---> Package liferea.i386 0:1.4.10-1.fc9 set to be updated
    --> Processing Dependency: gecko-libs = 1.8.1.10 for package: liferea
    --> Processing Conflict: rsyslog conflicts syslog-ng
    --> Finished Dependency Resolution
    Error: Missing Dependency: gecko-libs = 1.8.1.10 is needed by package liferea
    Error: Missing Dependency: firefox = 2.0.0.10-3.fc8 is needed by package firefox-devel
    Error: Missing Dependency: libldap-2.3.so.0 is needed by package kdebase
    Error: rsyslog conflicts with syslog-ng
    #
    What do i do now?

  7. #7
    Wayne Guest
    You've enabled the Fedora development repo! (see where it says "fc9") The development repo contains what is at the moment the beta stuff of the next version of Fedora which is due out in April! Better disable it.

    Edit: Open 'Add/Remove Software' and go to 'Edit > Repositories' and uncheck it. You should only have the main 'Fedora' and 'Updates' enabled and any third-party repositories you've added (Adobe, Livna)

    Also, if you add third-party repos, do not have Livna and others enabled (Freshrpms, Dries) at the same time, that can also cause problems.

    Wayne
    Last edited by Wayne; 22nd December 2007 at 09:15 AM.

  8. #8
    Join Date
    May 2007
    Location
    U.S.
    Posts
    4,851
    You could try forcing yum to do a bit of cleanup, maybe the metadata got FUBARed.

    # yum clean all
    # yum -y update yum
    # yum -y update

    If that doesn't work, I'd try updating rsyslog and syslog-ng independently, then trying a full update.
    # yum update syslog-ng
    # yum update rsyslog
    # yum update

    But I'm not sure that will help.

    Now, to see what repositories you have enabled:
    Code:
    # yum repolist
    - Tom
    "What is freedom? To have the will to be responsible for one's self." - Stirner

  9. #9
    Wayne Guest
    Unfortunately, new users get the idea that they should enable all and sundry repos, which can lead to 'bad things' (tm) happening. I wish they'd hide all those extra repos (updates-testing, development) or maybe or have them shown by having different user levels (newbie, intermediate, advanced)

    hope we caught the OP before damage was done.

    Wayne

  10. #10
    MACSimaKRECie Guest
    Oh Yes(!) So, probably at the time of installing Fedora8 i might have ticked(clicked) for getting all those Updates under the so called software-package-customization window (i remember i chose many many of then, maybe blindly)
    Now, how do i get to know about them, and how do i undo some of them - like this one about Fedora9 ?

  11. #11
    Wayne Guest
    Quote Originally Posted by MACSimaKRECie
    Oh Yes(!) So, probably at the time of installing Fedora8 i might have ticked(clicked) for getting all those Updates under the so called software-package-customization window (i remember i chose many many of then, maybe blindly)
    Now, how do i get to know about them, and how do i undo some of them - like this one about Fedora9 ?
    See my edited post above, I gave the GUI instructions.

    Wayne

  12. #12
    MACSimaKRECie Guest
    Here is the output of that command
    # yum repolist
    repo id repo name status
    InstallMedia Fedora 8 enabled
    adobe-linux-i386 Adobe Systems Incorporated enabled
    development Fedora - Development enabled
    development-debuginf Fedora - Development - Debug enabled
    development-source Fedora - Development - Source enabled
    fedora Fedora 8 - i386 enabled
    fedora-debuginfo Fedora 8 - i386 - Debug enabled
    fedora-source Fedora 8 - Source enabled
    updates Fedora 8 - i386 - Updates enabled
    updates-debuginfo Fedora 8 - i386 - Updates - Debug enabled
    updates-source Fedora 8 - Updates Source enabled
    updates-testing Fedora 8 - i386 - Test Updates enabled
    updates-testing-debu Fedora 8 - i386 - Test Updates Debug enabled
    updates-testing-sour Fedora 8 - Test Updates Source enabled
    #

  13. #13
    Wayne Guest
    Will the yum-allowdowngrade plugin help the OP if he's installed fc9 packages? I'm afraid I have to go out and do an evening job, so I'll leave it to Greg or Tom to help.

    Wayne

  14. #14
    Demz Guest
    do this as Wayne said above

    Open ADD/Remove and then click on EDIT > Repositeries > an disable the ones you shouldnt be using there

  15. #15
    MACSimaKRECie Guest
    The output of #yum repolist command does not have Fedora9 in it though! That is interesting in itself!
    Also the Edit Repositories feature when invoked does not show any Fedora9 anyway,
    so i think that there is nothing to unckeck/deselect therein.
    I am right now trying to follow the sequence of commands suggested by tjVanWyk(Tom)
    As soon as it is done i wil copy-paste the output here

Page 1 of 3 1 2 3 LastLast

Similar Threads

  1. Replies: 1
    Last Post: 15th March 2009, 03:46 PM
  2. Replies: 2
    Last Post: 24th January 2009, 04:02 AM
  3. Replies: 0
    Last Post: 20th October 2008, 12:44 AM
  4. Replies: 10
    Last Post: 15th July 2007, 03:54 PM
  5. Replies: 4
    Last Post: 6th February 2007, 05:18 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •