Umm... My Super Key Just Stopped Working...
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 14 of 14
  1. #1
    Join Date
    Nov 2007
    Posts
    198
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Umm... My Super Key Just Stopped Working...

    Yeah, so my super key just stopped working. You know, the one with the blasphemous windows logo on it? Or at least I'm positive that it just stopped working.

    Before, I was able to use it to use the "Switch Shifter" plugin in compiz fusion (Super+Tab), but now the tab key just works on it's own. I tested several different "Super+____" shortcuts, but they didn't work either.

    Any ideas? This is sort of a strange thing happenin' here.

  2. #2
    LinuxManMikeC Guest
    Check your compiz settings? Maybe it got reset by an update or something. Or maybe your computer just doesn't like you using those sorts of vulgar keystrokes on it.

  3. #3
    Join Date
    Nov 2007
    Posts
    198
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Everything looks fine and dandy in the settings manager. Could it be a problem with gnome or xorg.conf? In the meantime, I'll try to stick away from any vulgarity.

  4. #4
    scottro's Avatar
    scottro is offline Retired Community Manager -- Banned from Texas by popular demand.
    Join Date
    Sep 2007
    Location
    NYC
    Posts
    8,120
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I think it's a Linux thing, or xorg thing. I don't recollect it happening to me in the BSDs, but I could be wrong about that.

    I've found the easiest thing to do is create a $HOME/.xmodmaprc file

    keycode 115 = Super_L
    add Mod4 = Super_L

    Then

    xmodmap ~/.xmodmaprc

    This usually fixes it for me. Note that I've found this necessary even when typing
    xmodmap

    shows me that Super_L is mapped to Mod4. As the fix is so easy, I've not researched it further. It has happened to me, however, in several different distributions of Linux with various window managers.

  5. #5
    Join Date
    Nov 2007
    Posts
    198
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well, thanks for the tip! I appreciate that.

    Not that I'm against a "bandaid" solution (I'm going to use that tip anyways), but what's going on here (output of xmodmap)?

    Code:
    xmodmap:  up to 3 keys per modifier, (keycodes in parentheses):
    
    shift       Shift_L (0x32),  Shift_R (0x3e)
    lock        Caps_Lock (0x42)
    control     Control_L (0x25),  Control_R (0x6d)
    mod1        Alt_L (0x40),  Alt_R (0x71),  Meta_L (0x9c)
    mod2        Num_Lock (0x4d)
    mod3      
    mod4        Super_L (0x7f),  Hyper_L (0x80)
    mod5        Mode_switch (0x5d),  ISO_Level3_Shift (0x7c)
    Doesn't everything seem to be in order to you?

  6. #6
    Join Date
    Nov 2007
    Posts
    198
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Actually, just running the command "xmodmap" seemed to work!

    I was playing around in my "services" preferences earlier... I wonder if I mistakenly took it off of the startup list?

    At any rate, I think the solution has been found! Thanks again for your help guys!

    EDIT:
    I just tried to log out and log back in again, and it stopped working again! Strange!!

    I typed in xmodmap just like before, and it didn't work this time around... I guess something else happened? I'll keep ya posted.
    Last edited by SendDerek; 10th December 2007 at 07:14 AM.

  7. #7
    Join Date
    Nov 2007
    Posts
    198
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Okay... so I think I found out a little more.

    While noticing that "mod4's" keycode was "Super_L (0x7f)" or in decimal value of Super_L(715), I also noticed that when running the "xev" command, my super key is actually showing up as "Super_L(115)". So, right now, I'm trying to figure out a way to edit it without having to create that separate file...

  8. #8
    Join Date
    Nov 2007
    Posts
    198
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Okay, well, I used scottro's hint, and so far so good. Thanks for the tip again!

  9. #9
    scottro's Avatar
    scottro is offline Retired Community Manager -- Banned from Texas by popular demand.
    Join Date
    Sep 2007
    Location
    NYC
    Posts
    8,120
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    As I said, even if xmodmap is showing the correct settings (and yes, the Super_L key is 115 on most 104 and 105 keyboards) it seems to sporadically quit working.

    This isn't limited to Fedora or Gnome (or KDE). I've run into it on several distributions, usually using fluxbox. If it happens more than once, I put in a fluxbox combo key shortcut to run the xmodap ~/.xmodmaprc that doesn't require the mod4 key, like ctl+mod1 x. (Mod1 is the alt key.)

    It's probably some obscure Linux input-xf86-keyboard problem, but it doesn't bother me enough to file a bug report, especially as it's not always reproducible.

  10. #10
    Join Date
    Oct 2007
    Location
    Decatur, IL
    Age
    49
    Posts
    110
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    scottro, thanks for this. Helped me out.
    Fedora 9 (Sulphur) - Gnome
    HP DV6910US Laptop
    Linux Registered User # 449097

  11. #11
    scottro's Avatar
    scottro is offline Retired Community Manager -- Banned from Texas by popular demand.
    Join Date
    Sep 2007
    Location
    NYC
    Posts
    8,120
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Glad it was useful. Thanks for the thank you.

  12. #12
    Join Date
    Nov 2007
    Location
    above the earth under the heaven
    Age
    31
    Posts
    15
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    can someone help me..
    where to create and how to create file below.. (like scottro said)
    i've found the easiest thing to do is create a $HOME/.xmodmaprc file

    keycode 115 = Super_L
    add Mod4 = Super_L

    Then

    xmodmap ~/.xmodmaprc
    and what to be add to that file..

  13. #13
    Join Date
    Oct 2007
    Location
    Decatur, IL
    Age
    49
    Posts
    110
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by alexandria
    can someone help me..
    where to create and how to create file below.. (like scottro said)


    and what to be add to that file..
    Open a terminal as a user, not root and enter

    Code:
    gedit .xmodmaprc
    This will open a text editor. In the text document enter

    Code:
    keycode 115 = Super_L
    add Mod4 = Super_L
    Save the document.

    Then back in the terminal enter

    Code:
    xmodmap ~/.xmodmaprc
    The next time you boot your computer you will have a small window that asks what modmap you want to load. click the one listed and click add. Nothing more to do after that.
    Fedora 9 (Sulphur) - Gnome
    HP DV6910US Laptop
    Linux Registered User # 449097

  14. #14
    Join Date
    Nov 2007
    Location
    above the earth under the heaven
    Age
    31
    Posts
    15
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    thanks..it was so helpful

Similar Threads

  1. Super/Win key not working with Fedora 11
    By apocalypse in forum Using Fedora
    Replies: 17
    Last Post: 8th December 2010, 06:38 PM
  2. Super/Win key not working with Fedora 11
    By apocalypse in forum Using Fedora
    Replies: 0
    Last Post: 8th October 2009, 06:51 PM
  3. Super| WIndows Key not working properly
    By realvz in forum Using Fedora
    Replies: 4
    Last Post: 25th February 2008, 03:59 AM
  4. FC6: Laptop is super hot and super fast how do I scale my speed
    By DMD in forum EOL (End Of Life) Versions
    Replies: 4
    Last Post: 29th October 2006, 07:15 PM
  5. ati stopped working
    By niko123456 in forum Hardware & Laptops
    Replies: 4
    Last Post: 5th August 2006, 02:23 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •