Kernel and livna conflict
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 24
  1. #1
    Join Date
    Feb 2005
    Posts
    98
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Kernel and livna conflict

    I run yum update yesterday and today I decided to install kmod-nvidia but I'm getting "Error: Missing Dependency: kernel-i686 = 2.6.23.1-49.fc8 is needed by package kmod-nvidia-2.6.23.1-49.fc8"

    I my current kernel is 2.6.23.8.63. I'm I out of luck.

  2. #2
    Join Date
    Nov 2004
    Location
    MT USA
    Posts
    1,142
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    same problem.... Just waiting for a fix ...

    Also have this problem with firefox.

    ================================================== ===========================
    Package Arch Version Repository Size
    ================================================== ===========================
    Updating:
    firefox i386 2.0.0.10-2.fc8 updates 21 M
    Updating for dependencies:
    firefox-devel i386 2.0.0.10-2.fc8 updates 3.5 M

    Transaction Summary
    ================================================== ===========================
    Install 0 Package(s)
    Update 2 Package(s)
    Remove 0 Package(s)

    Total download size: 25 M
    Is this ok [y/N]: y
    Downloading Packages:
    Running rpm_check_debug
    ERROR with rpm_check_debug vs depsolve:
    Package devhelp needs gecko-libs = 1.8.1.9, this is not available.
    Package yelp needs gecko-libs = 1.8.1.9, this is not available.
    Complete!
    Last edited by rclark; 5th December 2007 at 04:20 PM.

  3. #3
    Join Date
    Jul 2007
    Location
    Indiana USA
    Posts
    1,715
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    try:
    Code:
    yum install kmod-nvidia --enablerepo=livna-testing
    The answer to all of lifes questions are buried somewhere in the Google search engine.

    Code:
    [Stephen@localhost ~]$ whatis this?
    this?: nothing appropriate

  4. #4
    leigh123linux Guest
    Try


    su
    rpm -e --nodeps kmod-nvidia-2.6.23.1-49.fc8
    yum update

  5. #5
    Join Date
    Feb 2005
    Posts
    98
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by leigh123@linux
    Try


    su
    rpm -e --nodeps kmod-nvidia-2.6.23.1-49.fc8
    yum update

    I get:
    "error: package kmod-nvidia-2.6.23.1-49.fc8 is not installed"

  6. #6
    Join Date
    Feb 2005
    Posts
    98
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by FriedChips
    try:
    Code:
    yum install kmod-nvidia --enablerepo=livna-testing

    Same error:
    "Error: Missing Dependency: kernel-i686 = 2.6.23.1-49.fc8 is needed by package kmod-nvidia-2.6.23.1-49.fc8"

  7. #7
    leigh123linux Guest
    Quote Originally Posted by benso37
    I get:
    "error: package kmod-nvidia-2.6.23.1-49.fc8 is not installed"
    Ok try


    Code:
    su
    wget http://livna-dl.reloumirrors.net/fedora/8/i386/kmod-nvidia-2.6.23.8-63.fc8-100.14.19-19.lvn8.i686.rpm http://livna-dl.reloumirrors.net/fedora/8/i386/kmod-nvidia-100.14.19-19.lvn8.i686.rpm
    rpm -U kmod-nvidia-2.6.23.8-63.fc8-100.14.19-19.lvn8.i686.rpm kmod-nvidia-100.14.19-19.lvn8.i686.rpm
    Last edited by leigh123linux; 5th December 2007 at 04:50 PM.

  8. #8
    JN4OldSchool is offline "Sean The Terrible" -- The forum(er) Vista® rep
    Join Date
    Nov 2005
    Posts
    8,819
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    yum install yumex

    go to the install tab, find the kmod-nvidia package for the latest, 63 kernel and check the box. Process. If the kernel is not already installed it will be installed as a dep. This should break the log jam.

  9. #9
    Join Date
    Apr 2007
    Posts
    43
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I had a similar problem. Prior to updating the kernel to 2.6.23.8.XX, I already had kmod-nvidia installed. It said there was an update to it yesterday, but I couldn't update because of a kernel dependency problem. Now that there is a new kernel, I decided the best thing to do was remove the kmod-nvidia package that it was having a problem with (which, in effect, removed the kmod-nvidia package), and then re-installed kmod-nvidia. This, in effect, installed the new kernel as well as an associated X11-nvidia driver. (I think it removed an X11 nvidia driver when it removed kmod-nvidia, so that may be part of the package.)

    These two incidents sound a little different, from the way you described your scenario, but they do sound related. So maybe that will help.

    In retrospect, however, I must warn you that after I managed to update both of them, xv doesn't seem to work in any of my video applications I've tested thus far. (I've only really tested vlc and mplayer. I'm currently using either gl or x11, where applicable, instead.)

  10. #10
    Join Date
    Jul 2005
    Age
    60
    Posts
    1,218
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Add kmod-nvidia-100.14.19-19 to the packages to install via rpm and things go well. Doing this I was able to upgrade to 8.63 without doing anything to my existing kmod-nvidia setup.

  11. #11
    Join Date
    Feb 2005
    Posts
    98
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by leigh123@linux
    Ok try


    Code:
    su
    wget http://livna-dl.reloumirrors.net/fedora/8/i386/kmod-nvidia-2.6.23.8-63.fc8-100.14.19-19.lvn8.i686.rpm
    rpm -U kmod-nvidia-2.6.23.8-63.fc8-100.14.19-19.lvn8.i686.rpm

    This gives another error:

    "error: Failed dependencies:
    kmod-nvidia >= 100.14.19-19.lvn8 is needed by kmod-nvidia-2.6.23.8-63.fc8-100.14.19-19.lvn8.i686
    nvidia-kmod-common >= 100.14.19 is needed by kmod-nvidia-2.6.23.8-63.fc8-100.14.19-19.lvn8.i686"


    I think I'm getting close though...Now I just need to find 100.14.19-19. yum can't find it.

  12. #12
    leigh123linux Guest
    Quote Originally Posted by benso37
    This gives another error:

    "error: Failed dependencies:
    kmod-nvidia >= 100.14.19-19.lvn8 is needed by kmod-nvidia-2.6.23.8-63.fc8-100.14.19-19.lvn8.i686
    nvidia-kmod-common >= 100.14.19 is needed by kmod-nvidia-2.6.23.8-63.fc8-100.14.19-19.lvn8.i686"


    I think I'm getting close though...Now I just need to find 100.14.19-19. yum can't find it.

    try


    Code:
    su
    wget http://livna-dl.reloumirrors.net/fedora/8/i386/kmod-nvidia-2.6.23.8-63.fc8-100.14.19-19.lvn8.i686.rpm http://livna-dl.reloumirrors.net/fedora/8/i386/kmod-nvidia-100.14.19-19.lvn8.i686.rpm
    rpm -U kmod-nvidia-2.6.23.8-63.fc8-100.14.19-19.lvn8.i686.rpm kmod-nvidia-100.14.19-19.lvn8.i686.rpm

  13. #13
    Join Date
    Feb 2005
    Posts
    98
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by leigh123@linux
    try


    Code:
    su
    wget http://livna-dl.reloumirrors.net/fedora/8/i386/kmod-nvidia-2.6.23.8-63.fc8-100.14.19-19.lvn8.i686.rpm http://livna-dl.reloumirrors.net/fedora/8/i386/kmod-nvidia-100.14.19-19.lvn8.i686.rpm
    rpm -U kmod-nvidia-2.6.23.8-63.fc8-100.14.19-19.lvn8.i686.rpm kmod-nvidia-100.14.19-19.lvn8.i686.rpm

    Well I got: error: Failed dependencies:
    nvidia-kmod-common >= 100.14.19 is needed by kmod-nvidia-2.6.23.8-63.fc8-100.14.19-19.lvn8.i686


    So I decided to install "kmod-nvidia-100.14.19-19.lvn8.i686.rpm" first and got the following error.
    "error: Failed dependencies:
    kmod-nvidia-2.6.23.8-63.fc8 is needed by kmod-nvidia-100.14.19-19.lvn8.i686"

    I can't win today.

  14. #14
    Join Date
    Feb 2005
    Posts
    98
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Any other ideas or should I wait it out? Will there ever be a fix...I hope I'm not the only one with this problem.

  15. #15
    JN4OldSchool is offline "Sean The Terrible" -- The forum(er) Vista® rep
    Join Date
    Nov 2005
    Posts
    8,819
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I gave you an easy, GUI way to fix it. Others have told you other ways around this. I am not in the habit of answering twice. I seriously suggest you install yumex so you can see what you are doing. Then just uninstall all the kmod nvidia stuff then install the latest. The kernel should be installed with it. Everyone has this problem, there have only been 1,000 or so threads on it the last two days now. Not just nvidia but other kmods too. It is a kernel problem. You need to work through this, it WILL work.

Page 1 of 2 1 2 LastLast

Similar Threads

  1. yum kernel conflict error
    By doobie in forum Using Fedora
    Replies: 5
    Last Post: 7th March 2006, 10:11 AM
  2. kernel conflict...
    By Zigzagcom in forum Using Fedora
    Replies: 8
    Last Post: 3rd February 2006, 07:47 AM
  3. .conflict between kernel-smp and e2fsprogs
    By sde in forum Using Fedora
    Replies: 3
    Last Post: 8th August 2005, 10:06 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •