"Desktop Effects Could not be Enable" error msg
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    neonflx Guest

    "Desktop Effects Could not be Enable" error msg

    i installed FC8 and compiz is installed when i go to the KDE menu - Settings - Desktop effects and try to enable it the following message appears on the top left corner of the screen


    "Desktop Effects Could not be Enable" i am using an Nvidia 7600 GT PCI-E with a dual core 6850 and 2 gigs of ram, how can i enable compiz, thx

  2. #2
    Join Date
    Apr 2005
    Location
    Littleton, CO
    Age
    33
    Posts
    2,856
    If you
    Code:
    glxinfo
    Does direct rendering say yes or no? If it is no, then that's your problem.
    S.C.O.U.R.G.E. Heroes of lesser renown, contributor.

  3. #3
    neonflx Guest
    it says "no" do i need to install something or edit the xorg file?


    i just lloke at my xorg.conf



    it is pretty empty just a couple of lines and is using nv instead of nvidia for driver
    Last edited by neonflx; 18th November 2007 at 06:12 PM.

  4. #4
    Join Date
    Apr 2005
    Location
    Littleton, CO
    Age
    33
    Posts
    2,856
    You need to install the nvidia linux drive. Assuming you aren't using freshrpms/rpmforge/atrpms this is the easiest way to do that.

    EDIT: I'm also assuming your using fedora 8. If you aren't change the number 8 in the second command to reflect your fedora version.
    Code:
    su
    rpm -ivh http://rpm.livna.org/livna-release-8.rpm
    yum -y update
    yum -y install kmod-nvidia xorg-x11-drv-nvidia-libs-32bit
    You enter those commands in a terminal, or in kde I think they call it a konsole. After you run the "su" command, then you will need to enter your root password. When you are all done, reboot the system. Then try compiz again.

    EDIT: Installing the 32bit libs isn't strictly necessary, but it is a good idea. Especially if you are planning on using wine.
    Last edited by leadgolem; 18th November 2007 at 06:56 PM.
    S.C.O.U.R.G.E. Heroes of lesser renown, contributor.

  5. #5
    neonflx Guest
    thanks that did the trick it is working good now ,thanks

Similar Threads

  1. Click "Enable Desktop Effects" = log out
    By tdcrooks in forum Using Fedora
    Replies: 6
    Last Post: 14th September 2009, 06:19 AM
  2. Cannot enable "desktop effects" with ATI drivers
    By fcassia in forum Using Fedora
    Replies: 0
    Last Post: 5th January 2009, 07:21 PM
  3. Only "Desktop Effects" --No CCSM effects or Emerald (HELP!)
    By freakystylie in forum Using Fedora
    Replies: 6
    Last Post: 16th July 2008, 12:45 AM
  4. another "Can not enable desktop-effects" question...
    By whoaminot in forum Using Fedora
    Replies: 4
    Last Post: 28th February 2008, 02:01 AM
  5. Help!! I cannot enable "Desktop Effects"
    By creeping death in forum Using Fedora
    Replies: 20
    Last Post: 26th February 2008, 01:20 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •