FedoraForum.org - Fedora Support Forums and Community
Page 1 of 7 1 2 3 ... LastLast
Results 1 to 15 of 103
  1. #1
    Join Date
    May 2006
    Posts
    70

    Fedora x86_64 on a Lenovo T61 notes and Driver Installation Guide

    Fingerprinter reader, sound and and bluetooth, wireless and suspend are all working. I'm pretty impressed with the performance of the 2.4 proc, 7200 rpm drive and 4GB of ram. I kicked 25 simultaneous, avi files (Season 2 of Star Trek Enterprise) and it didn't miss a beat. 25 video streams spread across 4 desktops.

    I'm using the native linux drivers from intellinuxwireless.org to run the 4965. There is also a
    modified intel_drv.so you'll need to get rid of some the screen fuzzyness as well as a patch that need to applied to alsa to get sound working. To get wireless working you'll need to download the vanilla kernel source, apply the mac80211 patch and compile it. I have a .config that sets all the options needed to get the T61 up and running under 2.6.22. This machine looks very, very promising.

    Below is what I did to get the various devices working properly...

    ========================== Wireless ===========================

    Below is a detailed writeup on getting wireless working using the Intel opensource drivers. It's a bit long winded but will get wireless working for you the correct way. The kernel recompile has the added benefit of enabling some of the optimizations for the Core Duo 2 processor that linux offers that aren't turned on in supplied Fedora 7 linux kernel. These instructions will also work for the 3945 card as well. Just substitute "3945" everywhere that you see 4965.

    First of all, if you have the mac80211 or any of the iwlwifi packages installed, remove them

    yum remove iwlwifi iwlwifi-kmdl mac80211-kmdl mac80211

    Next pull down the latest source from kernel.org. I used 2.6.22

    mv linux-2.6.22.tar.bz2 /usr/src/kernels/

    tar jxvf linux-2.6.22.tar.bz2

    Assuming that you have a Lenovo T61 or any other laptop with a dual core 2 processor, you can use the attached kernel config called config-premac80211.conf. Assuming that you're going to use it, copy it to /usr/src/kernels/linux-2.6.22/ Be sure to rename it .config and then as root run

    make oldconfig

    make

    make modules_install

    make install

    This will generate the Makefile for the kernel using the supplied config, compile the kernel and modules and finally install it. It adds an entry for the kernel in your grub.conf

    Reboot your machine select the newly compiled kernel when the grub menu appears.

    Obtain the latest builds of the mac80211, iwlwifi, and 4965 microcode/firmware tarballs from http://intellinuxwireless.org/?p=mac80211&n=Downloads

    I used the 9.0.2 build of mac80211 and the 0.1.2 build of the iwlwifi driver. Also be sure to get the firmware for the 4965 wireless card. With those downloaded, the procedure is as follows

    tar zxvf mac80211-9.0.2.tgz

    cd mac80211-9.0.2
    sudo make patch_kernel

    This applies the patched mac80211 stack to the kernel. You'll next want to goto the directory containing the kernel source /usr/src/kernels/linux-2.6.22 and rebuild your kernel again using the following procedure. The following commands are to be performed as the root user.

    cd /usr/src/kernels/linux-2.6.22
    make mrproper

    Now copy the other config file that I've upload (config-post-mac80211patch.conf) to /usr/src/kernels/linux-2.6.22. rename it to .config Now rebuild your kernel using the same procedure used earlier

    make oldconfig

    make

    make modules_install

    make install

    Reboot your machine and select the 2.6.22 kernel. We're almost done, All that's left now is to untar and copy the fireware to the correct location and compile the iwlwifi kernel module. The procedure that I used is as follows.

    tar zxvf iwlwifi-4965-ucode-4.44.15.tgz

    sudo cp iwlwifi-4965-ucode-4.44.15/iwlwifi-4965.ucode /lib/firmware/

    sudo chmod +x /lib/firmware/iwlwifi-4965.ucode

    Now for the iwlwifi driver...

    tar zxvf iwlwifi-0.1.2.tgz

    cd iwlwifi-0.1.2

    sudo su

    make

    make install

    modprobe iwl4965

    If all of that ran without returning errors, you're all set. If you run /sbin/iwconfig you should see wlan0 listed there. From this point you'll want to do some clean up work like adding a line to /etc/modprobe.conf that looks like this

    alias wlan0 iwl4965

    You can now use NetworkManager or the wireless config tool of your choice to connect to your wireless network. I use NetworkManager and did the following to enable it

    Adds services to runlevels 2, 3 and 5

    chkconfig NetworkManager on
    chkconfig NetworkManagerDispatcher on

    Starts the NetworkManager and NetworkManagerDispatcher services

    sudo /etc/init.d/NetworkManager start
    sudo /etc/init.d/NetworkManagerDispatcher start

    This information is provided as is and without guarantee. Your results may be different to mine, but I found this to be the least painful way to use the native drivers. I invite you questions or comments. Please let me know where I was unclear or left out a step.


    ======================== Patch Work ==============================

    + Intel Video Driver +

    To get rid of some of screen fuzzyness that you experience using the standard intel driver on the T61, you'll need to modify the i830_lvds.c file and recompile the driver. The change that needs to be made is documented here
    ' I took the liberty of making the change for you and uploaded the patched tarball. Important: before compiling the modified intel driver you need to ensure that you have the xorg server development sdk package installed. Just run


    sudo yum install xorg-x11-server-sdk
    tar xzvf xf86-video-intel-2.0.0.tar.gz
    cd xf86-video-intel-2.0.0
    ./configure && make

    Once that's complete, you'll want to copy the patched driver from src/.libs/intel_drv.so to the directory where your xorg video drivers are kept. On my system it's under /usr/lib64/xorg/modules/drivers/

    If you're running a 32 bit kernel it'll be /usr/lib/xorg/modules/drivers/ Once you copy the updated driver there and restart xorg, you should have a clear,sharp display.

    One thing that you might run into (I did) is that GDM doesn't use the entire screen. Neither does gnome. This is because the TV output is enabled. You can disable it by adding the following commands to your xorg.conf


    Section "Monitor"
    Identifier "TVOutput"
    Option "Disable" "true"
    EndSection


    and then in the Device Section add the following

    Option "monitor-TV" "TVOutput"

    I've uploaded my complete xorg.conf so you can just drop it in if that's easier for you.

    Composite Desktops

    It is a possible to get the composite desktop (Compiz and Beryl) working under Fedora 7. If you're up for some more driver hacking, then the information posted at http://intellinuxgraphics.org/install.html will get you going. You can skip the first part concerning compiling the intel driver because we did that earlier.

    So you'll want to pull drm and mesa which you can get from http://intellinuxgraphics.org/download.html

    Follow the instructions there as they're pretty clear. The only thing that you may have a bit of trouble finding is where to copy the compiled mesa shared objects. They go under /usr/lib/dri assuming you're 32bit. It'll be /usr/lib64/dir for 64 bit users. If you follow those instructions, you'll be rewarded with the ability to run Compiz Fusion with little issue. Assuming you're running Fedora you can get the repo containing the Compiz Fusion packages here http://devel.foss.org.my/~kagesenshi...agesenshi.repo

    Follow the instructions that he writes up on his site at this link http://blog.kagesenshi.org/2007/06/c...-fedora-7.html and you'll be enjoying X in all it's 3D goodness in no time.


    + Sound +

    Similar to the Intel patch, changes need to be made to the alsa driver package to get sound working. The file in question is alsa-driver-1.0.14/alsa-kernel/pci/hda/patch_analog.c The changes that need to be made are documented here
    I've already made the changes to the uploaded patch_analog.c file.

    You'll need to download the alsa driver tarball from here and then execute the following commands.

    tar jxvf alsa-driver-1.0.14.tar.gz
    tar zxvf patch_analog.c.tar.gz
    cd alsa-driver-1.0.14
    cp ../patch_analog.c alsa-driver-1.0.14/alsa-kernel/pci/hda/
    ./configure && make
    sudo make install

    This will extract and compile the alsa driver and install them. You'll need to make a slight change to your /etc/modprobe.conf file.

    The line that current looks like

    options snd-hda-intel index=0

    needs to be changed so that it looks like...

    options snd-hda-intel index=0 model=thinkpad

    Reboot your machine and then open Gnome Volume Control. Click on the the "Switches" tab and then check Headphone and Speaker. At this point you should have working sound.


    + Suspend +

    Due to post length constraints, the suspend instructions have been added to a new post at the following link.

    http://forums.fedoraforum.org/showthread.php?t=160325

    ...
    Attached Files Attached Files
    Last edited by ciphermonk; 20th July 2007 at 04:50 PM. Reason: Updated for mac80211 version 9.0.2 and iwlwifi version 0.1.2

  2. #2
    Join Date
    Jun 2007
    Posts
    38
    I tried to install FC7 on a brand new T61 and the install fails because it cannot find an appropriate driver for the SATA drive. How did you get past this?

  3. #3
    Join Date
    May 2006
    Posts
    70
    In the BIOS, change the Hard drive mode from AHCI to "Compatibility" and away you go. If you decide to run x86_64, I'll upload my patched intel_drv.so file that you'll need to get rid of some of the screen fuzzyness that you'll get due to a bug in the current intel driver. Feel free to PM or email me at ciphermonk@gmail.com if I can help out in any way. You'll also need a patch to get sound working. I can give you the patched file as well.

  4. #4
    Join Date
    May 2006
    Posts
    70
    Updated to fix a few typos. Also added link to information on getting wireless working..

  5. #5
    Join Date
    Mar 2006
    Posts
    682
    If you get Beryl working with a custom compiled kernel let us know. I have not seen anyone do it. It seems to entail rewriting the spec file for the kmod nvidia source.
    jbkt23

  6. #6
    Join Date
    May 2006
    Posts
    70
    I'm running the Intel X3100 card so I don't believe that the nvidia kernel module will help/hurt with getting Compiz/Beryl running. Not sure as yet what's preventing Compiz from working

  7. #7
    Join Date
    May 2006
    Posts
    70
    Updated to include instructions for getting Compiz and Beryl working...

  8. #8
    Join Date
    Jul 2007
    Posts
    4
    I just installed Fedora 7 on my T61. Looks good. Sound is not working and resolution is low, but I can live with that for now.

    For wireless I have the 802.11abg based on Atheros AR5212. It is not recognized. Does anyone know the steps for getting this particular wireless card working?

  9. #9
    Join Date
    May 2006
    Posts
    70
    Assuming that you have the intel card, you can use the sound and video steps that I posted earlier in this post to get those working. As far as the Atheros card, I'm guessing that you'll have to use madwifi or something along those lines to get wireless working.

  10. #10
    Join Date
    Jul 2007
    Posts
    4
    Ciphermonk,

    I believe it is the intel card, in my order slip from Lenovo it was listed as:

    41W1685 SBB 11ABGWIFI WL LAN USEULAANZ

    I put a SLED 10 evaluation copy on the machine a few days ago and it recognized the wireless as AR5212, so I am guessing that is correct.

    I have never used Madwifi, I have only used ndiswrapper on a previous Thinkpad under Suse 10.2.

    Can you link me to a tutorial or explain? If it will take too much of your time, do not feel obligated.

  11. #11
    Join Date
    May 2006
    Posts
    70
    I'm not sure about that card, but I believe that it's an Atheros based on the part number that you gave. I'm afraid that I honestly don't have much experience when it comes to the Atheros cards. I've primarily worked with Intel and Belkin cards. If you do a search for madwifi though, you should be able to come up with some great guides that others have written on getting it working under linux without ndiswrapper. Although to be honest, if ndiswrapper is working for you and is stable, why change? Unless you want to do wireless packet sniffing I can't see a reason to change what you're doing to goto the madwifi setup.

  12. #12
    Join Date
    Jun 2004
    Location
    oakland, ca
    Posts
    32
    madwifi works with the atheros adapter on the T61. it's kinda annoying working with dev ath0 and wifi0 and ping latency is intermittently bad but it works. i've built modules from latest stable and svn src from 2007-07-01 and haven't had any serious problems with either.

    btw, the latest alsa src is already patched. you can rsync the src via:

    rsync -avz --delete --exclude=.hg* rsync://alsa.alsa-project.org/hg your_directory

    audio output is running fine on my T61 with the internal speakers and headphone out, i haven't tried the microphone in.

    now if only tpb or ibm_acpi hotkeys would work properly for brightness and volume control.. anyone get that working? i'm using aliases to edit /proc/acpi/ibm/* for now but would like to get the buttons functioning like they did on my T42.

  13. #13
    Join Date
    May 2006
    Posts
    70
    decals75: I do have volume control working but not brightness control. You can just use the Gnome keyboard shortcuts to map the keys to be used for volume up, down and mute.

  14. #14
    Join Date
    May 2006
    Posts
    70
    Wireless configuration information along with supporting files added to this post

  15. #15
    Join Date
    Jul 2007
    Posts
    3
    thanks ciphermonk for taking the time to put this all together, it really helps

    also, where did you get the config files:
    (config-post-mac80211patch.conf,config-premac80211.conf) from?

    Were they derived from something else?

    pretty new to linux here...

Page 1 of 7 1 2 3 ... LastLast

Similar Threads

  1. Fedora 11 and Lenovo T500 webcam
    By kerryjcox in forum Hardware & Laptops
    Replies: 3
    Last Post: 12th October 2009, 05:43 PM
  2. problems with Fedora 10 on lenovo T60
    By openlinux in forum Hardware & Laptops
    Replies: 1
    Last Post: 2nd January 2009, 06:06 AM
  3. Fedora 9 in a Lenovo R61I
    By k_crew in forum Using Fedora
    Replies: 4
    Last Post: 6th November 2008, 10:35 PM
  4. Fedora 9 x86_64 on a Lenovo T61 (Heads up South American users)
    By danielito in forum Hardware & Laptops
    Replies: 5
    Last Post: 19th May 2008, 07:34 PM
  5. Fedora 7 on Lenovo N100
    By YevgenyEfter in forum Hardware & Laptops
    Replies: 38
    Last Post: 17th September 2007, 03:22 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •