FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    Join Date
    Jun 2005
    Location
    Washington D.C. area
    Posts
    182

    nfs mount problem: RPC Error: Program not registered

    Hi,

    I'm trying to nfs mount files on my desktop onto my laptop. But when I execute mount, I get:

    Code:
    mount /mnt/Research
    mount: mount to NFS server '128.150.72.58' failed: RPC Error: Program not registered.
    NFS is working on both systems, and I have the firewall and SELinux turned off on both systems. Here's how things are configured.

    Server (IP Address: 128.150.72.58)
    /etc/hosts.allow
    ALL:128.150.73.0/24

    /etc/hosts.deny
    portmap ALL
    lockd: ALL
    mountd: ALL
    rquotad: ALL
    statd: ALL

    /etc/exports
    /home/derek/usr 128.150.73.0/24(rw,insecure,sync,insecure_locks,no_root_squash)
    /home/derek/Data 128.150.73.0/24(rw,sync,insecure,insecure_locks,no_root_squash)
    /mnt/backup 128.150.73.0/24(rw,sync,insecure,insecure_locks,no_root_squash)
    /mnt/backup/music 128.150.73.0/24(rw,sync,insecure,insecure_locks,no_root_squash)

    Client (IP Address: 128.150.73.111)
    /etc/fstab
    128.150.72.58:/home/me/usr /mnt/Research nfs noauto,rw,user 0 0
    128.150.72.58:/home/me/Data /mnt/Data nfs noauto,rw,user 0 0
    128.150.72.58':/mnt/backup /mnt/backup nfs noauto,rw,user 0 0
    128.150.72.58':/mnt/backup/music /mnt/music nfs noauto,rw,user 0 0

    When I run /usr/sbin/rpcinfo -p 128.150.72.58, I get:
    No remote programs registered.

    However, I can see that nfs is running on the server, and I can ssh into the server no problem. My guess is my exports are incorrectly defined...any thoughts out there?
    Last edited by icthy; 25th June 2007 at 07:12 PM. Reason: to clean up the formatting of the post. no content was changed

  2. #2
    Join Date
    Jun 2005
    Location
    Washington D.C. area
    Posts
    182
    Hmm, I changed my netmask from 24 to 255.255.255.0, and it nfs runs fine now. I don't know what the problem was with the previous netmask...it worked before. I'll have to think about it. Case closed

Similar Threads

  1. NFS mounting problems: "RPC Error: Program not registered"
    By tornadof3 in forum Servers & Networking
    Replies: 14
    Last Post: 8th January 2014, 03:37 PM
  2. Replies: 5
    Last Post: 8th March 2009, 03:14 PM
  3. Replies: 9
    Last Post: 11th December 2008, 02:51 AM
  4. Replies: 0
    Last Post: 8th April 2008, 08:51 AM
  5. Program to mount CD!
    By panoramix222000 in forum Using Fedora
    Replies: 8
    Last Post: 12th February 2008, 12:11 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •